Locked out from Vera

I just received a replacement dongle and made an update from 1.0.616 to the Luup version 1.0.979 to be able to backup the data in my old dongle. It all went well, but when I tested things it looks like the scripts I use to control my devices, which uses HTTP commands does not work anymore.
I tried to back off to version 1.0.608 which was the only old one I could find, but now I am stuck with Vera saying “Cannot retrieve user data.”. From here I cannot go anywhere…


  1. How do I get my Vera up and running with version 1.0.616 again? I have tried reset…
  2. In version 1.0.979, will I be able to access Vera through HTTP like “” to switch a device? If not, is there any other way to do this now?

Many thanks for any support.


Things changed in LuaUPnP version. Read: http://wiki.micasaverde.com/index.php/Luup_Scenes_Events and http://wiki.micasaverde.com/index.php/Luup_Requests

You can send a command to a device through Vera or through findvera.com secure service directly by using some URLs in your broswer. Here are some examples:

For switching ON an Appliance Module within your home network you can use:
where you have to modify DeviceNum=5 with your device number and “1” in queue is the parameter you want to set (1=ON, 0=OFF).

Same from findvera.com "
where username and password fields are those from your finvera.com tab ( you should have findvera.com service activated)

Many thanks for your help :slight_smile:
I guess this will solve my scripting problem…but at the moment I cannot try it as my Vera is locked.
After restarting Vera it stops with the message “Cannot retrieve user data.” after the “Data loading” messages etc, and no matter which button I press there is a pop-up window saying “Please wait for data to load.”.
Is there anyway I can get back to where I can install 1.0.616 or 1.0.979 again?

I think that I managed to reload 1.0.979 by following a tip in an old thread:

If you can't get to the web UI, you can manually upgrade the firmware like this:
  1. run “telnet [ip of vera]” from your pc’s command prompt (or use ssh, like putty, if you set a root password)

  2. type:
    cd /tmp
    curl -o firmware.img “http://download.controlmyhouse.net/betafirmware/ftp/wl500gP_Luup-1.0.979.trx
    mtd -r write firmware.img linux

  3. Wait about 4 minutes. Vera will reboot and be at a factory default state. If it doesn’t reboot in 10 minutes, cycle power on Vera

You can reflash the firmware using the following also…

I think that I am back on track again :slight_smile: