Leviton Zone Controller will not control dimmer !?

I cannot get my Leviton VRCZ4-M0Z 4 Button Zone Controller to operate a Leviton Vizia 4R106 1LZ dimmer. I’ve tried two different methods:

  1. I setup a scene in the Vera3 and set a trigger (within the scene) as one of the buttons on the zone controller - nothing happens when I push the button.

  2. I setup two scenes without triggers: one to turn the light on, one to turn it off. Then I go the setup for the controller itself and on the scenes tab I set my “turn on” scene for when the button is turned on; and I set my “turn off” scene for when the button is turned off. When I push the button, the light ramps up to 100% then immediately shuts off. For what it’s worth, when I “run the scene” from the UI - everything works perfectly. I just can’t make it work from the zone controller.

I can control simple on/off loads fine: both outlets and relay contacts.

Any assistance would be greatly appreciated, I have hours into this - it’s driving me crazy!! I’m sure it’s something simple.

Thank you.

I have some additional information. I got it working, but only if I set the light level at anything but 100%.

Any ideas anyone?

Thank you.



Strange. This is with a VRI06, right? I have a zone controller setting several dimmers to full brightness, and it has been working fine. Just tried a VRCS2 and it appeared to work. (Using your method 1.)

So it’s working with 10%, 20%, …, 90%, but not 100%?

jefferwr… Did you ever figure out the solution to your problem (other than setting the brightness level to anything other than 100%)? I am having the exact same issue with a Vera3 (version 1.5.408) and all my dimmers switches (wall as well as plugin).

If you found out a solution, please let me know…

oTI@; I can answer what you asked before

So it's working with 10%, 20%, ..., 90%, but not 100%?

The answer is YES, it works in every level except when you set it to 100%. I have tested Leviton VRCS (2 button and 4 button) as well as VRCZ (4 button). Same behavior in all of them. It will work properly when brightness level is anything other than 100%. Any ideas???


This might be covered by bug 2480.

There is an issue with programming Leviton controllers when the scene uses scene-capable dimmers.

Another thread here on this topic.

Thanks! I have now set this up in a test environment and reproduced it. Looks like the scene is programmed into the dimmer with the wrong level.

As a workaround: on the [tt]Advanced[/tt] tab in the scene editor, remove the [tt]SetLoadLevelTarget[/tt] action (i.e. hit the [tt]Del[/tt] button on it). Then add a [tt]SetTarget[/tt] action with argument [tt]newTargetValue[/tt] set to 1.