Leviton VRCS4/VRCZ4s and UI7 Versions (vera Lite) experience

I have quite a few Leviton switches and scene controllers and thought I would share my experience with them as I am finding some mysterious behaviors setting them up.

VRS15, VRMX10 all include fine and work fine.

VRCS4-M0Z, VRCZ4-L1X, RZCS4, Monster IWC600, VRCZ4-MRZ all are painfull to include, the vera needs to be within 3 feet and sometimes require multiple tries before they include properly. Expecially the MRZ which need to include the local load as a second device.

So far the VRE06 is the only one which does not include correctly always hanging at waiting for manufacturing information during the configuration process.

Now setting user association for the scene controllers is where all the mystery comes about:
On 7.0.5, Every time I attempt to set user association to the scene controllers, the vera does a reset Zwave network. I initially saw it occur and display “Iphone locator: Resetting Zwave network”. The annoyance with this reset is that it wipes out all the virtual devices (created by apps or manually created i.e Vision temperature sensor associated with the motion sensor or multiple sensors for the Aeon 4in1) forcing me to revert using a backup. The way around this was to delete the “iphone locator” plug-in and it worked.
On 7.0.6, this bug disappeared making setting user associations much easier
On 7.0.7, It won’t allow me to set user associations unless something is written in the multi association field. I have no idea what this field is for. The user association device list then shows for example “100.xx” if I entered xx in the association field and the association fails.

The conclusion is that I had to switch between firmware versions in order to set user associations: Using 7.0.6 and then downgrade and restore on 7.0.5.

Another strange behavior is that while I can associate Cooper dimmers (RF9501), Leviton and GE switches and dimmers and Linear relays to the leviton scene controllers (all of theme seem to behave the same way) some devices only work one way:
The VRMX10 and a GE Zwave receptacle only has the ability to be turned off. Even using a scene associated to the button to turn it on through the vera sometimes does not work but turning off always work. I am having to create a scene and user association for these devices.
The only devices I have found to associate perfectly are the GE switches, Cooper dimmers, GE plug in dimmers and Linear Relay. It is a paradox for the Leviton switches to have such problems with the Leviton scene controllers.

I want to use direct association to limit response time so the signal does not need to go through the Vera but it seems very difficult to do for all devices.


Update with 7.0.8:

Seems many things were fixed or at least got a work around. My VRE06 works now. During the inclusion process it still hands at Wait for Manufacturer info in spite of having already gotten it but after a few retries it gives up and shows the device to have been configured correctly.
I am now able to run my device inclusions again without the dreadful reset Z-wave network.
I have not tested instant status on all devices yet but it is all much better than before already.

The only issue which remains is that my Leviton dimmers (RZM10, VRMX1, VRE06) when used in direct association cannot be turned on through the association to the Leviton scene or zone controllers. My cooper and GE dimmers can. Very strange. The association works because I am able to dim up and down and turn the off dimmer off with the controller but I can’t turn it on. Not even through a scene. Very odd…

I have been trying to include a VRCS2-MKZ for days with no look. Sometimes I almost get it to work. I want to use one button for the local load and one button to run a scene, any advice. To include, I pressed both buttons and waited for the amber light, after about 10 secs. my veralite include light goes off and stays off. The VRCS2 flashes and it is included. I cannot, however control the local load. Is there a special procedure for this?

Your best bet is probably to set an association for the button in the scene controller to the device ID of the load button. If you have the VRCS2 included correctly in Vera, you should have one scene controller and 2 on/off switches. Get the device # of the on/off switch you want to control and then go into the scene controller’s Device options and add a group ID (1 for button one or 2 for button two) and set it to the device # of the on/off switch you want to control. This direct association has worked the best for me. You can then include the other on/off switch in a scene.

With the units with a local load I have observed 2 different behaviors during the inclusion:
Sometimes it includes both sequentially without having to do anything: After you put the vera in inclusion mode, do exactly what you did to get the VRCS2 in inclusion mode. The vera will find the scene controller. The VRCS2 should not turn off yet. The amber light should remain on. Wait. then the vera will include the local load too. The vera does need to be within 3 feed of the switch during this process.
The second way I have observed it is: After the scene controller is added, the VRCS2 amber light should still be flashing and Vera pops a screen asking you to name it: skip it for now. Go to your device screen and add device again without touching the VRCS2. The local load should then be added.

After both devices show up on your vera, you can go set direct associations from the device option screen of the scene controller. Mine worked like a charm. With the Vera, unlike what the Leviton manual says, it does not automatically assign the first button to the local load. You have to do it yourself.