Leviton VRCS2 is there a final verdict how to add to vera3 ui5

I had a system installed and programmed using control think. Everything was programmed and working flawlessly. I told the customer about Vera and he liked the idea of iPhone control so I thought it would be an easy swap, transfer control for think essentials to Vera. NOPE. I figured since it was a fairly small network that I could reprogram it pretty quick. So I reset all the switches back to factory and started the include process. The one switch that refuses to operate correctly is the vrcs2.
As mentioned in other posts, the switch operates fine controlling the local load but once I learn it into Vera the local load doesn’t operate correctly. I can run all the scenes that are programmed to the switch fine through the dashboard, and everything turns on and off as programmed but those same scenes assigned to the switch for local control don’t click like they do when reset to factory.

I read in a post that learning the switch back into a remote first and then transfer control back to vera could be a solution, in my case I’d be using control think and not the leviton remote. Do I open control think as a new project and add just this one switch/controller? Hopefully there’s an easier solution !!!

Is the switch successfully included in vera? Or does the switch not want to include?

  • Garrett

Do you have more than one scene, triggered from a button push on the VRCS2? If so, if you enable just the scene that has the local load, does it work?

(I’m running the straightforward button-1-controls-local-load-1-only, and button-2-controls-local-load-2-only scenes and that works.)

The switch was configured through control think as follows. 2 zones, front lighting tied into local load of Vrc top switch. Bottom switch programmed turning on both local load front coach lights and side coach lights controlled by a separate leviton switch. It worked flawlessly.

In vera it shows 2 switches (light bulb icon) and 1X 2 button scene controller. They are controlled fine through the scenes assigned to the switches in ui5 but not on the local switch itself.

I also have a 4 scene switch that controls the same 2 zones of lighting and I assume the led is staying on all the time on it because it’s not communicating correctly to the vrc2 switch.

Hope I answered the question asked to me correctly


I returned to the house today and opened up UI5 to try to figure out what happened yesterday. Awkwardly, the 2 switches and scene controller were
there and when I opened them to verify the scenes were attached to the
scene controller correctly, there was nothing there. So I attached the scenes
to the VRC2 again, 2 on and 2 off scenes, one for each button, and it worked correctly.

One thing that I didn’t mention in the original post was that I have 2 veras installed in the home, since it’s so big, one on the east side controlling 80%
of the z wave and one on the west side where this switch was installed.
It was the only switch on the vera at the time and I had this Vera
tied into the other vera via the “Add UPNP Device” method. Opening up the master
Vera (east) it showed the west vera devices (VRC2 = 2 switches & 1 scene switch).
I programmed the west vera scenes through the East Vera. What I did differently today which I didn’t do yesterday was to “ADD UPNP DEVICE” on the west unit as well this way both Veras could see all the devices. Scenes created on either Vera could be utilized on any device. What was weird was that the east vera added the west units devices originally but didn’t control them locally on the switch.
But after tieing both units together via UPNP it all worked. I didn’t know that I had to perform the add UPNP procedure on both units since I didn’t have to do that at my house, creating all scenes off of the master Vera worked here.
I really don’t know what I did to fix the issue but it all worked the way it originally did so I stopped while i was ahead of the game. Also the 4 scene switch LED is now reporting correctly the status of the lights tied into the scene for that switch.

Good; nice. And yeah, that was an interesting detail you added. :slight_smile:

For clarification, did none of the lighting get controlled when you pressed the buttons locally on the VRCS2, or just not the local loads? (I.e., for the bottom switch, did nothing happen, or only the side coach lights would be controlled, but not the front coach light on the load load?)

It’s like the scene switch was dead, nothing happened at all, once I told BOTH vera2 units to search for UPNP devices and added them to each other, that then gave me the flexibility to readd
the scenes to the 2 switches and one scene controller to tell it what I wanted it to do.
The only time the scene switch worked prior to that was when you wiped it out to factory reset.
Of course that was for local load control of 1 switched load only (top button), there wasn’t a 2nd load.

Thanks for the feedback. Sounds like the scene configuration never made it to the devices.

I agree, I actually left the house and came back the next day with a fresh mind. The scenes themselves worked fine through iVera, but not internally so you are probably correct that the devices didn’t receive all the commands in the home. Vera, she too just needed time to think !!!