Kwikset 914 + Vera 3 w/UI7, can't program PIN codes

What works:

As stated in the subject, I have a Vera 3 with UI7. I just installed a Kwikset 914 deadbolt. The physical installation is excellent. The deadbolt turns smoothly. The action is almost silky.

I successfully paired the device with my controller. I can see the lock status. When I manually lock or unlock the door, the status updates quickly in the controller. I can remotely open and close the deadbolt from the controller.

What doesn’t work:
While I can program PIN codes in the UI, they don’t seem to take effect on the deadbolt. The UI sends the messages indicating that it is configuring the device… but when it appears to be complete the codes do not work on the deadbolt. I can manually program codes into the deadbolt, but they do not appears in the UI on the controller.

Does anyone have any experience with this issue? I have emailed Vera for support as it appears everything is working properly from the Kwikset side.

I’m having the exact same issue. The Kwikset 914 lock operates smoothly and can be controlled through Vera and by codes physically programmed into the unit.

Pin codes can be added through the Vera interface and appear in the lu_sdata (http://veraip:3480/data_request?id=lu_sdata&output_format=xml); however, these codes are not recognized by the 914 lock when you try to enter, and when these codes are attempted, Vera sends me a notification of a bad pin entered. It is as if these codes were never programmed. - this is not correct (see update below).

Any thoughts?


When I remove ALL of the pin codes from the 914 lock through Vera, the lock button on the front panel of the lock will not lock the door. Consulting the Kwikset manual (, apparently this is because “If no user codes are programmed, the Lock button will be disabled.”

Once a pin has been entered (through Vera), the lock button works, which indicates that the lock is aware of the existance of the pin codes being programmed or removed, but is simply not acknowledging the pins on the keypad.

I have a couple of Kwikset 910s - same problem. The web interface only shows the single PIN I coded on the lock at install. Adding a new PIN appears to work - I can use the new PIN on the locks with no problem, but the new PIN does not show up in the PIN list on the web interface. And the Vera iOS app doesn’t have a any provision for showing PINs at all.

I am not having this issue…although I did NOT program any pins using the physical lock itself. You can try unpairing the lock, factory reset the lock, and then re-pair the lock with vera.

The smartphone apps do not show pin details…only basic controls for operation. However, you can go to from your phone web browser. It takes longer (and the interface is slower), but you basically get all the functionality that you get from your PC browser.

I am having a different issue with my pin codes. I cannot remove pin code restrictions. I can add a restriction to a pin code (say, wednesdays from 8 AM to 5 PM) and that works fine. However, if I remove the restriction, vera says its removed…and it says that the transmit was OK…but the restriction is actually still in effect. I have a ticket open with Vera support on this.


I purchased another Kwikset 914. It paired and I was able to program PIN codes successfully. This item I purchased directly from Amazon, versus the previous one I had purchased from a third party seller through Amazon. I suspect there was something fishy (a return known to not work right) with the first lock kit.

In the future, I’ll purchase only directly from Amazon. Disappointing that it came down to this.

bump. Reviving this thread. I have a kwikset and can program PIN codes into the lock but the ones in UI7 with my new VeraPlus do not work. My lock has worked flawlessly with my UI5 on my Vera 2 for 3 years!

I had an issue with my Kwikset 916 and Vera Edge UI7, and solved it based on this thread.

I added two PINs to the lock when I installed it, using the lock keypad. Those worked fine. The UI listed those two PINs so I assumed all was good.
I recently added a builder code remotely. The UI now listed 3 PINs. But only the first two were working.
To restore sanity I deleted the user codes at the lock, and added them ONLY via the UI. Now everything works - I can add, delete. But it seems that adding PINs on the lock AND through UI are mutually exclusive. This should be made much clearer - if it’s a Kwikset limitation, then it should be reflected in the UI by not looking like it has succeeded.

To add to my pain, I had forgotten my master code (and that I’d even added one).
I tried the Kwikset test for master code - it says you hear 5 beeps if you press Program. What I heard was two normal beeps and four short beeps - distinctly different and not 5 any way I looked at it.
I tried factory reset, and the procedure worked - lights, etc, but it was completely ineffective. The door was still reachable (include) and all PINs remained - working at the lock and in the UI.
Thankfully I finally remembered the master code, and used the “all user delete” procedure to delete all, to get to the working state described above.
Moral - don’t forget your master code, and be prepared to spend time making educated guesses rather than relying on the guides!

I hope this helps someone else… I believe it applies to all Kwikset locks with the same Z-wave module, and possibly to UI7 regardless of Vera model.

I recently upgraded my Vera3 from UI5 to UI7. Kwikset door locks all had to be re-paired (but not un-paired interestingly). They are now visible and controllable once again. However, when I go to PIn Codes, I see momentarily on the screen the list of active codes, but then the screen refreshes and they disappear. I attempt to re-add a pin code and it recognizes it as a duplicate and says no. I can even add a new code but can’t access the existing ones to modify restrictions or delete.

Any progress on this?

My app/PC interfaces work similarly. I can make PIN code changes from the PC web interface but not from my iPhone app. Is this a limitation of the app or do I not have something setup properly? I can foresee the need to immediately eliminate a PIN code with my phone if I don’t have a PC available.
Developers: If this feature is not available from the iPhone app please consider adding. Thanks.

I am experiencing this same behavior where I can’t program pin codes from Vera. I have excluded the device, factory reset the lock, re-included the lock and attempted to add pin codes again from Vera without programming any codes from the lock keypad. Unfortunately I have not seen any change in behavior. I am, however, able to delete codes that were entered from the lock keypad.

Is anyone else still having this issue or has anyone found a different remedy than those outlined in this thread?