Keen Smart Vent

Update: I now have 4 of the Keen Smart Vents paired with my VeraPlus. Here is the step by step process that has worked for me. It is a copy of the email I sent to the Keen Support Team:

Here is the process for successfully pairing and operating your smart vent with Vera Control Ltd. (formerly Mia Casa Verde Inc.)

From Vera’s main screen go to ‘Devices’
Select ‘Add Device’
Select ‘Generic ZigBee’ and begin Vera’s three step process
Step 1: Select Your Device
Click ‘next’ to get started.
Step 2: Pair Your Device
Pull the teal battery strip to power the vent
Click ‘next’ to begin the pairing process
Once the device is discovered and added you will be prompted to name the device and assign it to a room.
Step 3: Give it a name and assign it to a room.

At this point the VeraPlus will restart its Luua and you should see the device in the room you placed it in, however it has been incorrectly configured as a Door Sensor. You must refresh your browser?s screen to reload the Vera control panel. (I am using Google?s Chrome on a Surface 3 Pro). If you do not refresh the browser you will see the device and can access its settings screen but it will NOT have the correct options.

Once refreshed, access the devices’ ‘settings’ and select the ‘Advanced’ tab. Locate and change the following two items from this:

device_file = D_DoorSensor1.xml
device_json = D_DoorSensor1.json

To this:

device_file = D_WindowCovering1.xml
device_json = D_WindowCovering1.json

You must click outside the field’s input box for the changes to be sent to the controller. Once done, click the ‘Back’ button and select ‘Save Changes’. You should now see the device’s icon has changed to the Window Covering icon and you will have full control of your vent using the ‘Open’, ‘Close’ buttons as well as the percentage slider. The ‘Up’, ‘Down’, and ‘Stop’ buttons have no functionality. If I knew how to modify the json an xml files, I’m sure those buttons could be removed.

I have four of your vents and all of them were discovered and paired almost immediately (distance from VeraPlus hub approx. 15’). For unknown reasons, once or twice I have needed to pop the battery tray out of one of the vents in order to reestablish its connection to my Vera. Other than that they work flawlessly.

Here is what I would like to ask for help on. I understand that the vents have both a temperature sensor as well as a pressure sensor built into them. When I look at the device’s variables under the ‘Advanced’ tab, I do not see anything I recognize at a ‘current temperature’ or a pressure reading. Perhaps there a ‘capabilities’ item that I could add that would allow those two items to be accessed or perhaps they are there and I don’t realize it. Any insight would be greatly appreciated.

I did NOT utilize a Keen Hub, ONLY the VeraPlus.

Again, the “Up”, “Stop”, and “Down” buttons do not work which is okay as they don’t seem applicable for an air vent anyhow.

Perhaps someone more knowledgeable than me could modify the .xml or .json files to remove those controls and we could rename the files D_AirVent1.xml and D_AirVent.json. If that is even possible???

Do you mean so that the Up Stop and Down are not shown or that its correctly recognised?
If its the former, then you can easily edit the JSON file in the device simulator to remove the offending buttons and save that code into a new JSON file… then use that one

The Buttons are displayed per the stock Window Covering files. They simply do not correspond to an action or function of the Keen vent. That said, I shall spend a little time tonight on my file modification learning curve and see if I can remove the buttons.

Thanks for the direction.

Hi, just received my vent but every time i try to pair, it shows as a generic Zigbee device. There is no advanced settings to make the proper changes for it to work. Every time i try to click any tab i get an error message. Any suggestions? Thanks

Did you try changing the parameters I outlined in the beginning of this thread?

I couldn’t because it would pair as an unknown device and when i closed the browser the device would disappear. Support did manage to pair it but now it states it cant connect to device. I looked at the settings and they are as stated at the beginning of this thread.

I have had this vent sitting in a corner collecting dust for weeks. If anyone can help i would very much appreciate it. Thanks :frowning:

Once or twice for unknown reasons I have had to pop the battery holder out to reset the vent. The symptom was the device not responding once I had installed the vent -vs- operating it on my counter top. My guess was that the air pressure while my AC system ran was causing a malfunction (I think the vent has a pressure sensor). At any rate, I simply popped the battery tray out and clicked it back in. Haven’t had a problem since.

Hope that helps.

I had edited the Window covering json to add a subcatecory and specific icons for vents for the econet. You would just have edit the subcategory of your vent so that it reports to it. Never made the up and down/stop worked since… there is no reason I could see I would need that. If you want I can email you the json I created.

Well tried to pair one and I am not sure what version of firmware you used but the latest on my vera plus is not very kind.
The Zigbee portion seems to work fine and it pairs but the device is not recognized. As a result it seems to show up as a generic app with reviews option.
Once you reload the browser though unlike Nutron’s case, it does not default to treat it like a sensor. Instead, it wipes it out of the UI. I am sure it is still paired but the UI won’t allow me to access it.
Seems like I need to go through some tricks to change the parameters.

I have the same issue as above. Don’t know what Nutron could be doing different but i have tried on multiple occasions including having tech support remote in but still no luck. I have tried everything. Please help.

I now own an $80.00 paperweight.

Don’t know if this has anything to do with it but it slipped my mind that at one point while I was trying to get a few of the Lowe’s Iris door sensors to work, under the Zigbee Advanced Settings, I changed the Network Channel from whatever it was to channel 16. I did this because I saw in some online document that the door sensors used that Zigbee channel. ???

Hi Nutron,

Installed the new beta firmware hoping that at least I could add it and it would recognize the device as a sensor. To my surprise it worked, I was then able to follow your instructions and now I have a perfectly working vent.

Thanks for all your help.

I can confirm that indeed the beta firmware has enabled the pairing of generic zigbee devices and therefore the Keen vent work. I did not even have to refresh my browser and the vent showed up as a door sensor on its own.

4 things I did: change the device type to “urn:schemas-micasaverde-com:device:WindowCovering:1”
changed both the device file and the json per Nutron and changed the device category to 8, subcategory of 0 will bin the device as a “window covering”. The vent has a temperature sensor.

One can create a temperature sensor device to export the temperature:
Procedure :
o App/Develop App/Create device
o Enter “D_TemperatureSensor1.xml” in the field “Upnp device filename”
o Enter whatever you want in the field “Description” -> it will be the virtual sensor name…
o Choose a room if applicable
o Click ‘Create Device’
o Reload luup
o Open the newly created device, go to ‘advanced’ tab.
o Enter “urn:upnp-org:serviceId:TemperatureSensor1” in the field ‘New service’
o Enter “CurrentTemperature” in the field ‘New Variable’
o Enter “0” in the field ‘new value’, click ‘Add’
o Reload luup

=> Then you must create a scene that runs every few minutes (like 5 minutes).
o In the scene luup code, enter :

local function update (src,tgt)
local temp = luup.variable_get("urn:upnp-org:serviceId:TemperatureSensor1","CurrentTemperature", src)
luup.variable_set("urn:upnp-org:serviceId:TemperatureSensor1", "CurrentTemperature", temp, tgt)

update (x,y) --x is the device number of the keen vent, y is the device number of the newly created device. repeat the update function call for as many devices as you need here.

return true

o Save the code, finish the scene (name, room etc), save

Also noticed that the voltage and the battery level on this device is not reported correctly. I am ready to bet it is a variable format problem.

Thank you rafale77 for the improved step by step guide.

Once the Device category and subcategory have been successfully changed to 8 ad 0, should I be able to see the variable ‘CurrentTemperature’ in the vent’s advanced settings? I have a couple Monoprice Motion sensors that have the built in temperature sensor and am familiar with how their Advanced Variables show this CurrentTemperature reading.

I followed your instructions for creating a new device. And also created a scene as suggested but no temperature readings yet in the newly created device. I do recall that when using the iDoor app that creates additional temperature devices, you often had to wait overnight for them to actually begin pulling the CurrentTemperature variable from the desired device.

Well you also need to create a scene to update the variable as per the second part of my previous post. run the scene yet? I was able to see the “CurrentTemperature” variable from the inclusion on without having to do anything.

Yes I ran the scene a couple of times. I initially created the Vent devices on whatever firmware came on the Plus. Earlier today I updated the firmware to this new Beta. Wonder if I need to delete the devices and recreate them under the newer Firmware??? I have two more vents that I’ve yet to add to the system. I’m gonna go unbox one and try it.

Nope! Not that. I just paired a new vent on new Beta firmware following the blend of both our instructions. I am still not obtaining the Variable ‘CurrentTemperature’ in the list of variables available through the Advanced tab. Hmmmm… Now it’s my turn to wonder what is different between your system and mine. :wink:

Stupid question but are you sure you are looking at the variables list and not the parameter list?

:slight_smile: There are no stupid questions. What I discovered was we had (Key word being had) different firmware versions. I had not gone to the new beta yet. So what did I do you ask? I installed the new beta firmware and have been losing my mind since. Lost connectivity with ALL vents, Lost access to PLEG’s interface. Cannot seem to re-pair even a single vent. Should have stuck with the ole motto 'If it aint broke, don’t fix it!" I was so determined to get those temperature readings from the vent. Errrrrrrrrr >:(

Update: Figured out how to reset each vent via the little black button right behind the louvers clicked a couple times. Have been able to re-pair vents and yes I now have the CurrentTemperature variable. Now if I can only figure out how to get the PLEG Next Gen UI to work I could actually use the vents as I had planned.

The firmware is the difference. I found out that before the beta, I was on the latest official firmware which is 1.7.1754 and you were on 1.7.1786 which was an accidental leaked firmware on some VeraPlus shipment. The beta seems to improve the 1.7.1975 seems to improve the handling of the generic zigbee device pairing but broke a few things. I will probably downgrade to 1.7.1754 or 1786 once all my zigbee devices are added since in the short term, I will not be adding any more and I need a few apps using javascript to work.

PS to Nutron: I noticed the signature… lol.

Just a quick update: I was able to get PLEG Next Gen UI to work after installing the ‘NewAndOld’ file. Only issue seems to be intermittent loss of connection to ALL vents. I’ve not had the time or strength in the last few days to ferret out a pattern or clue to why all the vents will suddenly be blinking yellow and they do not reconnect to the VeraPlus on their own. I have to reload the Luup engine and all vents will suddenly flash green 3 quick times and be back to functional. I’m tempted to get a Keen Hub and just observe how well the vents function.