Kamstrup 382 L and Vera3


Anyone tried this combo?

Meter im using: Kamstrup | Smart metering solutions for water and electricity with this Z-wave: http://kamstrup.com/media/21662/file.pdf

“To connect to a Z-Wave network, set the Z-Wave controller to inclusion mode, and press the push button ?network? on the module 3 times until the green LED turns on.” put i dont know how to put in inclusion.

I cant seem to get the vera3 to connect, tried pushing it 3 times fast, 1 time for 5 sec,10 sec, 15 sec… and so on… But no results

Anyone know how i do it or can give me some pointers? or if its even possible?

Cheers! :slight_smile:

Working “fine” here… Some bugs, but I hope the vera team will fix them.

But Readout of current Watt, and KWH works fine.

I just need the REactive power also, I have a solarplant, and like to read that data…

Just the detailed z-ware protocol manual from kamstrup, and have sendt it to vera.

but, select “Add device” → “Advanced Z-Wave devices” → and import one at FULL power, ane press 3 times (the LED will turn green), and you are good to go


Thanks for answer!

It still having problems with the slave modul. Even with Full power on vera3. i cant seem to get the LED lamp green.

Maybe its broken or something. Will try a couple of days more. then order a new one. And try again!



Led truns green, when pressing 3 times FAST on the kamstrup… is has noting to do with vera, it only activates the include funktion on the kamstrup, so that will broadcast it’s frame…

test the Kamstrup, without using the vera…

press 3 times fast, and see if the LED turns green, 3 times more, and it will turn off (also needen when excluding the device again)

I have asked MCV/VC to take a look at this power meter, it does not show correctly in vera.
Chris Tirdea has promised to look into it.
He told me he had been in contact with Kamstrup.

I have sendt them the tech manual for this device around 1 year ago…

I don’t think this can/will fix this issue… :frowning: