Kamikaze release

What release of Kamikaze on download.openwrt.org should be used with Vera?
Is 8.09 OK?
I’m concerned because they replaced package manager to opkg, so there might be some incompatibilities…

I had a similar question. The built-in URLs for Package lists don’t work in my Vera, they appear to be pointing to incorrect locations on download.openwrt.org (etc).

I can’t tell if this is a consequence of the [various] upgrades since I’ve had the box (Feb) or if new OOBox installs have the same problem.

I also tried “manually” downloading the following IPK via the built-in openwrt UI in Vera using the URL:


with no luck either. It appears to download, but not register it with the system.

My Alarm system (Paradox Security, with APR-PRT3 USB Interface Board) looks like it only talks 57600 baud (max) so I think I need setSerial to lower the rates so I can build out my LUA correctly.

The topic is quite old, but it comes up at the top of the search for people looking for Kamikaze/OpenWRT help… Here is the Wiki page I posted to address the issue of installing extra OpenWRT packages on Vera:


Right, so can we get a fix to the base issue?

Whilst I love documentation as much as the next person, I consider doc a work-around to a Software or Installation issue.

Fix that issue, and the Documentation is no longer needed and the solution is simpler.

It’ll also help get a step closer to the “It just works” goal…

I doubt it would ever happen, especially considering Vera2/MIOS looming on the horizon… :frowning:

And fixing it for the original Vera wouldn’t be that hard, as all is required is to rebase it with the current stable OpenWRT branch.

When the fix is as simple as implementing the configuration files from your Wiki page, it’s not that hard to imagine. Certainly not as hard and/or risky as moving up to the latest OpenWRT, which might make MCV and team a little gun-shy (although, given UI3, they’re not gun-shy :wink:

Personally, I have a lot of trouble accepting “mediocre” as being ok, and I think we all need to push for better or this product will have longer term issues, not just in terms of limited functionality, but broader ones also. An “aging” OpenWRT container helps no-one.

It’s tempting to turn your Wiki page into a Plugin codebase with a bunch of [tt]io.open()[/tt] calls to write the relevant config files. Then at least someone can “patch” Vera from the UI instead of the shell, which is needed if we want broad [user] deployment of anything written that depends upon it.

especially considering Vera2/MIOS looming on the horizon...

Looks like Vera 1 to me, just with a white case :wink: I’m sure we’ll see shortly if anything has changed under the covers (in the OpenWRT layer), but I doubt it’s anything significant since it’d cause them more issues to support.

I didn’t fully upgraded Openwrt to the latest release since I’ve waitted for some working wireless drivers on 2.6 kernel, but it seems that in Kamikaze 8.09.2, this still doesn’t work.
I’ll try to work on porting all our software to the latest Openwrt, but I can’t give an ETA since we use a few dependencies.

I’ve allready added the fix for ipkg (firmware > 1.1.216), but the package is accessible after you reboot the unit.

I think it would be preferable if the version of OpenWRT that you move to be a stable release as opposed to the bleeding edge release currently used.

From the name of the thread, I thought you were talking about the 1.1.213 release :wink:

LOL now that got me laughing for real.