iVera Problem with Window Covering Device

Hi everyone,

I’m a german developer for Z-Wave Devices and had a little problem with the iVera Software on my iphone.

At the moment I design a new marquee-controller.

The controller works very well with different Z-Wave remotes of different vendors. After I’ve tested this I “put” the marquee-controller into the vera I box (newest firmware).

Now I could controll the device with the buttons on the dashboard. So I could be sure that the hardware is not the problem.
Unfortunately, the vera box has registrate the device as a dimmer device. Because of that I changed these two option…

device_type: urn:schemas-micasaverde-com:device:WindowCovering:1
device_file: D_WindowCovering1.xml

in the advanced device options on the dashboard.

Now I see the little window shutter icon on the dashboard and I got a pull-down menu with open and close - options.
I could open the marquee with the open button and close it with the close button. Only Stop seems not to work.

So far, so good!

Now I tried to controll the device by my iphone and now the problems occurs.

  1. Open-Button = Close & Close-Button = Open
  2. At the start-up of the app there is sometimes the open button activated, sometimes stop and sometimes close
  3. If I press open sometimes the button remais activated and sometimes the stop button get activted. The same with the close-button.

I think that is a problem with the app or have to change some more options?

For the last test I’ve tried to controll the marquee with the mobile web browser of my iphone. That works very fine but the device is a dimmer instead of a window shutter. I got no idea what is wrong there?

I hope you understand my problem (and english :wink: ) and could help me with it.

Thanks a lot!


P.S.: Additional I’ve to say that the marquee normaly opens with a open command and stops with a close command. So you have to click close for two times if you want to close the marquee while it`s running in the open direction.

P.P.S.: Is there a list of the available .xml-files???

Hi Renz

Did you ever get a answer on this?


But I know that this problem is know at MiCasaVerde but not fixed at this moment.


Are you saying that it works from Vera’s dashboard, but not from iVera? That could point at a bug in iVera, which is developed by a third party, not MCV.

It works from the dashboard but not from iVera and not from the VeraMobile App. It works but the direction is wrong and the status of the device, 0% and 100% seems to be random if I reboot the apps.
Is iVera not produced by MCV?

Correct. It’s produced by the moderator of this board, @iVera, at Thinkiwi: http://www.thinkiwi.com/

Resolved issues in firmware 1.5.343:


  1.     Add window covering per christian 27-feb email