iTach Help

Hi All,

I’m trying to setup an iTach unit to my Vera2 UI4.

I’ve added the GC100 plugin, and tried to add a device. I selected ‘TV’, ‘Samsung’ and found that the ‘Samsung633’ codes matched my TV.

But when i try and select Samsung633 it tries to save the device but always get the following error…

Luup - Failed to download all plugins. Will retry in 10 minutes.

It does retry but ALWAYS fails with the same error.

I suspect that it can’t find D_Samsung633.xml & I_Sumsung633.xml files.

Any ideas greatly appreciated.




Anyone have any ideas how to get my iTach working please?


Hi JW,

The problem you face getting a response is there are not many forum members placing Q&A for UI4 and a lot of Vera 2 owners either bit the bullet and upgraded to UI5 or took to the Vera light or Vera 3 over the last year… Adding IR devices did become a little more seamless with UI5 after a few false starts.

I set a unit up and tested which I ended up with the same result. The log file represents this.

01 01/20/13 19:52:40.869 e[31;1mJobHandler_LuaUPnP::DownloadFile iSlot: 5 buffer: (null)e[0m <0x402> 01 01/20/13 19:52:40.870 e[31;1mJobHandler_LuaUPnP::DownloadFiles I_Samsung633.xml version 0.50 0.0 returned 0e[0m <0x402> 01 01/20/13 19:52:40.871 e[31;1mJobHandler_LuaUPnP::DownloadFiles can't get file I_Samsung633.xmle[0m <0x402>

I also tested against another IR Code Set for Sony which did download; however, it was not functional.
The unit was set the firmware to UI4 (1.1.1362) I upgrade to most last UI4 version via

I believe the best course of action available would be to submit a ticket to MCV.

Hi Brientim,

Thanks for the reply.

I having been toying with the idea of upgrading to UI5, but with all the issues reported on this forum I’ve been scared off from upgrading.

I am aware that if I ever bought a Vera3, I would have to upgrade my Vera2 to UI5 for easy migration of system to Vera3.

That aside, I followed your advise and spent a few hours tonight trying different model TV’s in the hope that one of models would actually download the correct .xml files.

After numerous failed models, i managed to find one where the codes worked and the files downloaded…Hurrah!!

For reference for anyone else who might have the same issue…Samsung 633 works fine.

Thanks for your help, greatly appreciated.


I went through the original upgrade and reverted back but the subsequent release proved to be stable and reliable. I had only a few minor issues with camera and the 3-1 sensor but this was rectified with later firmware releases. Consequently today there is a follow on someone who has just been though it see,11257.msg99261.html#msg99261.

I will say that I do not manage it through Vera as I use iRule and I did upgrade to a Vera 3.

Well i took the plunge Brientim and upgraded to UI5

Wish i never bothered now!!

Lost some devices, lost functionality of a couple of foscam cameras and most annoyingly, intermittently can’t login to my vera via cp.mios or through my LAN.

It refuses to accept my login details even though i know they are correct.

This really is a BIG headache now!


Just to wrap this up, the response and remediation of the last post was addressed in this thread:,8693.0.html