Issues with UI5 and the Linksys WVC80N IP camera

I have several issues with my Linksys WVC80N IP cameras on UI5 on a Vera2 controller. I use the generic IP module provided by UI5 to control the cameras. The following is not a comprehensive list:
– No lights will turn on when I access a Linksys webcam through the MIOS web portal. Worked with UI4.
– No images are archived when motion sensors are triggered. Worked with UI4.
– When I increase the size of my camera image, the image breaks after about 3 seconds. Worked with UI4.
– If I set a camera to take an image every 5 minutes and then examine the archive. Only a handful of images have data in them. Most of the images are empty. Worked in UI4.
– Cannot look at archived images from previous days. Worked in UI4.
– Cannot manually remove archived images from the image archive. Worked in UI4.

Hopefully, someone is working on correcting these issues. Being able to control cameras remotely was one of the main reasons I purchased a Vera controller.