Issues with old ZRP210 modules


I have a bunch of old ZRP210 modules, which I’ve paired and seem to work ok with Vera, except for vera is seeing them in an error state. I can send command on/off ok, and local control reports back to vera.

All Homepro zrp210 modules report:

ERROR: Unable to get any information on node

An old thread (,234.msg1745.html) has talk of this, but this is from 2008 so a lot has changed since then!

I’m running a Vera Lite on firmware 1.7.619.

What other information would be required for a bug report? I’d like to get these working properly as I have about half a dozen of them and it will save a bunch of money!





Seems this was never fixed then?

I just added two ACT HomePro ZDP210 plug in lamp dimmer modules to Vera Edge UI7. It shows errors:

ERROR: Unable to get any information on node…


Device failed to configure

I can control the lamps within the UI7 web interface, however if I press the button actually on the module the new status is not picked up by Vera.

Vera is on firmware version 1.7.1419.

I also have some ZRP210 Switch Modules I have not tried adding these to the Vera Edge as yet.

This is going to be a big problem for me as most of my plugs are ACT HomePro ones. I have emailed support today.

Looking at one of these Dimmer modules that is still on VeraLite UI5 in the Advanced area of the device I can see:

CommFailure = 0

Maybe I set that in the past and that hide the errors?

Looking on the VeraEdge UI7 at one of the dimmer modules in Advanced I cannot see a variable for CommFailure listed.

As a test on the VeraLite UI5 I change CommFailure = 0 to CommFailure = 1 for one of the ZDP210 dimmer modules.

And on the VeraLite UI5 I am not seeing any errors for this module device.

So that says to me, that the module is working fine in UI5 and that this must be a new issue with these devices in UI7 etc.

EDIT: Think its not related to the CommFailure variable at all, because when I turn on the light in UI5 it changes Commfailure back to 0. So its not a way off surpressing all CommFailures I don’t think.

Looking in the Variable area and Neighbors for these two ACT HomePro dimmers they don’t have any Neighbors listed. Even though there are other Everspring plug switches in the same room and those devices are listing Neighbors OK.

And you can now no longer run a network heal,34413.0.html

So how do we prod the powers that be to look into this?

Or just give us a workaround so they do’t show up as failed devices… I can live without the feedback to UI7.

If I was to replace all the old units with new ones, it’d cost me a few hundred ???s. I’d rather save that money for nice new gadgets like the yale door lock thats come out! :smiley:

I had a lengthy conversation with support about these ACT plugs and the upshot was they just won’t work fully on the VeraEdge UI7 something to do with the ACT plugs not announcing themselves correctly and not giving out manufacturer info. And something to do with the Vera Edge having a newer Z-Wave chip and firmware.

They also didn’t announce this manufacturer info with the VeraLite UI5 either, but they would end up configured and have neighbors OK but not on the Edge.

However you can hide the errors in UI7, go to the device settings and change Automatically Configure to NO.

All my ACT plugs are all working OK via direct communication with the Vera Edge. None of the ACT plugs ever configure fully when being paired and they never have any neighbors, but they do still work OK in my house regardless via direct communication.

Below are some of the comments I got back from support in the many emails about these devices

"The issue with these devices is that they are not implemented correctly because they do not support COMMAND_CLASS_MANUFACTURER_SPECIFIC , therefore these devices doesn?t send the manufacturer info to Vera (manufacturer id , product type, product id).

If you take a look under Capabilities (Advanced → Variables) you will see that 114 (COMMAND_CLASS_MANUFACTURER_SPECIFIC) is not listed in there."


"I have checked the logs on UI5 and it seems that the device still doesn?t send the Manufacturer Info but it?s somehow it?s configured.

This might be because the old z-wave firmware version used on UI5.

On the VeraEdge there is a totally different z-wave version and a new kind of z-wave chip (gen5 vs gen3 used on the lite).

The device might not send the Manufacturer info either if it?s not implemented correctly or the inclusion procedure is not correct.

Because the device fails to configure on the Edge the Neighbors aren?t updated.

You can contact the manufacturer and ask what is the correct inclusion procedure and also what is the manufacturer id , product type and product id for this device.

Also you can ask what z-wave firmware version does it use (for example 2.67, 2.78 or 3.40)."

The Vera support guy even called the ACT phone number in the states for me, but was never able to get through. We think they may have gone out of business ?

Thanks for the info! I can live without it being in the full mesh, etc. if it saves me a few 100 ???. :slight_smile: My Vera Lite is pretty central, and I’ve plenty of other devices to extend range, etc.

Just not having it show up as an error is enough for me.




Let us know how you get on?

I was also worried about the mesh network being down sized but it doesn’t seem to have made any difference in my house. I have the following ACT dimmers and switch plugs.

Lounge = 2x ACT dimmers
Kitchen = 1x ACT switch
Masterbed = 1x ACT switch and 1x ACT dimmer
Other bedroom = 1x ACT dimmer

I have lots of other Z-Wave devices downstairs, but upstairs I only have one other Fibaro Relay module, so was worried about the lack of other Z-Wave devices upstairs. The VeraEdge is located centrally in the cupboard under the stairs.

However the ACT plugs upstairs are responsive and work fine when controlled by scenes or by an Aeon minimote which is located in my bedroom.

Just seen you are using a VeraLite with UI7. These plugs maybe OK on the VeraLite ?

I know they configured fine and had neighbors on my VeraLite UI5.

Or are you seeing the same problem as me on the VeraLite with UI7 ?

Support suggested it was an issue with the VeraEdge because of the newer Z-Wave chip.