Issues with adding new devices and loss of existing devices {Support Ticket #190843}

I was attempting to add a door sensor and a motion sensor and my Vera Plus went on the Fritz. I then tried to recover from Backup which took a very long time to complete, upon which I lost all my switches and relays, thermostats and door locks. I had to go to work and am not sure what else is awry but I did manage to open a support ticket upon which I received one email stating that it’s connected.

I responded to this email stating that it may be connected but I’m missing a LOT of devices. I don’t look forward to re-pairing about a dozen switches all my door looks and my thermostats so I’m hoping Vera Support is working on this case but I’ve heard nothing more from them.

Please help and advise. Thanks!

Support Ticket #190843

One thing for sure: take your time. Be very slow and measured when adding devices, particularly Z-Wave devices, and let things settle down before you move on to the next one. Every time I rush it, it goes badly. Devices that have children cause extra reloads when they are created, so be aware of that and make sure you watch the system for when it’s truly quiet.

Also, I can’t stress enough that most people don’t hard-refresh their browser enough. You need to do this every time you add/delete/move a device. Every time a device shows up that shouldn’t be there. Every time a device is missing that should be there. Every time you’ve done something on the system and it seems like nothing changed, or the UI is ignoring it. Every time you install a plugin, update a plugin, or remove a plugin. Every. Ding. Time. Trust me, it will change your life.


I did one then CTRL F5 but it wasn’t wanting to show up, even after several CTRL F5’s… then my controller became unresponsive and lost several devices. This is when I tried the recovery from yesterday’s back up. Hopefully Vera Support can get everything back again and maybe free up some memory in the process too.

BTW, where’s the post on freeing up memory and using a USB Stick?

Did you lose all of your zwave devices or only a subset?
Losing all of your devices is a sign of having your zwave network reset. Restoring from a known good backup with zwave network restore should get you back up and running. Vera support can help you with that if you were backing up to their servers. Taking a long time to complete is pretty normal as it takes a few luup reloads and reboots if you recover your zwave chip.

I lost the sets consisting of switches, thermostats and door locks that I know of. I tried a restore of a backup from yesterday / last night to no avail. Maybe I should try an earlier one but then I know I’ll have to re-pair at least one switch for lights I just installed and redo the reactor that controls them.

I never did power cycle the Vera as I was out of time. I actually have a WiFi plug powering it so I can remotely power cycle the Vera if needed… should I?

Power cycling won’t hurt. It will have to do it during the restore process anyway.

I’m wondering, should I have selected “Restore Z-Wave Network” on restoring a back up? What else is there to restore? The check box seems a bit redundant as that’s the point of restoring from a back up, isn’t it?

In your case, restoring from backup without restoring the z-wave network will likely do nothing for you.
The only way your devices could be deleted is that they were removed from your zwave network and that’s why I suggested that you likely accidentally reset your zwave network. You need to restore your zwave network first and then your user data which is what this process does when you tick that option.

No it isn’t redundant. With z-wave, the vera has two processors and storage. The logic engine and UI (web server) are what is making the vera the vera (object oriented layer). Zwave itself has its own processor handling the communication stack. It has its own flash memory which stores the device list (altid) and zwave layer information like routes, whether the device “is failed”, home id. It runs its own firmware. Restoring the vera without restoring the zwave network will not restore the zwave chip’s memory data and I think it is what got wiped.
The vera creates and deletes devices (id) based on what the zwave chip tells it. If a zwave device number (altid) disappears, the vera during the luup reload will delete the corresponding device id (id).

Got it. I’m going to attempt that remotely via . I’ll click restore and come back in half an hour and see what’s up. If all else fails I can call my wife to tell me what the LED status is on the actual unit and power cycle if need be.

Now that I think about it… it is likely why it is taking a long time for you to restore.
If you restored your vera logic layer which has all your old devices (id) and your zwave chip had none (altid) of them, upon reboot, the vera will be busy deleting your devices and reloading luup over and over…

So now it says “Connection OK” but all I get is the spinner of death…

No sooner than I posted that, it loaded the Dashboard but that spinner was going for a while and I’m missing some switches and a motion sensor that were installed at a time / date preceding the date of the backup I restored. Additionally, it is properly connecting to Harmony Plugin now where it wasn’t before.

I think I’ll give it a rest for a bit…

Spinner means the luup engine is either off or loading. It is surprising though that you still have devices missing which were added before the time of the backup… Well at least you are back and you can build from here.

I think I’ve restored all but devices 580 (Shop Lights) (Switch), 582 (Shop Motion Sensor) (Motion Sensor and 586 (Car Lights) (Switch) have all gone missing. These are the latest devices installed.

Also, I have some new devices that I didn’t install and I think they may be two of these same things; Vera has been unable to configure them. They are devices 589 (_Generic IO​)​ and 590 (_Appliance Module).

Yeah, I can restore from here but these switches are buried in the ceiling plugs at 10 feet above the floor. To get access to the reset switches I’ve got to pull them out! I’ll probably bring the Vera in the garage to do this as I have wired Ethernet available on my Workbench and this will put it close to and in the same room as the switch for pairing.

You may not have to… if the switches were already included before you can just put the vera in include mode (add generic device) and just wake up the switch. Since they were on your network homeid, they already think they are included. Only the controller doesn’t know. It will save you the reset step and having to do all the rerouting. They should already have the neighbor nodes in memory and you don’t need to get the vera close.

Can you give a little bit more detailed instructions? Do I need two browsers open? One to add generic Z-Wave Device and the other to wake up the switch?


It’s pretty basic. Find how you normally wake your device up. (that’s what you do when you include a new device normally push the button a number of times within a short period or push the button for sometime)

  1. Set the vera to add a device like you normally do except you don’t need to move the vera anywhere.
  2. Wake the device up. The vera will see the device, include it and configure it.

It is like a normal inclusion but you don’t need to be close and you don’t need to reset or exclude the device because… it was already included.

So I still need to dig the switches out of the electrical boxes in which they are? UGH! Still a little easier than a full inclusion.

Does it matter that the Switch showed up as an appliance module with a different Device ID# and the Motion Sensor showed up as a Generic IO with a different Device ID#? Also, only one of two switches showed up this way.