Issue with new device on Ezlo Plus - Alexa integration

I recently added a new device - a Leviton ZW15R-1BW - to my Ezlo plus. The inclusion process went well enough aside from a small glitch in the Vera app (it asked me to scan the QR code from the box, but never activated the camera - I had to manually enter the code), and the device now works properly on the Ezlo Plus, but it isn’t showing up in Alexa.

If I go to home.getvera.com, and navigate to the “Manage Alexa Ezlo” section, the device does show up there (actually, it shows up there about a dozen times, as do several devices that I have renamed…), but it doesn’t show up in the Alexa app, and my Alexa is unable to control it.

How can I fix this? Thanks!

Hello @ibrewster,
We are really sorry you are experiencing this issue. We would like to inform you this has been already reported. It should be solved in the next few days. Thank you for your patience.
Kind regards!

1 Like

Oh, perfect, thanks! I thought it was just something I was doing wrong… :slight_smile:

1 Like

I was wondering if there were any updates on this? The plug is still not showing up in Alexa, and I just added a VistaCam which is also not showing up (though I don’t know if I should expect it to). Should I contact support to get this resolved on my system, or is it still a work in progress?

Hello @ibrewster,
The issue is still being worked on by the cloud team. We expect it to be completely fixed in the next few days. However, the integration with Alexa is not meant to work with cameras, so you won’t see it on the Alexa app.
Happy new year!

Also having problems with the Alexa integration. I created a virtual device. Linked alexa account. When I click the on or off it says “mismatch location” and does not turn the device on or off. Also, when I look in my alexa app it shows my ezlo voi offline. I can control the device through alexa, but not through the vera mobile app.

All the voice assistant and VOI stuff is pretty much broken right now.

Not sure why they couldn’t keep the current back-end cloud infrastructure working whilst they are developing replacements ?

But apparently big things might be coming at the end of the month. They are building an entirely new back-end infrastructure for all the voice assistant stuff I think eventually.

Although not totally sure if this new stuff at the end of the month, is just for VOI or for fixing the general broken state of the voice assistants integrations?

And I wouldn’t hold them to timelines so much either as they come and go often.

Ok. Well, at least they’re working on it.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules