Is Ezlo Plus Ready for Prime Time?

Hi @ibrewster

Smoke sensors were supported for a while now. and the plugin installation/creation/upgrade should be working fine. We have come a long way to this point. Only thing is that you need to get the latest plugin versions to have the upgradable devices. But while upgrading from an older version(which does not support keeping the devices while upgrading) you will have to re-create your devices for once. Then the subsequent upgrades wont break the devices.

I think your specific case needs more investigation. I am triggering the customer care and the dev teams again to re-review your logs to understand the problem. Sorry for the inconvenience.

For alexa problem, the latest known issue about the configuration interface was solved recently. However I am re-triggering another round of full regression to see any problems remaining. We are committed to resolve all issues just to assure you. Even if it takes a while you already can see that we are continuously making progress and will do so.


Nope, still not working. Though the icon may have changed - perhaps that’s your definition of “supported”?

Ok, well, that’s something then. So I just have to wait for every plugin I use to be updated once more before I can start using any plugins. So yeah, progress - just not visible at the moment, especially since only one plugin I might use has been updated to support this.

Whoa, Ezlo VOI WORKED!!! I’m astounded - it’s been literally years since I was able to do anything other than get an error from there!

That said, the other way is definitely still broken - the list at under “Manage Alexa Ezlo” still shows many long-since deleted devices - and duplicates of many of those, to boot (see attached screen shot). Plus, my device that had the spontaneous name change - which I fixed, as reported before - still is not functional via Alexa.

Well, since someone else just installed the DSC plugin and had the same issue I do, it’s obviously not a situation of just my specific case. But feel free to look at my specific case for troubleshooting/debugging/whatever - I’m happy to help out any way I can!

But that’s exactly the problem - I DON’T see that. All I see is upgrades to Ezlogic that, sure, make it prettier and easier to use, but the basic functionality doesn’t seem to be improving.

…Unless, of course, it’s just a case of my controller is FUBAR, and all the issues I’m seeing really are just due to local issues with my controller. That’s certainly a possibility!

Hi @ibrewster ,

We will re-check, re-review, re-investigate and even re-write the whole code if necessary.
For plugins you can use any latest version since all of them supports upgrade. No need to wait.

For DSC we will let you know if the error replicates. And still will get logs from your controller.

For Alexa , we will solve it even it requires complete re-write of the integration.

We are determined to solve all problems and improve our platform experience.

Thanks for you cooperation and interest , we appreciate that very much. we will update the community as soon as we have an update on the platform.

1 Like

Thanks. Hopefully full re-writes aren’t needed! With any luck, it’s just my controller that’s messed up, so it will be easy to fix and I can issue a public apology for my attitude :slightly_smiling_face:

For what it’s worth, I think if the DSC plugin and Alexa integration issues were resolved, that should check off most -if not all - of the blockers for me. There may still be some smaller issues, like needing to add a poll capability for switches created by the IP Device Generator plugin (unless you have already done that!), but those are minor - especially since that’s an ability that my vera doesn’t have!

well, here’s a good one for ya. Completely cleared controller… Added 20 or so devices NONE of which with Smart Start. Now my controller is completely bogged down with Smart Start errors. I think at this point, even advertising that this is a Smart Start enabled device is just false advertising.

Hello @Dan-n-Randy ,

If we are talking about the Smart Start broadcast visible on the Z-wave logs (taking into account previous interactions), those are not an indication of Smart Start errors.

Since you have multiple Smart Start capable devices within the controller’s range, it’s constantly receiving Smart Inclusion requests. The controller will receive those requests and ignore them since the devices were not added to the provisioning list.

I’ll reach out through the support ticket you have currently open to get more information about your case.

Bought a Hubitat C8. Wi-Fi support is great add. I plugged the Hubitat into my laptop (USB-C) and walked around the property excluding devices from Vera Plus and including them on the C8. Only took me about two days including connecting and configuring a second EVL4. (I wanted to make sure the DSC Alarm app worked with Hubitat HSM before I disconnected my original EVL4.) I also converted from Reactor to Multi-System Reactor. The Reactor to MSR conversion feature provided by @rigpapa really eased the scene/script conversion. My initial impression is that Zwave V8 has much better range than previous versions. There is a vibrant Hubitat development community, much like Vera used to be. Lots of options for dashboards, for example. Vera was a great ride, but it was time to move on.


Current slate of issues:

  • DSC plugin remains inoperative
  • Aeon 4-in-1 sensor that was woking no longer registers motion
  • Attempting to add the “Power” capability to an IP device template results in a screen that just says “Error”
  • Alexa integration still (and again, as this has been an issue before, and been fixed before) shows numerous devices that have long-since been deleted, as well as duplicate devices. Though I was able to update alexa with the “new” devices, so at least I have functionality back. That’s something :slight_smile:

And so the saga - and waiting - continues.

I trust @osman’s comments, above, and so I feel confidant these issues will be resolved and this will become a good/usable platform - eventually - but not yet.

“A Brief Moment of Elation Followed by Continued Disappointment…”

You are correct, that is what I am seeing. But it leads me to wonder, how much is all of this unnecessary chatter affecting the reliability of my network?

A couple of weeks ago, you guys pulled off some sort of miracle!!! Many of my triggers that hadn’t worked in MONTHS, all of the sudden started working again. It was like a cloud moving away from the sun, and everything felt warm again.

Of course, there are always more clouds and just as suddenly as they started working, they stopped. But at least now they come and go. The flip side of which, it clearly demonstrates how unreliable it still is. A product this unreliable is not a salable product - so then why am I getting all of these E-mails to “Hurry and get your Ezlo 2. Sale ends fr…”???

I’ve been rebuilding my network and connecting everything with S2-Unauthenticated, leaving S2-Authenticated off. I was hoping that it would make things a bit smoother (less complicated conversations). The jury is still out… What are your thoughts about speed and reliability with and without authentication?

And back to my initial frustrations with pairing and excluding… That whole interface needs to be scrapped… it doesn’t work reliably, it never tellls you the truth (“Did you really want to leave the pairing routine before it is complete?” says the error message). No, I DON’T want to quit early, and I didn’t touch anything, so why are you asking me?

If you can’t get your devices paired, than what good is all this other integration? Stop spending resources on this esoteric junk until you have a reliable pairing routine.


…and now the exa integration isn’t working AT ALL. Sigh.

Nope, DEFINITELY not ready for prime time. Beta, sure. Release? Not hardly.

It’s time for a wake-up call again. Progress seems to have fallen asleep again.

What about the “Community Feature Request and Bug Tracker”? I see little progress there.

Then there was this Excel spreadsheet right here
FORUM BUGS/REQUESTS - Google Sheets where a lot has also remained open.

The MiOS app also lags behind the web interface and should be revised.

There were promises of what should be improved/introduced/changed in the near future.

@Melih: Maybe you can report a bit on the current status. What is being worked on at the moment? What features will be introduced? Which errors are corrected? And what is the schedule?

@All: Perhaps the users can also summarize which serious errors still exist, what should be changed/improved and what is still missing.

Then I’ll start:

  • Topic reliability: It happens from time to time that commands are not executed. It doesn’t have to be the controller. It can also be that a device isn’t responding, has hung, or simply has a dead battery.
    What can be done here to improve the reliability of command execution?
    There must also be a way for the user to be informed if something cannot be executed correctly. Nothing is happening at the moment and then at some point you accidentally notice that, for example, the thermostat didn’t turn down when the window was open because it didn’t carry out the command for whatever reason. There should at least be an option for a notification to go out in the event of an error. This would also be helpful for general troubleshooting.

  • MiOS App: The app still differs in functionality from the web interface. If Meshbots are adjusted in the app, it is possible that one or the other function that you previously programmed with the web interface will become incorrect. In addition, the service is excruciatingly slow. Again and again you have to wait several seconds, or you are thrown back to the controller selection, or no devices are displayed and you have to restart the app.
    Summary: Improve performance and keep in sync with the web interface.

  • Community Feature Request and Bug Tracker: In principle a very good idea. The user can make suggestions for improvement, report bugs or request integration of devices. Unfortunately, I only ever see little progress here. Sometimes you make requests that don’t get a response, some get a direct response, and sometimes there are status changes from time to time that don’t say much. For example:

“Assigned” is self-explanatory. Someone is dealing with the request.
“Waiting for customer”: Information or the like is requested from the user. If you then answer, the status is not changed. That would have to be “Waiting for support” or something like that.
“Work in progress”: Also self-explanatory. The matter is being actively worked on.

Then there are these ready-made standard texts like “The development team is currently working on the tasks and / or bugs blocking this request.” or “The tasks and / or bugs blocking this request have been resolved and are awaiting validation from our QA team.” It would be better to write clearly what is happening, such as “We have ordered the device”, “We are now starting the tests” or “We have now integrated the device and it will be included in the next version X.Y”. It also often happens that you confirm that the bug has been fixed and the status is still not set to “solved”.

  • Custom Dashboard: It should be intuitive to use, or there should be some kind of help/instructions for use. Best with examples. Some time ago I had an online meeting where this was explained to me. I couldn’t reproduce it the next day.
    I’ve just seen that when creating a dashboard you currently have a selection menu whether you want to use a new or the old designer. You can’t select the new one and nothing happens with the old one.
    It would also be good to have some information about the status, what to expect and when the new designer will be ready to try it out.

That was all that came to my mind so spontaneously. If I think of anything else, I’ll add it.

Another feature that I think is important: data logging. I’ve mentioned this so many times now. The only reaction so far has been a “like” ( ECS-1118 status “open” for almost half of a year). Perhaps someone from Ezlo stuff can comment on this as well, if this is in the future and if so where it is on the roadmap.

Haven’t read this thread for a long while. But seems there are common themes from the users feedback.

Main, but not only points that I picked up on, whilst skimming over the last 100 replies or so, being:

  1. No local web UI. Will there ever be one?
  2. Voice Assistant integration broken and partially functional in some instances, its been pretty broken for years now.
  3. Using Hubitat as a Z-Wave radio and for dashboards, MSR for logic engine, as several of you said, about switching to Hubitat. (Are they any good the Hubitat dashboards?)
  4. Z-wave / Zigbee device response and comms issues, “Offline”.
  5. Meshbot rules running properly or not, reliability etc.
  6. Vera / Mios mobile apps being slow. This is a problem for me also and devices not always loading and the apps just kicking you back to the select Controllers page, most times when you leave the app and switch back to it, which is annoying…
  7. Vera / Mios mobile app scenes not being fully compatible with the web UI Meshbot rules. This is a problem, but not one I care about. I would never use the mobile app to create a scene. Always use the web UI.

And not to forget…

  1. All the other issues and frustrations raised.

I’m still running my Vera Plus and MSR as my main setup. And Home Remote app for dashboards.

Also lets not forget why Vera hubs were so popular in the first place. They were primarily used as Z-Wave radios only, for pretty rock solid stability and their easy to use and to develop for API’s.

The dashboards and logic engines were always done by 3rd party developers in the past.

Ezlo now have to do everything and provide a fully functioning system all on their own. As the 3rd parties devs have all moved on.

Only exception being MSR logic engine and that was a reluctant addition the Ezlo controller for MSR to support, I feel. Perhaps done out of a sense of duty to old Vera users who had used Reactor plugin for Vera in the past.

Ezlo have a ways to go yet. Its happening just very slowly it seems. Too slow for some people to wait.

But in time I am sure it will get there eventually.

1 Like

Regarding Zigbee Centralite devices mine all normally say Offline. They either just eat through batteries and drop off the system or just drop off the system for other unknown reasons. Sometimes taking the battery out and in again will restore them.

Either way I’m sick of buying expensive batteries for them, so kinda given up on using Centralite Zigbee devices on my Ezlo Plus.

Z-Wave devices, I only have a handful paired directly to the Ezlo Plus, these on the whole seem to work OK. Although I think they could expose and display more device settings and variables for them in the Ezlogic web UI. We seem to have a lot more control over Z-Wave devices in the old Vera UI7 web interface.

My wish list:

  1. ZWave stability and reliability. Doesn’t seem robust enough, doesn’t report failed attempt at a command, assumes an issued command has worked, no round trip ACK/NAK. Retry mechanism is suspect.
  2. Scenes meshbots with ZWave devices. For meshbots operating on many devices if some devices have comms problem the meshbot seems to get confused or delayed.
  3. Missing capabilities in IP Devices templates. Polling of nodes for status (for nodes with local switch state changes), binary switch input type,
  4. An IPhone app like HomeWave where you can customize a graphical UI for your system with trivial effort.
  5. Ademco Alarm panel interface via AD2USB interface. Just turn on (arm), turn off (disarm), and see status is all I need. None of the partitioning and subsystem stuff is needed by me.
  6. More IP Camera capabilities so I can control PTZ and preset positions from the UI for my many FOSCAM cameras. All the commands are simple HTML Puts so the base functionality is in Ezlo, just need a way to control it as soft buttons on the video display window.

#1 is the biggest for me. #2 might come from fixing #1. #3 is nice to have but seems trivial to add to the system. #4 is needed as I find the Vera iPhone app cumbersome. Just cut a deal to buy the source code from Intvelt and refresh it for Ezlo?? #5 stops me from retiring my Vera Plus… can’t convert my main home until I have this. #6 I have a work around using the FOSCAM app. I get all my cameras fine on Vera Plus now, shouldn;t be hard to do this on Ezlo.

1 Like

Number 1 seems pretty important, Vera firmware hubs certainly do this. Not sure about Ezlo hubs ?

On the Vera hubs in the UI you could clearly see a banner on the controlled device if there was a comms issue? And it would say something like retrying.

Cant say I’ve really tried a Meshbot rule Actioning many or multiple devices.

But from some of the comments read in this thread it seems lile it maybe an issue.

Hello @curiousB

We implemented improvements for zwave communication mechanism that should increase zwave reliability. Those improvements are related to

  • retry set commands for known responsive devices
  • delay commands to unreachable devices
  • reconstruct zwave network periodically
  • ignore controlling unresponsive devices

Answering your comments:
1 We do have a retry mechanism inside our FW. We aren’t showing this process to users (#1).
2 The improvements mentioned above should improve meshbot reliability (#2)

Now we are testing a new version of Linux FW that includes these improvements. The target is to release it by the end of summer.


A few weeks back, I asked Alexa to “open the curtains”, which triggered a relay on my Ezlo Plus, opening the curtains.

This prompted my wife to exclaim “Wow, it actually worked!!!”

I think that says it all. Any device that is so unreliable that normal functionality generates exclamations of amazement that it is working has serious issues and should be recalled from the shelves until such a time as said issues can be fully resolved.

Of course, in my case this is mostly a moot point anyway, since the continued non-functionality of the DSC plugin (community bug-tracker #ECS-1085, “Assigned” since January 20th) continues to prevent me from using the Ezlo for much of anything anyway.

1 Like