IP camera plugin UI5

I have migrated from UI4 to UI5 and there were several issues with IP cameras. I deleted them and later added them again via the “Add Devices > I want to add an ip camera”. All worked fine and even though I have JVC camera, I know I can not control them, I have the picture and refresh.

Now, UI5 is still an issue on my system and becomes non responsive after a while and I must manually restart to which I have logged jobs and I hope in the que… However, what I recently noticed was the system was saying it was downloading plugin # 5 and the sever was constantly busy…

I finally found plugin #5 was the new ip camera. So in a hope to rectify the issue I have downloaded the Panasonic Camera “app” plugin #7 and modified the camera to reflect this instead of plugin #5. I am hoping this help!

My questions are as follows:

  1. What are the difference between the two plugins?
  2. What is the correct method to add a camera?
  3. Why the inconsistencies in adding cameras?
  4. If there are defined processes via “Add Devices > I want to add an ip camera”, why do we need the app to be available and why was it always trying to download plugin #5?

Lastly, we should be consistent app vs plugin. Also, it only been a short time since I did the change, about an hour but I haven’t seen server busy other then when I have tested something…

Hi Brientim,

On UI5 you don’t need a plugin for IP cameras anymore because the plugin files have been added in the MiOS core files. However, using the PTZ capabilities of a camera still requires a plugin. This is what the Panasonic IP camera plugin is for.

The reason it’s trying to download plugin #5 is that when upgrading from UI4 to UI5 all the plugins are updated to the latest version from apps.mios.com. But because the Generic IP Camera plugin doesn’t exist anymore, that error occurs. However, that doesn’t cause Luup to restart, and it shouldn’t affect the stability of Vera.

Most cameras are plug&play, meaning that when you first add a camera to the network Vera detects it and creates a device for it. This causes Luup to restart once or twice.

What firmware version do you have?

Hello MCVFlorin

I was running 1.5.255. It was continually downloading plugin 5 not just once and this was after the the camera were working and still did for 2 days. Change the camera to reflect plugin 7 stopped this and improved the system slightly.

I put comments here about performance see http://forum.micasaverde.com/index.php/topic,8883.0.html. However due to it running like dead horse and having to manually reboot every few hours until I installed the swap file I have downgraded.

I really look forward to upgrading the firmware again when I believe it will do the job without error. Get the AUS version of Vera 3 here and I am with you.

To stop Vera trying to download Plugin #5, visit each camera’s Advanced tab, find the text box “plugin” and delete the “5” you see there. Save.

I did this this morning under 1.5.255 and the cameras still work.

Thanks futzle

Your hint fixed my problem (downloading Plugin #5). Now my Vera2 (1.5.255) is only trying to download Plugin #188. Do somebody know how to fix Plugin 188 problem?

I used this procedure, which unfortunately means using SSH on the Vera. I don’t know of any simpler way.

@futzle, I removed it and then added plugin 7 in the advance tab. It worked the same as just deleting it. Should have stopped after I deleted it. Thanks for the feedback.


Plugin 188 see http://forum.micasaverde.com/index.php/topic,8117.0.html

As I said in another post I like UI5. Keep working on resolving the issues!