Welcome to the forum pages for the Visonic PowerMax plugin.

Currently there are 2 main versions available.

[ol][li]The one in the Marketplace. [list]
[li]This one is stable and information can be found here.[/li]
[li]It can be downloaded from the Marketplace.[/li]
[li]The one in development. [list]
[li]This version should be relatively stable, but issues can occur on certain models.[/li]
[li]It can be downloaded from the trunk. Download the zip archive and upload all files to Vera.[/li]

Please note that the PowerMax serial protocol is undocumented and needs to be reverse-engineered. Much of this was already done by people on the Domotica forum, but not everything. And since I only have a PowerMax Pro (without partitions) myself, I can only test on that model. Hence other people are needed with different panel types to confirm that it also works on these.

If you want to assist with testing then please contact me including info on your panel. For testing it is needed to turn on the debug logging of the plugin and to send the ‘LuaUPnP.log’ file with a description of the findings. How to get the ‘LuaUPnP.log’ file is explained here and here. Log files can be sent to ‘vera.powermax at’.

As I understand from another post the one in development is in the Marketplace since March, right?
Is there still a difference between the version of the Marketplace and the trunk?
Maybe idea to update the introduction text in this topic?
Thanks for the great work! :slight_smile:

Thanks for the tip, the text has been updated.

Just wanted to thank the developer of this plugin. Worth buying the Vera just for this!


Thanks - that’s nice to hear :). You’re very welcome.

Hi nlrb,
just wanted to thank you so much for your plugin, it is just perfect and does a great job.
I am using it successfully with a Visonic PowerMax Pro and VeraPlus UI7 (1.7.2138).
To interconnect the PowerMax Pro to VeraPlus I have installed the VISONIC DUAL RS232 PORT (9-100697) and I use a modified cable that converts USB to serial RJ45 (purchased on Amazon, “Asunflower? 6 Ft FTDI USB to RJ45 for Cisco Console Cable Windows 8, 7, Vista MAC Linux RS232”).
The cable as it is will not do the job because it is fully wired, all 8 pins on the RJ45 side are connected to the FTDI chip.
The VISONIC DUAL RS232 PORT will not like it, the pins 1, 2, 7, 8 must be disconnected.
The easy way is to cut the cable close to the RJ45 connector (with the USB disconnected!), cut wires 1, 2, 7, 8 and crimp a new RJ45 connector with only the central pins (GND, RXD, TXD) that are needed and used.
Ciao and thank you once again. Roberto

Hi there!

I?ve been trying to add this plugin to a vera edge costumers, but it seems impossible right now.

Even after vera support guys trying to find a solution, still have the problem to connect directly with the panel.

I think there?s no problem with the comunication (cables interface, etc) because I already have this integration working (arm, desarm, sensor status, etc)

After a couple of days, the plugin stop working, with the error “Lua startup failure” and “can?t detect device”.

I open a new subject on the forum, but no one seems to be able to help me.,48330.0.html

I can specified what kind of parameters have been change by the Vera support but I know that was create a code and put it in startup lua. The specific code put a nil value on the commexception and commlastexception variable whenever it will change it.

I have this plugin configured in other vera controller (lite), and works perfectly! I just configured the plugin exactly the same way and exaclty with the same material, and in one controller works great, and in other onde it just run at all.

Rigth now, I just uninstall the plugin, and try to install again, waiting for a miracle :wink:

It seems that the plugin software version is slightly different from the one paired with the vera lite than the one paired with the edge.
On the edge unit the panel has a JS701699 v5.3.7F and the panel on the vera lite has JS702317 C17.108

Is it so diferent? nlrb I?ve checked that you are the hero from this integration :slight_smile: can you help me?

Thanks a lot for your time!

Hi Daniel,
I have compared the settings I have on my Vera Plus et it matches 100% a part from the Name and the Device Number of the SER2USB adapter.
Sorry for not being able to help you further.

Oh man, I think I hosed up my config.
My setup ran for some years fine on VeraLite and even survived the migration towards a Veraplus on the latest firmware)
However, I recently asked MCV to cleanup my serial-port config because I had entries that did not want to go.

In the process, they removed the Visonic app and also my sensors are gone etc,etc.

So I tried from scratch to get up up again, but for some reason I cannot get a PowerLink mode, always “Standard” mode and my sensors are not recognised.
There IS a working connection.
I initially did not install the Visonic app from the market, but took the 1.2-branch with separe files and copied to the Vera.
Didn’t do much … then I install the Visonic app from the market and at least I have “some sort of connection” and I see (with serial-debugging PDU) communications

This type of logging.

019-01-31 17:43:57.265 <-PM- 0D A5 00 02 00 00 00 00 00 00 00 00 43 15 0A
2019-01-31 17:43:57.266 -VR-> 0D 02 43 BA 0A
2019-01-31 18:00:01.928 <-PM- 0D A5 00 02 00 00 00 00 00 00 00 00 43 15 0A
2019-01-31 18:00:01.929 -VR-> 0D 02 43 BA 0A

Since UI7 the menu where you select the serial-port and other “on off” setting is a bit crippled in the sense that I don’t see what I select.

(you know this menu below)

General options
Communicate using UART
Motion sensor timeout
Language selection
Generate debug logging & files
Powerlink options
Force Standard mode
Auto-create devices
Auto-sync time on startup
Allow (dis-)arm without PIN
Sensor arm status

** Any clues on how to get “Powerlink” mode up ? I tried offcourse on the panel itself to install Powerlink but it does not give me the chimes I want to hear … a “Peeeep” instead of “Peep Peep Peep” so it failed for some reason.
Currently there is also 1 alarm on the panel itself regarding the onboad battery-pack, but that should not “prevent” you from installing Powerlink I think ??

I’m a bit running out of ideas…