Internet & Flash Issue - Please Help As Cannot Use

I have just bought VERA 2 and in the box was a red paper to tell me to update to the latest firmware (1.1.992) via [url=][/url] as it wouldn’t update via VERA’s Interface. I followed all the instructions to the letter and says that it has upgraded Successfully!

But now when I go to the box at the bottom stays grey and says Vera is not found. When I try to enable Remote Access via MyMiOS (I’ve created an account) says that it cannot detect the Vera box.

If I power off the unit and back on, it takes about 4-5 mins to come back on and when it does, the ETH1 light double blinks and the Z-Wave LEDs come on and all my settings have been wiped. Does this everytime I turn the unit off.

Have tried to reflash the unit, incase the updating might have been corrupt, but does excatly the same as above. I have gone to Advanced > WiFi / Net Settings, it is selected on Automatic and done Troubleshoot Network with the following results:-

=== IP Configuration ===
br-lan Link encap:Ethernet HWaddr 00:C0:02:9F:90:EE
inet addr: Bcast: Mask:
eth0 Link encap:Ethernet HWaddr 00:C0:02:9F:90:EF
eth0.0 Link encap:Ethernet HWaddr 00:C0:02:9F:90:EF
eth0.1 Link encap:Ethernet HWaddr 00:C0:02:9F:90:EF
inet addr: Bcast: Mask:
inet addr: Mask:
wl0 Link encap:Ethernet HWaddr 00:C0:02:9F:90:EE
Interrupt:2 Base address:0x5000

External IP:

=== Testing Gateway: ===

=== Testing DnsServer: lan ===


Should the DNS says this? If not, what should the DNS be?

I have Vera Connected at the power supply and by ETH1 to my Netgear DG834GT Router, as it says in the user guide. But can’t understand why it won’t work?

Many thanks
in advanced


So it looks like you can access Vera’s UI via the local IP address. UI4 will not work with Find Vera. MyMios is the one you want to use. There have been some posts here about Vera defaulting to certain network settings after a firmware flash, but it looks like you have/can change those. Hmmm…

Two things:

Once you are on UI4, no longer works you must use
You can go to and it will tell you to update to the latest UI4 build and allow you to access the box.

Thanks ASI

Neither MiOS or Vera 2 update sites cannot find the VERA unit on my local network :frowning:


Here are some things you can try:

In the firmware tab and the upgrade URL, try to upgrade firmware using this link:

See if you can then connect OK through

If the above doesn’t work then I suggest maybe trying to set it up some of the network setting manually… I assume at the moment its set to Automatic? Set it to “Through another gateway on my network. Vera is a switch” instead and try that; If that doesn’t work then you can try and set IP and DNS manually with something that is applicable to your existing subnet etc but use the DNS address

You can also try the other Ethernet port perhaps also.

Vera2 as thats what he said he had. Its exactly what his box would download from the micasaverde/vera2 URL if his DNS was working and it could resolve the addresses correctly.

Has been successfully updated now to Firmware version 1.1.1008

But still can’t detect the unit on or at MiOS.

The network troubleshooting still says the same and with the DNS issue

@PJ28, that a small victory at least!

Have you tried anything else like changing Ethernet port or trying manual network settings?

Yeah, sadly same result. The only field which I don’t know what to fill in is the DNS field. Have tried just using the PC only connected to ETH2 & removed the ETH1 connection. When VERA comes back on, ETH1 double blinks which means it’s reflashed the unit again & wiped all my settings.

The way you can tell is the Vera2 firmware ends in .squashfs where as Vera1 1 ends with .trx

@PJ28, In the DNS field try which is the Google DNS server.

What brand of router do you have and which ISP? there seem to a few cases of this recently and somebody else that reported this was using a satellite broadband ISP (may have been (Hughes net) and a Dlink DIR 655 router

If you use Windows open a command prompt and write ipconfig /all. Then you can see the DNS server (and other network setup) your PC use.

Thanks for all your help. Have returned the box back to manufacture and had a replacement shipped to me.

Says the Internet is working. But cannot still find it under or

Have not updated the firmware, it currently has version 1.1.116 and says that there is a newer version 1.1.319, but when I click to update the firmware it fails.

From playing around, could there be something blocking inbound traffic to VERA, as to why it can’t find it on the two webpages? I’ve looked in my router’s firewall and there are no commands in either Inbound or Outbound traffic. Or would I need to setup something like Port Forwarding?

This is my second unit and just want it to work :frowning:

Can you describe your network configuration?

What is connected right out of the incoming line from the cable company and in between the vera?

Since you have gone through two devices with the same issue its not the vera obviously.

I am having the same issue (I think). I could not get Vera UI4 to register with or using the ‘activate’ in the UI. But I can definitely get to it by its local IP. It would stand to reason that it is not finding because the DNS is wrong… I’ll have to try the network troubleshoot to see if I have the same message.

Can one manually specify the DNS somehow in the short term?

So it turns out I am not having the same problem… the DNS works fine and Vera finds firmware updates (or says ‘you have latest version’) correctly resolving to the mios firmware URL. But for whatever reason, none of the ‘detect local vera’ pages seem to work…,, or the ‘activate’ in the UI4 myMios. Submitted a support ticket a couple days ago, but haven’t heard anything yet.

Just wanted to thank you all for your help. The problem has now been resolved! ;D

I rang toll free support number to VERA on Skype and after two days they have sorted it for me. Apparently it was a database issue, that’s all I know. But it is now fully working and thanks for all your help and support. Much appreciated!