Installing HomeBridge (HomeKit bridge to Vera) on QNAP - Container Station


I’ve been looking at the post related to the Synology, but wanted to see if anyone has set the HomeBridge up on their QNAP via Container Station?

I’ve tried the docker instance but get an error.

does it work via CLI ? I don’t use HomeKit but have found the GUI for Container Station a bit limiting in the past .

Should be able to follow the same instructions as Synology with slight modifications in paths. The container used on Synology should work on QNAP. You’ll have to use command line interface as I do not believe the GUI provides all the necessary options.

I have mine installed on a QNAP VM, not the container station…

Hi @rafale77

What VM did you use and dos you follow an online guide ?

I am using the QNAP built in VM and had it set on Ubuntu server edition and running it headless. I installed it with command lines through SSH. I actually have quite a few bridges (echo, homebridge, sonos etc) and API running on that VM. Did not really follow an online guide other than the instructions on github for the respective bridges.

Anyone got it working on QNAP and have a clear manual ?

i tried on windows but didnt work for me, would be nice to get it running on my QNAP

alright, I’ll write up a guide when I get time later this week… I did not use the container station though. I used the Virtualization station…

have you had the opportunity to write up or record a guide to install Homebridge on the Qnap. Either container or virtualization station?

I’ve just bought a QNAP to get VM as my ancient synology didnt, and now I have upgraded RAM to 8Gb am also going to try this. Anyone got recommendations on RAM to associate for this? I was planning to use a raspbian vm but wondering if its better to load full ubuntu?

I too would like to know the easiest way to install this on a QNAP. Is there a guide out there?

I would love it if someone could offer some assistance to me. I have the Qnap TS-453A and am trying to set up a homebridge connection to control my Vera with little success. My Qnap runs both container station and VM station and so I originally tried to install a predefined docker in CS. My issue is that I was unable to locat the file structure after install to alter the config.json to my liking. Bashing my head up against a. Tick wall SSH’ing to create /root/.homebrige and copying the files without success. After reading many a forum entry I decided VM might be the way to go but again have not been able to find any instruction S to follow nor an image I can install and adapt. Is anyone willing to help an old man in distress?

Thanks in advance

Hi All - I’ve got a little further now and have Ubuntu installed inside VS on the QNAP. I have just about managed to install Homebridge-vera but seem to fail at the last hurdle. Can anyone help me decipher the meaning behind this?

I have no proxy in place - everything is set by DHCP and the QNAP has no internet connectivity issues that i can identify.

any help would be appreciated please.

ohh seems like I totally forgot about this thread. I thought I posted a tutorial on installing another bridge (probably the echo bridge) on the QNAP VM.

I am making a copy paste from my other post since a lot of the steps are the same

  1. Download latest Ubuntu from here: Get Ubuntu Server | Download | Ubuntu
    I personally use the server LTS version to run it headless. I won’t need the UI and is less resource hungry. Can move the iso file to a location on your QNAP where you will find it

  2. Open Virtualization Station

  3. Create a virtual network adapter:
    Under network setting. At the top click Add a virtual switch. Set it up as external only network. Choose the free network interface you have. Click create.
    If you don’t have a free network port, the virtual switch will enable you to have the VM communicate through the one physical ethernet port but have its own IP address.

  4. Create a VM: For Ubuntu I would recommend at least 1gb in memory and 20GB disk space.
    Name: whatever you want
    OS Type: Linux
    Version: Ubuntu Utopic Unicorn
    VNC password: If you need one
    CD Image: pick the ISO of Ubuntu you just downloaded
    HDD Location: I just left the default. You can pick where your VM will be located on your NAS
    Network: Pick the network interface/switch you created above.

  5. Launch the VM
    Under Overview, you should be able to pick the VM you just created.
    Click “Power on” on the top left.
    Hurray! you have a ubuntu VM running.

  6. Open the console and you should be able to install Ubuntu like on any new system. You will obtain an IP address for the VM network interface normally from your router’s DHCP server. I would configure Ubuntu to a static IP address:

To assign a static IP you need to edit /etc/network/interfaces. The interface will probably be called eth0. The current entry will look something like

Code: [Select] auto eth0 iface eth0 inet dhcp
You will need you need to change this to:

auto eth0 iface eth0 inet static address netmask network gateway dns-nameservers
You will have to change the numbers around depending on you network, but you can find out the information by checking out ipconfig from Windows.
Make sure you choose an address outside the address space of the dhcp server
Then restart networking sudo service networking restart. If that gives you trouble reboot the machine.

  1. After Ubuntu server is installed, the VM should reboot at least once, go to VM settings and remove the CD image.
  2. Start the VM and from the console install the bridge per the instructions here:

then the vera plugin

I personally have reverted back to the old hackworth bridge and have not been using homebridge. A lot of the errors you are having are due to not having the proper libraries installed.

make sure that you follow the instructions to install nodejs and libahavi:

sudo apt-get install nodejs npm git-core libnss-mdns libavahi-compat-libdnssd-dev

+1 - working on it now.

I am still working on this, but there are some additional steps:
7a. Install libavahi-compat-libdnssd-dev (not in step 8 ):
sudo apt-get update
sudo apt-get install libavahi-compat-libdnssd-dev

7b. Install node.js (not in step 8 ):
curl -sL | sudo -E bash -
sudo apt-get install -y nodejs

7c. Install NPM (not in step 8 ):
sudo npm install npm -g

Then Linux will be ready to install Homebridge in step 8.

Thanks Don for your assistance, I am up and running and working well. I have Siri controlling Vera, Nest and Milight seamlessly. Many thanks for your expert assistance.

I cannot take credit for Google’s work ;D

Homebridge is working. My iPhone sees it and connects. When I try the sample config.json file, and/or add the Vera information, Homebridge fails to run. Anyone have a good config.json file?