Instability and crashing

I thought I would throw this out for comment. I have been as happy as a clam with my Veralite since I got it last January. It just sits there looking cute while it controls my lights and such. So much better than that noisy 12 year old Dell Linux box in the garage. Well, that was until it crashed several weeks ago. Tech support was able to restore it from backup and life was good again, or so it seemed. Since, I have on occasion had to cycle the power since it seems to get lost.

Yesterday it melted down again. I couldn’t access the Web remotely, or SSH into it. After getting someone to cycle the power I was able to at least SSH into it and look at the logs, but not via the Web.

When I got home it seemed to be working okay. I was concerned that I was refreshing some code too frequently and made some adjustments. Hours later it melted down. It lost its static IP settings and had reverted to DHCP. I couldn’t see any devices but could restore from backup, which I did. I choose an online backup from two days ago. This brought back my devices, but the IP was still set to DHCP and I lost all of my rooms. I tried restoring again, this time from a local backup from several days ago. That worked and life is good again, except my confidence in the unit is gone.

It concerns me that the restore from the online backup did not restore everything. Not sure why. More importantly, why it would fail in such a way? I realized today that I had verbose logging turned on, so I took care of that. Next I plan to set logging to a USB flash drive. Maybe memory is an issue? Also, I am going to look at a way to schedule backups to a local server. Finally, I would like to figure out what is going on to avoid it crashing in the first place. Maybe scheduling reboots? Any thoughts?


Do you have lots of plugins? some plugins can cause crashes, you might want to remove all plugins and install one-at-a-time and observe stability.

Update! I may have found the problem. I turned off verbose logging, logging to USB flash drive, deleted unused plugins, and for good measure healed my network. My VeraLite seems to be running without issue for a few days.

Checking top though reveals a problem. CPU utilization is sustained 83%, /usr/bin/LuaUPnP is consuming 124% of memory (I didn’t think that could be). Checking the log files I see that it is in a tight loop. In code I wrote. :cry:

Reloading via the web interface brings the CPU down to a reasonable 3% and logs look good again. Still wondering about the memory usage?

Using tail –f LuaUPnP.log to keep an eye on the logs, it runs fine for quite awhile. Then the problem comes back.

A closer look at my code and I see an obvious editing mistake. Fixed it and uploaded the code. I think life if good again! :slight_smile: