Incorrect lat/long in Ezlo hub?

I have set my timezone and location (address) via the Vera app for my Ezlo hub. However, when I query the hub to get my location information, it returns:

39.8338508605957
-74.871826171875

Which is somewhere in New Jersey, US.

I am located on the West Coast in Washington, US.

Is there some other area I need to set my address for the hub to provide correct information? (I use this information to calculate sunset, sunrise, so I need it to be correct).

Thanks,

Hello @robotman,
It seems like your controller still has the default location. You can change it on the VeraMobile app by going to “Menu” → “Settings” → “Unit settings” → “Location”. If the location information doesn’t change, you can send this call through the API:

{
  "id": "_ID_",
  "jsonrpc": "2.0",
  "method": "hub.coordinates.set",
  "params": {
    "latitude" : 49.9808100,
    "longitude" : 36.2527200
  }
}

Change the latitude and longitude with the same amount of decimal digits. Let us know if you have any issues. You can also send an email to support@ezlo.com with the coordinates and we will do the process for you.
Kind regards!

Thanks - I did that and the address is my correct address, but the lat/long is incorrect in the controller.

I can change this with the API, but is this a bug that will affect others? I ask as my app uses this information and I’d rather not have users have to figure our their own lat/long.

It was an issue on previous firmware versions but not anymore, as far as we know. It is possible the location was set up on this old firmware and the location was not correctly changed then. Since the controller is updated, it should be solved by just setting up the location on the VeraMobile app one more time.

I uninstalled and reinstalled the app. (to fix the camera issue) and this fixed the location issue! Odd, but good to know.

1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules