Including a Fibaro Gen5 Motion sensor (FGMS-001-ZW5)

Hello there Vera users of the world,

Today I got a new Fibaro Motion sensor Gen5 (FIBEFGMS-001-ZW5)
The “old” sensors included normal and showed up as an:
1 motion sensor
2 temperature sensor
3 light sensor

But now the new sensor showed up as an:
1 Generic IO
2 _GET_LANG(generic_sensor, sensor)
3 temperature sensor
4 light sensor
(see attachment)

Anybody got this problem to? and how did you solve it?

Maurice

Hi!

Had the same issue and had to contact support for them to add it. Next firmware release will have it and it is also problems with battery powered sensors.

[quote=“mbrihed”]Hi!

Had the same issue and had to contact support for them to add it. Next firmware release will have it and it is also problems with battery powered sensors.[/quote]
Thanks I’ll contact support then.

Maurice @ www.totalremote.nl

Hi,

I’m having the same issue. Did they replay to you? What was the solution?

Thanks!

If you go into the advanced setting and set the following it should work:

device_json D_MotionSensor1.json
device_file D_MotionSensor1.xml
category_num 4
subcategory_num 3

Should
device_json Not be D_MotionSensorWithTamper1.json
Thats how they set mine up.

That is a good question, both of mine is set up like i wrote, what devices does your?s show, i got temp, motion and lux

And you can uses one code to make the “_GET_LANG(generic_sensor, sensor)” device invisible as its not needed.

I just get the same three as you, though earthquakes arent a serious concern in the UK ;D.
I think VERA simply haven’t addressed the Fibaro modules which coincidentally seem to be the most popular on the market, certainly here in the UK.
I have the Dimmer 2 which constantly reports “cant detect device” BUT seems to work Ok…
I have the New Gen 5 Door/Window module, i’ve contacted support regarding that but no responses yet…
On a positive the Motion Sensor however does seem to be OK.

Was this resolved in the latest firmware update?

This is more and less resolved in the latest beta firmware. My experience with this Fibaro Gen5 motion sensor is that you have to try several times but then you get three devices: motion as parent and temp and light as child devices. I only missed the battery level icon. I tried several times to unpair and pair it again but still no battery icon. Then I informed Vera Support about this and they replied “quick” (2 days…): they have tested this device in their lab and advice to put the sensor in wake up mode (blue led is on) and then remove the battery and put it back in. I did this…and it worked ! Within a few seconds the battery icon showed up (level 100%). I will follow up coming days if the battery level is also updated.

@Mai, if you are using lithium batteries it is likely to show 100% until almost dead. Mine show 100% for most of their lifespan, then fall off and die in the last day or two of battery life.

I am having really hard time configuring this sensor on my Vera Plus UI7. It includes and works fine with default settings, but when I try changing anything, it gets really frustrating:

Changing configuration parameters: I go to Device Options, change parameters, click Save Changes, then Vera waits for the device to wake up to update parameters. It either wakes up every 30 minutes by itself, or I can wake it up manually by pressing the button on the sensor. The problem is that when the sensor wakes up, the parameters start changing, but the change does not complete, and the sensor falls asleep again. So I have to manually wake it up several times (like 20 times!) for the parameters to fully update.

This becomes a real issue when I try setting up an association. On one sensor I had to wake it up like 200 times to get it to finally set up. On the other sensor I’ve been unsuccessful. Here is what is going on:

  • I go to Device Options, set association there.
  • On the Devices page it is now saying Waiting for the wake up to configure device, highlighted in red
  • I wake up the device by clicking the button, it is now saying Wait, getting secure classes in blue font, not highlighted
  • In a couple of seconds it changes the same text Wait, getting secure classes to be highlighted in red and nothing more happens - I assume the sensor fell asleep
  • I wake up the device by clicking the button, it is now saying Wait, getting secure classes in blue font, not highlighted, then saying Purging associations, in blue font, not highlighted
  • In a couple of seconds it changes the same text Purging associations to be highlighted in red and nothing more happens - I assume the sensor fell asleep again
  • I wake up the device by clicking the button, it is now saying - Purging associations in blue font, not highlighted, then saying Setting user association, in blue font, not highlighted
  • In a couple of seconds it changes the same text Setting user association to be highlighted in red and nothing more happens - I assume the sensor fell asleep again
  • I wake up the device, and the cycle repeats, it’s either saying Wait, getting secure classes, Purging associations, Setting user association, or Setting special association, in blue font but inevitably it becomes highlighted in red and everything stops.

When I woke up the first device like 200 times, it finally set up, and the association is now working. However, I was unsuccessful with the second device after hundreds of wake ups.

Is there a way to wake up the device and prevent it from sleeping?

Are you hitting the Configure Node Now button before walking the device? It is on the Advanced Menu, last tab to the right.

Yes, does not make a difference.

I tried clicking configure now, and then immediately pressing the button on the sensor.
I tried just pressing the button on the sensor.
I tried pressing the button on the sensor repeatedly once every second, to keep it from sleeping.
I tried to leave it for a couple of days, so it wakes up by itself every 30 minutes.

The results are the same - blue text for a couple of seconds, then red highlighted text. Again, I was able to make it work after about 200 wakeups on one sensor, but could not on the other.

You might try unpair, and then re-pair it but from much farther a way, the fact that you are getting security issues means that you added it in secure mode which it might be having issues with. Pairing it far way from the Vera can force it in to unsecure mode and may make life easier. (Unfornately Vera doesn’t have an option for unsecure mode so you just have to trick it by doing a full power include)