Improved Ezlo Dynamic Dashboard loading with this Chrome browser setting

My Dynamic Dashboard is massive as I have a lot of devices and changing this Chrome browser setting has greatly improved things for me, load up times are faster and also when switching tabs away from Ezlogic and back again, I am now not getting just a black screen and the dashboard is still visible.

Before I had to refresh the webpage every time when switching tabs.

Under Settings - Performance - Memory Saver -

I added the Ezlogic domain name.

Give it a try.


I can’t find this “Performance” settings in my Chrome browser. Which version are you using? I’m on Version 110.0.5481.177.

Probably should of said I was using my Windows 10 laptop.

What device type are you using?

I’ll switch it back on and check the version number

Version is 110.0.5481.177

Windows 10 22H2

Not sure try clicking this instead.


That’s also not working here. I’ve just read that these performance settings are not visible on Desktop systems.

Not sure we’d have to Google for more information.

My laptop is Windows 10


A staff member just told me on DM he had managed to change the setting on his PC and it was loading up the dashboard faster.

Some suggestions on this page

This command did the trick:


1 Like

Great nice one !

Let me know if you see any improvements with your dashboard ?

I don’t see any improvement. Switching from settings/devices to Dashboard takes in both cases approximately 11 seconds.

How many devices and plugin devices approx do you have in the dashboard?

It certainly seems to have improved things for myself. I have about 150 devices on my dashboard.

I’ve counted 58 Items in the Dynamic Dashboard.