Imperihome talks

Weard thing, I rebooted the Android device an now ImperiHome started up like as if nothing happend. Even netatmo is working again.

Imperihome sadly is on borrowed time. Their parent company Evertygo went in to liquidation.

The login / register web pages and their dev Api page are still down and likely wont come back. Their main website home page still works however.

Everyone should not log out of the Imperihome app or you won’t be able to log back in again.

You should export your imperihome configuration to a local backup file now.

Restoring an existing backup file will get you logged back in.

I’d also recommend using the apk extractor from the Play store and create a APK file, so if it gets removed from the Play store at some stage, you’ll still be able to install the application.

I have an old apk file saved from ages ago, it was the last version before they introduced the account login system, may come in handy at some point.

This is bad news … I think this is the best app for controlling SH devices.

cw-kid Thank you for your advice.

1 Like

we are going to be releasing an app called “Ezlo Dashboard” very soon.

This app will allow you to 2 things:
1- “customize” dashboards and use it on the app itself…
2- “customize” dashboards and link it to your Vera app and use the dashboard within the Vera app.

This Ezlo Dashboard is written in NativeScript so works with IOS/Android and web . We want you to be able to customize literally everything on it!
First alpha version for you to play will be out very soon. (I am already playing with a testflight version for IOS).

3 Likes

Any theories as to what brought the company to insolvency?

I ask because the questions of product pricing, and feature set – as well as business model sustainability – are currently very much at the fore here in the Vera Forum.

Now that we’ve watched numerous otherwise robust and popular IoT / HA / SH companies** either fold, go cold or get sold – with various degrees of sphincter-tightening effect on users – we’ll want to help make sure ezlo does not follow suit.

**HELP ME UPDATE THIS LIST (PM me more names, fates and reasons/outcomes)

Dark Sky ► Sold to Apple ► App monetized
Stringify ► Sold to Comcast ► App killed
IFTTT ► Company pivoted ► App stagnated but active
ImperiHome ► Company liquidating ► App uncertain
Wink ► Company pivoting ► Products monetized
X10 ► Still going strong ► Since 1978!
Yahoo! Pipes ► Company purchased ► Dev stopped
plus dozens of others along the way. Here’s some of the reasons.

Didn’t know Google bought IFTTT

Sorry, that was a misprint on my part.

1 Like

Any screen shots or demo dashboards for us to look at yet?

1 Like

Interesting!

of course! here they are…just few pages…

2 Likes

Please make sure there is a option for:
*home page 30+ devices :blush:
*page for CCTV cameras local direct stream and remote :innocent:
*short cuts for pages (if you want to jump from page 1 to page 3) :sleeping:
*to control app via scens (when doorbell triggered page changes to page “4”) :face_with_monocle:
*Widgets for quick access on your mobile phone (Arm or dis-arm alarm, Open/Close Gate, Turn all lights ON/OFF, Home status change)
*I am creating my own icons .png I would like to use them on the new app
*Page with local URL /Exsternal URL Login password like on ImperiHome

2 Likes

Please add your requests on to this thread:

Customizable Dashboard - Add your Wishes/Requests

2 Likes

Thanks, Will do.

Melih, I was curious if this dashboard was only for the new Ezlo devices?

For me it is very important that you can add more controllers to the app. Currently I work with three Vera controllers and a Fibaro Home Center 2. They communicate with each other AND in Imperihome I have them all 4 in 1 app.
With current Vera app you can only add 1 Vera controller and functionality is very very limited compared to Imperihome

2 Likes

Has anyone managed to get Imperihome and their configuration backup file working on a brand new Android device?

I just bought a budget Lenovo Tab E7 tablet to replace one of my old Amazon Fire 7 gen 5 tablets.

During the initial Android startup wizard on the new device, I selected to restore both the Imperihome Pro app and the Imperihome app.

Once in to Android I then restored my Imperihome configuration file and it restored all my dashboards OK and everything was looking good.

The Imperihome app said it was logged in as there was a log out option on the menu.

However to my horror after closing down the Imperihome app and reopening it again I was faced with the Imperihome login screen which obviously no longer works.

I then tried restoring my configuration file again and the same thing my dashboards all came back OK, but when closing the app and reopening, same thing again it was at the login screen.

I couldn’t find a solution.

In the end I had in remove those current versions of the Imperihome app and install the old Imperihome Lite and Imperihome Pro apk files from way back, version 3.0.11

This is the last version of Imperihome before they introduced the account login system, so its not there basically.

I restored my configuration file again and my dashboards are back and I can close and reopen the app OK no issues.

At a glance all my Vera devices are present and the few I have tried seem to be working and controlling stuff.

Only slight problem is this very old version of Imperihome does not have the Philips Hue 2 object so I lost that, not a big issue I can still access and control my Philips Hue lights via the Vera object.

And the Weather object is not there in the older version so I lost that object also. Both I can live without.

I have a similar issue in my setup also. If I close the app and restart it it will ask for login, witch is not possible.
The workaround I have for this is to restart the device, when the device starts it will also automatically start Imperihome and I will be again logged in without entering any credentials.
I don’t remember if this automatic start of ImperiHome is something I have configured.

There is a setting in Imperihome to have it launch at device startup.

1 Like

Then that is probably what I have done, luckily it starts without asking for the credentials so every time I get kicked out for some reason I just restart my device.

I forgot to turn off in the Google Play store automatic updates for Imperihome. It’s updated to version 4.3.17
2019-01-14 .

And I am stuck at the login prompt again.

Will have to uninstall, install old APKs restore backup and then turn off automatic app updates for Imperihome.

EDIT Seems you can turn off auto updates for just one particular app?

I’ve had to turn off the setting for all apps so they don’t auto update.

EDIT2 Looks like you can turn it off per app

Screenshot_20200601-130752

1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules