ID Lock 150 problem including

I can´t include my door lock after upgrading to the latest firmware version in Vera Plus 1.7.4955 (7.31).

I have also updated the lock (ID LOCK 150) to the latest firmware 1.5.0 and did an OTA update of Z-wave firmware to 1.6 (so this might be the problem and not the firmware in Vera).

Yesterday I included the lock but got stuck in “getting the manufacturer…”. Today I tried excluding, resetting and including again and can´t pass “exchanging security” (tried several times). My Vera Plus is less than 1 m from the lock.

This is the error displayed “Z-Wave device 259 ERROR: Failed to setup security. Please exclude this device from your system, and then include again…ERROR: Unable to get any information on node“

I´m including it as a generic Z-wave device (worked before the upgrade).

Any idea what to try next?

try having vera att 2 meters from the dorr when including, i had super big problem including vera when it was just next to the lock or if it was more than 4 meter from it, the sweat spot seems to be 2 meters. (very strange)

And if you tryde many times it normally help to remove all batteries from the door, wait a while and then try again

1 Like

this, works.

It worked! (2 meters from the lock)
I passed exchanging security keys, but now it´s stuck in “Please wait! Getting the manufacturer…”.

Does it need to wake up / be woken up?


I have tried that. But it does not seem to help. Sometimes it is possible to lock / unlock the door from Vera (but not always). The message “Please wait! Getting the manufacturer…” will not go away. Maybe this will fix itself if I wait long enough :blush:

As daft as it sounds, it might well do…

Worth looking out some of @rafale77s posts on the matter


nop it wont, the best to do is, remove it from vera, when that’s done, remove battery from idlock, unplug z-wave chip then instal it again and ad batteries, open the door, try adding it again, o do not close the door until it’s finished including. Do you have other z-wave devices net to the door that using power, i noticed that cutting the power to them and then turning it on helps including idlock for some reason. OBS do not use batteries that are 1.2v like normal rechargeable batteries, lithium rechargeable works but that’s because they give 1.5v

have you updated vera to latest 7.31?

I’ve tried all that, but maybe I closed the door before it was completely configured.

I’m running the latest Vera firmware 7.31. The latest ID Lock firmware 1.5.0 and the latest Z-wave firmware in ID Lock 1.6. It might be these firmware’s that are the problem.
What is the reason to have the door open throughout the complete configuration? Does it keep the lock awake? I don’t have any powered devices next to the door, only batterie devices. I can try installing a plug near the door and see if that helps …

As it is right now the lock is operable (lock/unlock from Vera) but no status updates and no variable changes.

for me it always seems to work if the door is open, i have no idea if it matters. i have done 4 things, and since this i never had a problem including or using the look, or any problem with any devices at al since this changes, before i always had some problems, including, or devices that didn’t respond and so on, the things i did are 1:: have vera at 2 meters, 2 have the door open, 3: installd som hardwired stuff close to the lock, and what i think is the most important thing i done is to turn off pulling on all devices using hardwire and minimising the power reporting to free up time for vera to do things it supposed to do when i like it to do it. //Regards

Did you solve the problem? Just updated the lock to latest version and then the zwave module using OTA. After including, everything looks ok but the Vera UI says “Please wait! Getting the manufacturer” and I cannot lock/unlock the lock using remote commands.
Actually, this worked before the zwave update but I wanted to update to solve battery problems…

where in the UI do you see the “259 ERROR”?

I’m also having this issue. Used the ID Lock 150 with Vera for 2 years, but due to some technical issues I got a new z-wave module, now with firmware 1.6. It pairs just fine with my Vera Plus, exchanges security keys, but then it freezes during configuration with the error “Please wait! Getting the manufacturer…”

My Vera is also a newer firmware since I last paired my ID Lock 150 without problems. In fact, previously I have paired the lock and Vera several times, never had any issues.

I have tried local reset of the Z-wave module on ID-Lock, taken the z-wave module out of the lock for several hours to make sure it has run out of battery, unpaired, and paired several times with Vera 1-2 meter away from the lock. I have tried this procedure more than 10 times. I even complained to the dealer which gave me a new lock and Z-wave module (also v 1.6), but the result is exactly the same.

Had a remote session with Vera support who had a look at the backend data, they claim that Vera is performing like it should and sending the appropriate configuration commands. They claim that after the initial pairing and exchange of security keys the ID Lock stops responding, and hence configuration fails with the error “Please wait! Getting the manufacturer…”
They claim that it is an ID Lock issue, probably after firmware 1.6.

Have anyone got this working? Anyone have z-ware firmware 1.6 working with Vera?

I have the same problem, incl OK then “Please wait …”. I have redone the procedure several times incl some work around hint issued by Idlock (to local reset the module 3-4 times). I bought the module last week, I should mention.

Yesterday I had a conversation with Idlock (in Norway, I am in Sweden) and they say the follow the Z-wave+ format but that there is some problems that Vera not been willing to solve (i.e. it is in the Vera domain to solve). So I have currently no clue, sorry.

I have further asked Idlock if the Zigbee module works better (with Vera). Answer is pending.

hej göran, ändra i inställningar så det inte står att vera ska konfigurera låset automatiskt, ställ det på NEJ, det bör lösa problemet, sedan är just avståndet väldigt viktigt med id lock och vissa firmware, tex måste jag vara på exakt 2 meter och på samma höjd annars får jag samma fel som du får. skulle det misslyckas att inkludera, exkludera igen, ta ur batterierna ur låset, tryck på knappen för lås/lås upp på låset så du tömmer det på ström, sätt i batterierna och testa igen.

did someone actually got ID 150 and zwave 1.6 to work?
i am facing this right now and it would be sad looking for new zwave controller

Stort tack! Det var manuell konfigurering som körde fast för mig.

1 Like


Vad väljer ni för typ av enhet i Vera när ni lägger till Id-lock?

Min ID-lock 101 verkar inte ha samma möjlighet att göra en factory default reset på modulen enligt manualen. Hur går man tillväga?