Hello Stuart,

Just discovered the calendars I use are in fact ical feeds. Would it still be possible to set GCal up, perhaps as a read only instance? I can get the info <iframe to just will not be able to share. Thanks!

The short answer is ‘probably’. The slightly longer answer is it depends somewhat on how the iCal was set up. Take a look at the instructions in the very top post.

Thanks Stuart. I am unable to Share the calendar and thus link to google service account. Is this a problem or can I forget this step? I seem to be stuck in bypass mode but the link works if i paste into a browser.

Stuck in bypass mode ? Should only happen if the plugin is not armed.

Progress! Now getting Access or Calendar Error … Thanks for your patience Stuart.

Is there a time limit for Gcal to get a response? I am on satellite broadband and with this weather it is quite slow.

The standard timeout is 30s which should be more than enough.

The “access or calendar error” WAS a high level error message that I’ve removed in recent patches (but not in the latest formal release) as it was over writing the actual error message.

Try this version and we should get close to seeing the real issue. Note that we may have to get a log file as well.

EDIT: Attachment Removed

Yup still no luck. error 404. Tried the Miami Heats also and had the same result. Even remembered to change “&” too!

I suspect you have a typo or something. Error 404 usually means that the url could not be found.

Try the following:
(1) make sure the plugin is armed
(2) cut and paste this into the Calendar ID input on the Control Tab

(3) click on “Set”

You mentioned above that you were using an iCal – the plugin does not use credentials to get at an ical (with the url in a form something like https://www.abc123.com/calendar/ical/…). This is because the iCal calendar must be public in order to be used. This is DIFFERENT than if you access an iCal through your google calendar in which case it is given an alias url by google and accessed in the normal manner (with credentials).

If you IM me the actual Calendar url’s you are using (assuming an iCal) - I can take a look.

Thanks for this Stuart. Your link appears to work showing no more events today. I have noticed a popup on google calendar advising my calendar is not public. I have PMd you with the link as it does open in a browser.

So several things to note. If you calendar is in fact a google calendar (or linked to another calendar – even an iCal) you need to share this calendar with your service account. This is the case with the url’s you shared via IM. The instructions for sharing are in the service account instructions in the link below (first post of the main topic). In your case - the 404 error suggest that you have not shared the calendar with the service account or you have not created the service account properly. I just went through the instructions and except for a typo (which I fixed) - the instructions are accurate. It’s likely quicker for you to go back and redo these steps.

If your calendar is just some ordinary iCal (not linked via google) then there are no credentials involved (but obviously that calendar would have to be public).

I just added a test credentials file and test calendar ID that can be used to prove that the plugin is working properly. See the Debugging section on the first post.


Going back to my original post am unsure if I am able to share this calendar. Thanks for you time, I will have to have a rethink.

Can you see your calendar in calendar.google.com ?

Yes I can. I have logged out of google and the calendar displays correctly.

I just thought of something that MAY be to do with the calendar url you are trying to access. I unfortunately deleted your previous IM. Would you mind resending ? It’s POSSIBLE that there is a google url variant that I am not handling. It’s been trial and error since there does not seem to be a published list of all the variations anywhere.

Will do.

The url format for your calendar was NOT one of the forms that I knew about. I’m rethinking how best to parse the google url. In the meantime I added this form to the code and the patch file can be found here:


Basically – because you are using google to get at a non-google calendar, google uses a slightly different url than normal.

So try the patch if everything is ok it should now work. If you still get an error it’s likely a http 404 error (which is the one I get when I try your url) because you do not have access to the calendar (either through settings on the calendar in google or credentials are not set correctly).

In any case - we are getting closer … :smiley:

Yes, I do appear to be seeing 404 error after updating. Just to recap - I have not set any credentials as I am unable to share (as far as I know) the calendar to the Google Service Account email. I do not know if this will affect what we are trying to achieve even though the calendar link opens a calendar without requiring authentication.

The http 404 error code can mean (usually) one of two things (1) that the url cannot be found or (2) that you do not have permission to access it.

In this case I suspect it’s a permission issue. So now the question is whether it’s at the google end or at the ical end.

Can you see and access the calendar in google ? In an earlier reply you said “Yes I can. I have logged out of google and the calendar displays correctly.” but it was not clear to me if you meant that you were accessing the ical directly or if it was displaying in your google calendar.

If it does not display - then it’s a good guess that the problem is at the ical end. How are the permissions set in your ical – is it public ? If it is - and you want to share the ical link via IM I can see if I can access from my system.

Also - if it is public - have you tried putting in the ical link directly into GCal (it will work with some ical calendars but not all as ical is not standardised too well)

have a look in https://calendar.google.com/calendar/syncselect does your calendar show up as shared and read only ?

I just tried getting an iCloud calendar to show up in google calendar and guess what … error 404. So I think the problem may be at the google end. There are some posts on the web talking about issues.

I’ll see if I can make sense of it over the weekend.