I cannot figure out how to arm my DSC with a pin code entry on the door lock?

I am creating the scene, I see how the trigger works, but when I go to devices vera3 does not let me use the DSC system module. It looks like I need to set the alarm on from the advanced tab but it does not seem to do anything. I tried creating an advanced entry for set alarm state and again nothing.

I am on UI5 if the helps.


You can go to code.mios.com and download the disc plugin files that has some changes recently. One which allows you to change the state of the partition.

  • Garrett

I think I have that version already, 1.1.

Where I am confused is how you change it’s state on a scene. Do you need to do that lump code stuff, change each device sensor to arm on the devices part, or do it in advanced using those drop downs.

The files on code.mios.com have recently been updated a day ago. So it is most likely you do not have this version. In order to use the lastest on code.mios.com, you would need to download the files and upload them via the developer section on your vera. The updated version will allow you to set the arm state in the scene, however, if you need to use a pin to arm/disarm the alarm, you will need to do this in the advanced section of the scene.


  • Garrett

Oh wow. Thanks so much. I spent hours trying different things and it never worked. Updating those files and now I have access to the system from scenes. You are a great help.


Does Vera update the dsc plugin automatically? I posted this same forum question about deadbolt pin code disarm a few weeks ago with no reply. When I check installed apps, it says version 1.1

If Vera doesn’t update this app automatically, what’s the process to download and install the above mentioned link?


Vera will only update the app if the plugin is posted in apps.mios.com. The new code that was added the other day by guessed and myself was uploaded to the developers section code.mios.com. You can go to the link above and download the files and upload them into vera via the developer section of vera in the lua files section.

  • Garrett

So installing this download gives you the ability
to send the arm or disarm command in a
scene? Maybe this is the download I needed to
make my scenes work correctly.


  • Garrett

Sorry to sound like a complete idiot, I’ve been staring at this system dashboard for so long I forgot where anything is located. First of all, I see 2 files that were created 3 days ago
by following the link in this thread, do I download both of them? 2nd, I can’t remember where to download them into vera operating UI5 on vera3.

I clicked the link and see 2 files created 3 days ago, thats where I stopped, my brain is fried !!! ???

If you could tell me what tabs to click that would be awesome.

[tt]Apps[/tt] > [tt]Develop Apps[/tt] > [tt]Luup files[/tt]

I download the 2 files that are 3 days old??
I downloaded those two files then went into APPS, develop apps, luup files, and clicked the
browse tab next to the 2 files that closest resembled the same name, uploaded 2 files and
checked the box “restart luup after upload”
now nothing works, no more virtual keyboard icons or status feedback from opening a door window etc…

I’ve never done the file download/upload in vera before so its all spanish to me.
I’m about to use these 2 vera3 units for boat anchors!

I would download all the files together from here:


Upload them all, but make sure you don’t use internet explorer to do it… then restart/save!

Thanks Strangely, I’m starting to get the hang of this, the upload download area on UI5 appears as if the right “upload” column is associated with the left column of downloads. A little confusing, but I downloaded from that link you provided in Firefox not IE, went to the UPLOAD area in vera3, clicked the top right BROWSE tab, located the file downloaded, uploaded, rebooted then saved. Everything still appears to be the same, can you tell me what the changes in that upload are that maybe is a hidden update? Just curious what it changed. THANKS

Here is a log of the changes between revisions.

e.g. revision 69 = 0.34
revision 67 = 0.33
revision 64 = 0.32


  • Garrett

Did you upload the files zipped or unzipped? If you did it zipped then you need to unzip and upload 7 files in total!

How do i know what revision im running? My 2 partitions keypads still have all labels and i dont see any “Door Sensor” looking devices either. In the advanced tab of the DSC panel I have zones 6,7,8 as doors. Is there something I still have to do click like the download tab by the different DSC files that appear on the luup files area?

OK sanity check…

Uninstall everything and read the wiki here:


In particular the sections for the installation with UI4 UI4 – DSC Alarm Panel or UI5 UI5 – DSC Alarm Panel

I accidentally posted the last reply and then noticed that you had a reply with the UNZIP which I didnt see prior to the post. I unzipped that one file, it opened up 7 files, I uploaded all 7 into vera, and I do see the different looking keypads now. But not doors.
Since everything is operating correctly (I believe) as far as communication, notification and status control, do you still recommend I uninstall everything?

At night I always arm the system bypassing the same zone and then arming *9 then enter my code.
Is that something that can be created as a scene?

How do you track the version you have installed. I want to make sure I always have the latest.