I bricked my new Vera EDGE within 24 hours of getting it. what are my options?

My Vera lite was doing pretty great for a while now. But I tried to add one device too many (a new dimmer switch for my son’s room) and it refused to take it. On top of that, the new firmware update caused several of my devices to be unresponsive. I knew eventually I would run out of memory on the lite, so I broke down and ordered the edge from Amazon. It showed up without a power adapter, but I figured I would use my vera lite and try it anyway. I powered it up, managed to get a few devices added, and then it stopped letting me add devices. I’m guessing that it was because those devices were having connection issues on the lite when I tried to unpair them. I upgraded the firmware on the edge, and it became unresponsive.

So are there ways to unbrick it? I’ve searched the forums and to be honest my head is swimming. I think I just need some, “try this this and this” steps to troubleshoot this one. Or am I just out $140? I’m going to be REALLY bummed if that’s the case. :’(

Any suggestions? I’m open to ideas!!

Yes you can fix this

set you PC/Laptop ip address to

then plug an ethernet cable directly into the PC NIC and the other straight into the VeraEdge

then open a browser and navigate to

if that doesnt work…

check to see if you can ping that address… if so you probably can fix this over ssh which will be a little more compicated

Great! Thank you, konradwalsh! My husband was just saying last night that he would love to SSH into the EDGE. This will be right up his ally!!


here is more specific help for SSH
run this
os.execute("/usr/bin/cmh_Reset.sh all")

the above settings i gave on IP address… set the gateway IP on teh PC to as well…

Bringing this topic back to the front…

My VeraPlus (similar UI7 and so on to Edge) was working ok hardware-wise. I updated firmware and some of my devices became “hidden”.

I had tried the “beta” on my own but had a few issue:

  1. Devices wouldn’t delete.
  2. Blue banners no longer appeared indicated Vera reloads, etc.

I then reverted / reset and reverted saved backup to last reliable firmware. All was well , so I dared to go to current firmware. Devices disappeared again.

Calling Vera Support ended with them updating my system to Beta… well they tried. They actually bricked VeraPlus.

Currently I can’t get it to respond but I can SSH in and see files, etc… But I don’t know if there is a way to force another factory reset through SSH? Could I force firmware to load that way?

Otherwise I have to RMA the existing VP… would rather get this one “alive” again…


Return it back to Vera. Hopefully they will honor you with another one

Chuck got his unit back in the meantime.