HSM100 issue... Fixed.

The situation:

I have 2 HSM100 sensors (or ExpressControls 3-In-1… same thing). Both have been setup in the past to turn on a light when motion is detected and then turn the light off 1 minute after motion stops. The quick power off is because they are just in closets. I have had this sucessfully working in vera in past firmware releases.

What I did in 899:

Added both sensors to the network. Fine.

Configured both sensors. Green Cog. Fine.

Added custom z-wave variable “2” as “1 byte dec” value: 1 (for 1 minute timeout)
Configured both sensors again. Green Cog. Fine.

Added 1 scene for both sensors. Both scenes “turn on *** light” when “sensor *** is tripped”

The result:

Walk in closet. Motion Sensor trips “RED”. Light Goes On. Great!

1 Minute Passes… Sensor goes “GREEN”… this is good…

BUT… light stays on. WTF?

I tried adding a second scene to each sensor to turn the light off when the sensor goes idle… but it didnt work and ive never had to do that before anyway. The sensor has always turned off the light after its configured timeout period. Anyone else having this problem?

Just wondering out loud here, B0SST0N…

  1. Which is responsible for turning off the closet light… Vera or the HSM100?

  2. Do Vera’s logs show any activity around the “1 minute” mark after the ‘On’ scene ran?

[quote=“LibraSun, post:2, topic:164861”]Just wondering out loud here, B0SST0N…

  1. Which is responsible for turning off the closet light… Vera or the HSM100?

  2. Do Vera’s logs show any activity around the “1 minute” mark after the ‘On’ scene ran?[/quote]

  3. I wish I knew the answer to that. My best guess is that vera configures an association between these devices directly and the motion sensor is responsible for turning the light off.

  4. I’ll check the logs… but I don’t think this command is initiated through vera. I think configuring the association is what might be messed up.

Nothing is showing in the logs but the command sent to the light to turn on when motion is detected.

The logs dont even show the motion sensor triggering and then going idle. However I can see the little red and green indicator working correctly in the dashboard. It even goes back to green after no motion for 1 minute like it is supposed to.

It seems from all the logic you’ve described, then:

  1. The sensor, not Vera, is responsible for turning off the light.

  2. The ‘Off’ delay time is told to Vera (by you making the setting you mentioned), then transmitted to the sensor (during the 2nd configuration), which it is supposed to honor.

  3. Vera remains ignorant of the sensor entering an idle state, and has no scene to react to ‘Idle’, nor is HSM100 activity appearing in Vera’s logs.

  4. The light remains on forever after the HSM100 turns it on.

All of which leads me to ask: Do you now have to “Group” or associate the HSM100 with the light (or Vera’s dongle) as some users found you must do with the ZIR010 / ZIR000(elsewhere in the Forum)?

Vera is supposed to manage these associations in the background… and always has… but I will check the other threads to see if I can workaround the automatic association not working correctly.

Again, just thinking out loud here, B0SST0N (sorry if annoying):

Does your Vera have a checkmark next to “By default Vera should automatically configure devices” under DEVICES > Z-Wave > More Z-Wave Options ?

Yes it does…

The wiki states that you must also check the box “let vera manage associations” in the device properties but I dont see that check box in 899 anymore…

Another interesting note… technically if vera setup the association then I wouldnt expect the on command to come from vera either… the on command should come from the device. No?

Im thinking something has happened recently to this “associations” code in vera… especially since that check box is no longer there.

I believe your assessment is 100% correct, B0SST0N.
This definitely sounds like an ‘Associations’ oversight on Vera’s part.

For quick reference:

(I’d forgotten that this setting is under the + next to each device, not a global setting.)

… and now seems to require clicking + and then “Custom Z-Wave Settings”, then (oddly) scroll down to bottom of the page to find these Z-Wave settings for your device. (Includes Associations, Group ID, etc.)

Now Im just confused, maybe I did have a scene to turn it off before… but either way… there is no event for when a sensor goes idle anymore. I tried creating a scene to turn the light off when sensor tripped = no, but that didnt work (in fact it just doesnt save the event if you select “tripped : no”… weird!?) . So something is broke one way or another.

****ok figured out the saving event issue, you HAVE to put in an event name or it wont save.

I dunno… having read:

… I still believe your initial hunch makes the most sense… namely, that somehow the sensor or the light, or both devices, have had the requisite “Associations” mis-configured somewhere along the line.

Wish I had more insight to share… I’m confident someone will! (And again, sorry for semi-hijacking your thread here…)

Nope… its working now.

You have to setup a scene to turn it off when sensor tripped = no. This wasnt working for me earlier in the night, but now it is. Strange.

On that note… I think that this would be entirely too difficult to setup for the average person. They are not going to post on forums and look in wiki’s. And they are certainly not going to add custom zwave variables of 1 byte dec. The custom zwave variables need to be available for people to view and set, especially for popular devices like the HSM100.

I would like to see this product hit mass market like the company wants. But I would also like to keep advanced options for people like us. It certainly is a difficult balance.

I keep loosing my advanced settings. For some reason Vera once in a while decides to re-discover my HSM100 and shows “Generic IO” and wipes all the settings from it. No obvious reason why!

For some reason Vera once in a while decides to re-discover my HSM100 and shows "Generic IO" and wipes all the settings from it. No obvious reason why!

Can you go to Advanced, Logs, check ‘verbose logging’ and ‘lock log levels’ (you’ll definitely want to uncheck lock log levels, though, once this issue is sorted out). Then the next time it happens, go to advanced, tech support and submit a trouble ticket.

My HSM100 keeps being rediscovered as Generic IO also. How did you fix it?

Hi feinstaj,

What firmware is your Vera on?

Please send us a trouble report from your Vera. Go to Advanced/Logs and enable Verbose Logging, then go to Advanced/Tech Support, enable it if it’s not already and submit a ticket with logs and configuration files. Thank you!

They all do the same after u run a heal, especially if you have physically moved the device

feinstaj: if you need some help, let us know what you need and we can give you advice. I have three HSM100s working reliably now - as long as I don’t repair my network, as madas pointed out :wink: