How to setup Sensative Strips (Guard, Drip, Comfort) in a Vera Controller

The attached document details how to add any of the three currently available Sensative Strips (Guard, Drip, Comfort) to a VeraEdge, VeraPlus, or VeraSecure controller.

EDIT: Verified on VeraEdge and VeraPlus runnning 7.31. Not verified on VeraSecure, but it should (famous last words) work.

EDIT: Use the device “Sensative Strips Strips-MaZw” as it provides some valuable magnet moving instructions when adding. Also, pay close attention to the steps described in the attached document about how to move the magnets when resetting a Strip device.

This document is a compilation of information gathered from numerous posts from this site, feedback from the Sensative development team, Vera support staff, and trial and error.

I am using these devices in several homes and they are quickly becoming my favorite sensors. The battery life is impressive (a door sensor from 2 yrs ago is still going strong and they have updated the implementation to last even longer), the form factor allows for hidden installations, and the price is fair.

– Ernie

VeraDevicesSensative.pdf (674.3 KB)


On my wish list to get for all 9 of my windows.

Thank you for these.
These are normal inclusion with some specific configuration settings I have used for 3-4 years. Except they don’t work anymore. As I reported, the latest few firmwares are failing to assign a HomeID to the device. So though the vera thinks they are included, the strips don’t think they are and are therefore failing the follow on configuration steps. I listed this also in the 7.31 known issues.
The battery is rated for 10 years. I have had 1 drain after only 2 years because… of the vera’s special wakeup nnu and wakeup polls which lead me to discover the problem with the inclusion when I tried to replace it. I have no doubt that they would last 10 years on any other controller.
Are you sure you did you had successful inclusions on 7.30 and 7.31? Or did you have them previously already paired and just took the screen captures on these firmwares?

[broken link removed]

Following my instructions, I successfully included on 7.30 (several devices of each of the three types) on several Vera Edges. I have not retried with 7.31, but will repeat on both FW versions to verify again.

As I was still going through my trials and errors phase, I may have had to reset one of the strips but otherwise I had no issues.

I have not tried on the vera edge but can guarantee you that it fails on the plus. I am not the only one reporting this as you can see from the thread I linked.
You don’t even need to get to the specific instructions part for it to fail. It fails at step 0… zwave level inclusion. Note that this worked a couple of years ago…

I do have an unboxed vera plus and will try on it.

One other thought … I used the device: “Sensative Strips Strips-MaZw” for all of my pairings.

While the Sensative dev team told me the “Generic Z-Wave device” should work the same way, I vaguely recall it may have had issues. Regardless, I will try again and report back.

I was u able to setup a Sensative strip on Vera Plus v7. 29.

It added the device but never configured it.

the vera thought it did, but the device disagreed… that’s why you can’t configure it. :wink:

Thanks for everyone’s comments. Here is the results of today’s testing and my test procedure.

  • Verified a StripGuard works on a VeraPlus with 1.7.4955 (7.31)
  • Verified a StripGuard works on a VeraEdge with 1.7.4954 (7.31)

My suggestions for success are:

  • use the device Sensative Strips Strips-MaZw
  • carefully follow the instructions in my document when moving the magnets to get the device into pairing mode or when resetting.
  • If it doesn’t work the first time, then try again. Especially if you are like me and found it difficult to watch the LED flashes, the computer screen, and keep track of the number of times I moved the magnet to/from. By the end of my testing, quickly moved through the steps and things worked the first time.

Here are the details of my testing:

Test setup:

  • brand new VeraPlus - first time out of the box (automatically updated FW to 7.31)
  • brand new StripGuard - first time out of the box
  • re-verified VeraPlus is running firmware version 1.7.4955 (7.31)
  • a VeraEdge also running 1.7.4954 (7.31)

Test 1 (initial add on VeraPlus):

  • Click on “Add Device”
  • Selected the device: Sensative Strips Strips-MaZw
  • Started pairing process.
  • Removed the two magnets (Note: if just removing the magnets doesn’t work, then follow the on-screen instruction for moving round magnet to/from round edge three times.)
  • A new a device in Vera was created.
  • Assigned it a name and a room
  • Verified device type: urn:schemas-micasaverde-com:device:DoorSensor:1
  • added two notifications: one for open and another for close
  • received notifications when I moved the magnet away and near

Test 2 (verify rest to auto-add mode works):

  • Deleted/unpaired the StripGuard on the VeraPlus (per on-screen instructions I moved round magnet to/from round end 3 times)
  • Device disappeared
  • Followed the “Reset to auto-add mode” steps in my document
  • Added the device a second time with device “Sensative Strips Strips-MaZw” and it worked as before

Test 3 (verify reset to factory settings works):

  • Deleted/unpaired the StripGuard on the VeraPlus as before
  • verified device disappeared
  • “reset to factory settings” per steps in my document
  • added the device a third time with device “Sensative Strips Strips-MaZw” and it worked as before

Test 4 (try adding device to a VeraEdge running 7.31):

  • Deleted/unpaired the StripGuard on the VeraPlus as before
  • “reset to factory settings” per steps in my document
  • Took the StripGuard to a VeraEdge running 1.7.4954 (7.31)
  • added the Strip with device “Sensative Strips Strips-MaZw”
  • Vera created a new device and it worked as before

Test 5 (add with “Generic Z-Wave device” on VeraEdge w/ 7.31):

  • deleted/unparied the device as before
  • “reset to factory settings” per steps in my document
  • Did “Add device” and selected the device “Generic Z-Wave device”
  • removed magnet
  • Vera created a new device and it worked as before

Test 6 (just messing around):

  • deleted/unpaired the device as before
  • “reset to auto-add mode”
  • this time it didn’t add until I moved the round magnet to/from the round end three times
  • Vera created a new device and it worked as before

Additional tests (more messing around):

  • I tried a few more test after resetting to factory settings &/or resetting to auto-add mode.
  • In general, I found that I needed to pay very close attention to how the magnets were moved to/from the device and which end of the device I was moving the magnets near.
  • If it didn’t add the first time, then try again and follow the magnet moving instructions very carefully.

Bottom-line: the StripGuard successfully added to both a VeraEdge and a VeraPlus running 7.31 when paying close attention to moving the magnets per the instructions.

I am baffled. It could be that it is because you have 0 device on your network though this would be a new failure mechanism on the vera I had not seen before. I only previously observed security exchange failures caused by the vera’s excessively chatty network when adding a device.
I would not know why the vera would fail to assign HomeID to a device because of this.

By the way I did try both the specific and the generic inclusion wizards and it made no difference. As every one else reported, the vera detects the device, goes to include it but then on the next step can’t find it. I verified through another follow test that without a factory reset of the strip, I can immediately include it to another controller indicating that the strip never acknowledged that it was included, It had no HomeID. On top of that the LED indicators of the strip shows that it’s inclusion process timed out while the vera is trying to configure it, hanging at the first step “waiting for manufacturer info”.

Being able to exclude the device does not indicate the device was included as the zwave exclusion is promiscuous.
Obviously the wake up of the device is tricky with the magnet but was never our problems for the three of us who reported failures since the vera detected the wakeup and started inclusion.

I can only conclude that we found a new device inclusion failure mechanism caused by the vera’s network handling. Once again, vera is not testing their systems with 231 (or at least 150 as they rate their the units) devices networks as they should.


I am an engineer… When I do testing, I don’t test to pass, I test to fail in order to find the boundaries. They don’t even test to spec which make me wonder what the zwave certification entails…

1 Like

Not arguing with you, chap!

Have a similar argument with lots of customers

‘We want to load test your system’
‘What do you think that will tell you?’
‘We need to check that you can handle our volume’
‘We already handle 17x your volume. The only use is to test to failure, and I will not let you do that on a multitenant environment’
‘We want to load test your system’




Not quite sure what to say about the failures some of you have experienced. My experience has been positive – but I didn’t come to the Vera game until just before 7.30 was released.

I have successfully included approx twenty of all three Strip types in the past 4 weeks on several VeraEdge controllers without any issues. Except for my initial test on the VeraPlus today, all systems had numerous zwave devices already included. (I am readying a few more VeraPlus systems and am hopeful 7.31 is solid enough to deploy. I may slow that down just a bit while 7.31 soaks a bit more.)

I have many more of these strips on order and don’t expect any issues. In the past, I used these strips on HomeSeer controllers with no issues. To be honest, I am still climbing the learning curve on Vera, but other than the Vera 7.30 fiasco it seems to be working for the relatively small configurations I create. Thank goodness for the Reactor plugin, or I would have moved to something else right away. I am a long time HomeSeer user/dealer, but I recently struggled through over a year of HomeSeer cranking out between 100-200 beta HS3 software releases (depending on how one counts) and throwing them to the user community for test; that awful experience forced me to find an alternative controller. And now they are doing it all over again with HS4. Unfortunately, there are only about three non-cloud-based controllers available on the market today.

So … I will continue with Vera for a bit longer and may end up rolling my own before all is said and done. Meanwhile, if you try the Sensative strips again, I hope you have success and that my shared learning was of help.

1 Like

I just tested today and can confirm that the device includes fine on an empty vera and fails on my production unit with 145 nodes so… thank you for your report. I would have not guessed this failure mode.

A bit odd for you to come from Homeseer. What made you move?

1 Like

Interesting. I have not had any Strip device include failures on VeraEdge systems with <24 devices and will soon try a VeraPlus with that many devices. I wonder if it isn’t something other than # of devices in your system that is causing issues. Perhaps some other system resource constraint that slow things down?

Homeseer … although it is a very mature and robust system for technically oriented users, the biggest issue for me was a lack of maintenance features (backup/restore or replacing a failed controller). I ended up writing a complete Linux subsystem to deal with that, but then just too many pain in the neck issues: crazy number of SW loads that the users had to test and that no delaer could ever support, much higher controller prices (than either Vera or Hubitat), no native Zigbee, not as dealer friendly, lack of technical support, plugin count restrictions (<=4) on Raspberry PI-based Zee, and expensive plugins. I cater to 2nd/remote homeowners in the mountains who want to monitor just a few things … garage/exterior doors left open too long, motion sensor to two, water leaks, heating system failure, a few lights on/off, no monthly fees, a few custom features to support system health monitoring (I am still working on this). Nothing complicated. So far Vera meets most my needs. I was very excited about Ezlo-atom, but the native scene support is so feature poor that I can’t do the few things that I need to do. At CES this year, Vera also announced new controller hardware for later this year … so hope it is better, faster, and less $. We will see. :wink:

I can promise you that it isn’t the case. Plus you are the first one reporting success so far. Everybody else failed until… well I tried on an empty test unit. 24 devices is about where the limit is, it might be up to 30-40 when I started having problems including secure class devices, failing security key exchanges. It also depends on what devices are being used, the polling frequency, the wakeup intervals of the battery operated devices etc… So it isn’t a single factor. I ended including mine using a secondary controller on the same network and it configured right away on the vera.

Well you moved to a less mature and not very robust platform needing lots of maintenance features so we will see. At least it is inexpensive and has some limited zigbee support.

So, 4 years later and I’m trying to add a Sensative Strip Guard to my Vera Secure and run into the problem described by @rafale77 above. Controller adds the strip as a generic io device but strip doesnt seem to be paired.

Anyone know of a work around for this these days or am I screwed and need to buy a different sensor?

I’m running FW 1.7.4971 and there is an upgrade to 1.7.5187 available but considering my Vera Secure was bricked last time I performed a FW upgrade I’m a bit hesitant to push the upgrade button… Also, the realease not linked in the UI says nothing about a fix for sensative strips so… :frowning:

Looks like I had a similar problem back here, but I must of fixed it some how as it was working again.

If its added it as a Generic IO device then you will need to manually change the device template files it is using, to make it into a door sensor.