How to get startet with using the say-comand in a simple scene?

First of all I am i newbee ;).

I have a VeraPLus - Multiple Sonos speaker - and some Hue bulbes.

I have installed the upnp-app and the Sonos-app. Found all speakers and they are controleable from the UI. I have also tested the saycommand from the devicetab and it runs fine saying what ever I want in my native language (Danish) So far so good.

I want to use the say-function i a simple scene - like “at 7 am on a weekday - say good morning”

The basics of treggering the scene is no problem - but after setting up the schedule I choose the Sonos speaker that I want to say good morning and this is where i get stuck.

? Do I use the play/pause/stop-buttons? :-\ (I set the PLAY to green)
? I have inserted this

luup.call_action(“urn:micasaverde-com:serviceId:Sonos1”, “Say”,
{Text=“Hej Verden”, Language=“da”, Volume=60},

When I try to run the scenes - all that happens i that my sonos - plays music - and nothing is “said”?

Hope that someone can help me ore just point me to a HOWTO. A have been loking around for a while, but have not been able to find some hints to get me started.

Thanx in advance - Christian :slight_smile:

UPDATED - This did not work for me either !?

[quote=“mrv777, post:13, topic:183219”][quote=“jasperpants, post:12, topic:183219”]Hey mrv777,

I totally get where you are with this. UI7 baffled me at first but I’ve got it down for TTS alerts and actions.

Here’s the process:

Go in to “Scenes”
“Add Scene”
Select your trigger
Select “Next Step”
Then select “Next Step”. Don’t define any action just yet.
You should now be at Step 3: Finish the Scene
Select “Advanced Editor”
“Add First Action”
Select the Sonos from the drop down
Then select what you want to do, in this case try “Say”
Add some text to the “Text” box
Set the volume, I usually pick a number over 60 so it’s loud enough for me to hear it
Then, and this is critical, click “Add”
Then “Done”
Give your scene a name and then click “Finish”

Try testing it out and see how you go.

Good luck![/quote]

I won’t be able to test that until I get home, but I was able to find all the options. Thank you!! That’s just what I was looking for[/quote]

UPDATED - This did not work for me either !?