How to create Ezlo Plus Scene to turn off lights (that was left on in between a specific time)

Are there any updates on this topic? I am looking to do the exact same thing. I would like to have a light turned off if left on accidentally between the hours of 10 PM and sunrise.


So, the logic here would be something like:

Whenever device X is turned ON

Time restriction:
11 PM to 6 AM

Wait 20 minutes, then turn device X OFF.

If that’s what you wish to accomplish, it is not yet possible on the app since no options for time restrictions or delayed actions are currently available.

The request for implementing time restrictions on scenes in the app is already on the queue:

Since I couldn’t find one for the delayed actions option, I created it:

Hopefully, it will be implemented soon, but there is no ETA to offer on this.


@Leandro ,

Delayed action is available for an action, so what would be changed by your request?

@ranneman You’re right, I didn’t notice I was connecting from an old APK when I checked from my end. My bad.

Doesn’t this do the trick?
(i used a smart switch instead of a light bulb).

OR if you are using motion detector

1 Like

Hi @ryantatum20 ,

As @melih shared, we have a special “functions” area where you can use “FOR” function for these kind of requests. That function results true when the condition holds TRUE FOR specified amount of time. So it exactly matches your condition.
You can refer to our documentation about it

or we have example videos in our youtube channel

1 Like

I have a night light scene/meshbot for my living room.

I want my floor lamp to turn on when motion is detected and only when in Night Mode and want to arbitrarily disable the night light if I have a guest sleeping on the couch or I’m watching a movie when my wife goes to bed which requires night mode so the fan doesn’t turn off in the bedroom.

On VeraLite I achieved the arbitrary disabling through virtual switches. Does ezlo have virtual switch capabilities or how would I go about disabling and enabling this scene/meshbot with a simple voice command through alexa and/or button on the app?

In this meshbot I’m trying to turn off the light only when motion hasn’t been detected for 15 minutes and it’s in night mode and the same virtual switch is enabled.

previously I used a virtual switch and called it “Living room night light” and used it to enable and disable the two scenes/meshbots above.

Have you tried the “Virtual Container” capability?

You can create Virtual switches in Ezlo if you prefer to go that route and stay consitent with your prior scheme on Vera.

To the OP regarding a retriggerable monostable multivibrator function to trigger a delayed turn off of lights after the last motion detected.

I guess you could code up some logic to do this and it would be an elegant solution. I just have a couple “All Off” cleanup runs on my system that shut all the lights off at 10:30 PM, 1AM, and 3AM.

I have a virtual switch (VS) for the 10:30PM run that is called “defer off”. If defer off is true I skip turning off at that time but at the end of the script I switch the VS back to false so it doesn’t happen the next day. Then at 1AM all the lights go off. Then again at 3AM if for some reason a light gets turned on between 1 and 3.

As my dad once told me, “nothing good happens after 1AM”…

1 Like

Is there a wiki on this? I’ve attempted doing this through virtual containers but I don’t see an option for a switch in the dropdown and I don’t know how to write java scripts. Is there an online tutorial or video for this? I tried searching the wiki but didn’t find anything.


Hello @homeuser

Instead of using “Switch” you can use power to replicate that.

We do not have an official guide for Virtual containers, however, we’ll push to have one as soon as possible.

1 Like

Thanks everyone for the feed back so far. I wasn’t able to figure out how to make the virtual container method work. It’s above my level.

I was able to create virtual switches on Ezlo plus using this guide: Create Virtual Devices in EZLogic - (Note on a Mac you don’t need Putty… use Terminal instead).

I have a meshbot/scene setup to turn the lights and fan off in the master bedroom when the virtual switch “Auto Enable - Master bedroom” is true, and the Motion detector is “false” FOR 15 mins, and the fan or light or lamp are true.

I’m trying to do it this way because I don’t want things to turn off 15 minutes after they were turned on. I want them to turn off if no one is in the room for 15 minutes as I get lots of complaints when lights turn off on people that are using them.

The lights still turn off immediately after turning them on. The vera app shows the motion sensor is detecting motion. What am I doing wrong?

@homeuser your meshbot config seems correct.
To identify the error, lets break this down to pieces and include only motion sensor with FOR function only in the triggers first. And check if you can trigger it in case of no motion for 15 minutes.
Then we can add other conditions one by one to see where the logic breaks.
In our tests here ,the FOR function is working correctly.

I took off the “OR” Master bedroom Device Group and it works like it should.

I tried making 3 AND groups, for the 3 different devices and the lights turn off immediately.

I guess I don’t really need the the OR group. Would having the controller tell the devices to turn off every 15 minutes whether it’s needed or not cause congestion on the z-wave network? I don’t know what the best practice is for this.

Hello, @homeuser

Please, share the firmware version of your hub.
You can see it in the Controllers tab, hover over (i) icon, and copy a value of the “Firmware” field, please.

v 1.30.1

it was doing it on the previous version also.

This is not a firmware version. This is a version of user interface.
Please, share your hub’s firmware version: Open tab Controllers, and hover over the information icon.

  • Model: h2.1

  • Uptime Info: 12d 5h 54m 47s

  • Firmware:

  • Advanced Scenes: 1.52

1 Like

Hi @homeuser

While they’re investigating, here’s another couple of strategies you could try to get your meshbot working.

Option 1. Two meshbots. One to perform the actions, the other to control the first meshbot with your virtual switch:

Meshbot #1

Trigger - Motion sensor does not detect motion for 15 minutes

True Actions:
TA1 Turn off main lights
TA2 Turn off lamp
TA3 Turn off fan

False Actions:
FA1 Turn on main lights
FA2 Turn on lamp
FA3 Turn on fan

Meshbot #2

T1 Virtual switch = true

True Action
Enable ‘Meshbot #1

False Action
Disable ‘Meshbot #1

Option Two. Single meshbot with exceptions. Note, this one might not be possible due to a seemingly unresolved bug that prevents users from adding multiple exceptions - Pool control with Fibaro Smart Implant - #38 by Odysee.

Trigger - Motion sensor does not detect motion for 15 minutes

True Actions:

TA1 Turn off master light

  • E1 master light is (already) off

TA2 Turn off lamp

  • E1 lamp is (already) off

TA3 Turn off fan

  • E1 fan is (already) off

False Actions:

FA1 Turn on master light

  • E1 Virtual Switch = false
  • E2 master light is (already) on

FA2 Turn on lamp

  • E1 Virtual Switch = false
  • E2 lamp is (already) on

FA3 Turn on fan

  • E1 Virtual Switch = false
  • E2 fan is (already) on



1 Like