How do I set a PLEG action value to be the same as a device input value?

Hi,

Hoping to figure out how to use PLEG to control dimming of a Fibaro FGD211 per my other thread, and stuck on one part - hope somenone can help!

I have setup a virtual dimmer as a device and I can alter its value in the Vera GUI. I have setup a device “Living Room Spotlights Virtual” input in PLEG to report the value which works ok…

pLivRmSpotDimLvl Living Room Spotlights Virtual LoadLevelStatus 10 (set at 10% in this case)

Through an action, I would like to set the dim level of real device based on the virtual one above. I have tried the following the in the advanced tab of the action…

Delay: Immediate
Living Room Spotlights SetLoadLevelTarget newLoadlevelTarget pLivRmSpotDimLvl

But it did not work, so in the LUUP tab, I tried…

‘Living Room Spotlights’ SetLoadLevelTarget newLoadlevelTarget={(pLivRmSpotDimLvl)} (I also tried without the single brackets)

But it didn’t work either!

Would anyone know what is wrong with this method or syntax, really appreciate it!

Thanks

Remove the content from the LUUP tab.

In the advanced tab of the action, replace pLivRmSpotDimLvl with {(pLivRmSpotDimLvl)}

For those that are not familiar with device commands available via the advanced tab I would do the following:

  1. Set the Virtual Dimmer to a value of 50
  2. Then go into the advanced mode and change 50 with the value of {(pLivRmSpotDimLvl)}
    You will have to check the “Customize Arguments” checkbox so you can enter something other than a number.