How do I include Stella-Z in UI7?


I’ve been at this for a few hours now, and I’m about to give up…
How can I include a Stella-Z in UI7? The manual for the Stella-Z is just a piece of junk…
Please help!

Perhaps I should add that I was trying to include the Stella-Z without having it mounted (none of the adapters would fit my radiator). I think I read somewhere that this could make the Stella-Z to go into an error state.

No one, really???

Have never used one. Did you try a Google search? Perhaps when power is connected. Bring the hub to the valve.

Sent from my iPad using Tapatalk

It really looks like it needs to be installed, and push the button through the little hole for 5 seconds to include.

Sent from my iPad using Tapatalk

Yeah, I found an updated manuela that says:

You must apply the device to the valve before applying any wireless setups and actions. Without the back pressure from the valve the device will turn into error mode.
I'll get my hands on an adapter, and try again.

Hi - it can be done without mounting, but you need strong fingers to hold the actuator in place when you first turn it on. The device goes in and out in an attempt to find out the stop points of the physical valve, if you don’t apply any resistance it keeps going and pops out. Only after the TRV has done the initial stop point check will it start the inclusion process.

Anyway, inclusion should be straight forward thereafter, instructions are a pile of poo, but remove the battery and start again if the green light is not blinking (inclusion mode)

I tried holding it backwith my fingers, but I guess I’m a weak guy. :wink:
I’ll give it another try.

I’ve bought some fitting adaptors, and tried again. No luck!
I must have tried all three of my Stella-Z at least ten times each.
When I install the batteries the arm retracts as it should. I mount it and press the blue button, and it senses the end point. So far, so good…
But after that, it’s totally dead. I’ve tried pushing the blu button 2, 5 or 10 seconds, but nothing happens. The LED stays dark, no matter what I do.

Please help me!

I installed my Stella Z with adapter, me too pusching the blue button, nothing happens. :grin:
The LED is absolutly dark. No green or red, nothing…

Isn’t there anyone who has included a Stella lately?

I also have the same issue, calibration function works, frost protection works (it closes valve when temperature is low),
inclusion/exclusion and leds are not working.

So, I had my Stella-Z’s replaced. It’s really simple to include them when you have the version with the non-crappy firmware.