How do I change device types with Vera?

All of my Zwave devices are showing up as light bulbs. Many of the appliance switches I have do not turn lights off and on/

Is there a field that I can change so my switches don’t show upas light bulbs?


Yes, you change it under the devices “Advanced” menu in the fields “category_num” and “subcategory_num”. Here is a reference for the difference category numbers.

In the past changing this would cause strange behaviour on vera. The category is automatically chisen by vera based on the devcie type. E.g. auto chaning back or devices not responding as expected. Let us know if it worked out for you after a while.

Thanks to both of you for your suggestions! Forum users who are experienced with the products are often the very best sources of information.

I will try out the different settings and see what happens. I will also do a backup just before I make any changes I case I need to do a massive UNDO.

Thanks again to both of you.

I just completed upgrading my firmware to the latest version on my VeraPlus. I decided to do a complete reinstall of all devices, don’t ask why. Two of my devices are not Vera Approved and are not listed in the Add Device list. I did a “Generic Z-wave Device” install to get the VeraPlus to load the devices. It did but, they both registered as motion sensor devices (C=4, S=3). I had to change my Everspring DT812-2 to a flood sensor (C=4, S=2). I had to change my EnerWave ZWN-BDS to a door sensor (C=4, S=1). Also had to change the “device_type”, “device_file” and “device_json” to the appropriate pointers. Both devices were recognized properly after I did a “Reload Engine” in the Z-wave settings. I have not had any issues since. Best of luck to you.