How are you using the web tiles?

Just going through and revamping our homewave and saw the web tiles function. Seems like it could be cool. Curious to hear how others are using this.

Is there any way to pass a username and password to a website using the web tile (ie, to automatically log in)?

You can include user and password in the url:

How to show brent and $ rate from or anyone else?

Sorry for being such a noob but I don’t seem to be able to do this. Is it as simple as adding ?username=XXX&password=YYY to the end of the URL?

I’m trying to use a webtile to display the energy meter from my rainforest eagle portal at

Ok… the penny has dropped and I now realise that the syntax is meant to be (The reference above is hyperlinking to a website called “” which confused me!)

Anyway, when I insert my username and password into “” it doesn’t automatically log me in.

Any tips?

After some trial and error I figure out I could log onto the device locally (ie, not the cloud login) using the following syntax: http://CloudID:InstallCode@eagle-000XXX.local

where CloudID, InstallCode and XXX are supplied with the Rainforest Eagle device.

All good.

I’ve been using webtiles to successfully display graphs from a number of sources (eg, electricity consumption from my Rainforest Eagle, solar generation from the Solar Edge monitoring portal etc) on my iPad (running iOS 10.2).

However, I’ve recently started using emoncms to create customized dashboards, which I thought I’d view on my iPad in the same way, but they refuse to display. I just get a blank webtile. The dashboard urls display fine in Safari.

I’ve checked the Homewave logs and can’t see anything that explains this behavior.

Any tips as to what might be causing this problem?

Are there any redirects in emoncms, or does it use https with self generated certificates? Those would be the obvious reasons for failure.

I’m not 100% sure how to check.

The url format is[dashboard id]&apikey=[user api key]. When the dashboard displays the url does not change. I assume this means there are no redirects?

However, it does use https so maybe it is something to do with the certificates???

I’m still struggling with this…

intveltr, can https websites be displayed via a Homewave webtile?

If yes, then I’m clearly doing something wrong.

If no, then I’ll have to find an alternate solution. One option might be to set up a local emoncms server - presumably I could view that locally via a webtile without SSL handshake issues?