Harmony - Error : Failed to get data from Hub

I’ve been using the Harmony plugin for quite some time now and have never had any issues. Today when I try to initiate anything Harmony related it doesn’t work. If I go to the Harmony Control Device the plugin created and click on either Activities or Devices I get the following error:

Error : Failed to get data from Hub.

I’ve spent the last several hours trying to figure this out including reading previous posts about this. I’ve verified the IP address and sign-in credentials are correct. I’ve restarted my Vera Edge several times, the hub several times, rebooted my router several times, even did the whole recover and reload deal on the Harmony hub and remote.

Everything else on my network is working fine, I even run the hue emulator on a Raspberry PI and all the controls work with all my Alexa devices.

I also have the hub extender and I have the 4 home control buttons on my Elite remote set for various Vera devices and that works fine. I just can’t go the other way, can’t get Vera to talk to the Harmony Hub at all!

What am I missing?? Thanks for any input!



My hub stopped working today and it appears that it is the firmware update that has caused the issue.

Found this and it has worked by backdating the firmware

The instructions are a little way down the page

Hope this helps

Thanks, I finally found that info as well.

I am in the market for a Harmony in 2019 and posted my displeasure in the Harmony forum they may start to lose future customers like me.

For them to block out Vera and not provide unofficial plugin or API is really bad. Vera doesn’t connect and phone home or any place else unless you tell it to. I use my Vera in vacation mode to turn on and off the TV in the family room through the Harmony Hub at random times and now apparently I won’t be able to do that any longer unless I can roll back the firmware which leaves me with a device that can never be updated again.

Sent from my SM-G960U1 using Tapatalk


Please upload the L_Harmony.lua file to your Vera or openLuup system if you got stopped by the Logitech 206 firmware update. You can find it here.

Cheers Rene

Receiving “Harmony Control : Hub connection set-up failed. Check IP Address.” message after hub automatically upgraded to 4.15.250

I found this link about this:

I have attempted, to Sync using mobile app and Windows MyHarmony app.
I have disabled XMPP and re-enabled using the mobile app
Verified I can ping hub with correct IP
Rebooted hub
Rebooted Vera3 UI5 / ALTUI

Still cannot connect, anyone else having this issue with the firmware update?

I also noticed the following error in LuaUPnP.log:
Harmony Control_error: Connect, failed geting details. Err 417, HTTP/1.1 417


6.5.14. 417 Expectation Failed
The 417 (Expectation Failed) status code indicates that the
expectation given in the request’s Expect header field
(Section 5.1.1) could not be met by at least one of the inbound

I’m hoping Logitech did not lock this API down to the local subnet, I have my Vera3 in an isolated subnet due to the uPNP traffic and an old bug for Onkyo plug-in that I use to use.

Hi jepjr,

I seen an other topic you got your issue solved with the 3.7 update. This should become available on the MioS app market today.

Cheers Rene

Hi Rene,

Yes, I did not realize that there were two threads on this issue. I was able to update to 3.7 using the ALTUI app store.

Thanks again for the fix, we really appreciated it.