Handler failed on "report=scenes"

I’m not sure how long exactly but I suddenly get a “Handler failed” when calling:


When looking at the logs I see this:

root@MiOS_30108774:/tmp/log/cmh# tail -fn00 LuaUPnP.log | grep -i event 01 01/25/16 10:19:26.433 LuaInterface::CallFunction_Request function AKB_eventWatcher name EventWatcher failed attempt to compare number with string <0x2f663680> 02 01/25/16 10:19:26.434 JobHandler_LuaUPnP::REQ_Handler handler failure for lr_EventWatcher <0x2f663680>

It always worked, and all other pages work also. I’m not sure how this could happen.

Any idea?

I’m running EventWatcher v1.20140123 on a Vera3@UI5 1.5.622

I also have EventWatcher v1.20140123 running on a VeraEdge@UI7 1.7.1707 and it doesn’t give this error.

No, I’m not sure either… Never seen that. What’s changed recently?

There may be more in the log than grep shows, perhaps look a few lines either side for more information.

Anything different if you use :3480 syntax, rather than /port_3480?

Last thin I did on this machine was: http://forum.micasaverde.com/index.php/topic,35914.msg266026.html#msg266026
But I reverted that all back because amg0 fixed it in his own code.
Could it be something in json libraries?

Regarding the grep… I actually looked into the full log first but there is nothing there actually so thats why I used the grep to cut/paste it for this post.

EventWatcher has its own JSON module, so I don’t think it’s that. If the other calls work, then I assume there’s something odd in a scene. It’s a while since I’ve looked at (or changed) the EventWatcher code, but I’ll take a look. The other place to look in the log is at startup when it does its initialisation.

Ok, I see. Anyway there is no rush with it.

I do see on my VeraEdge@UI7 that the last column of the scenes page contains the LUA code of a scene.

I did add/enhanced some LUA for a scene or 3 a few weeks ago.
Could there be a render issue there? I know that showing code in a screen is always tricky to program.
Maybe a conversion conflict? (PS the scene lua code has a correct syntax and works.)


I had this problem yesterday after trying to make some changes to the JSON file. When I returned everything to what it was, I had the Handler Failed notice to the link for Variable and Events Log, which was something I had changed.

I ended up closing the browser completely and log back into Vera… it went away…