HA Bridge: only old versions work (for me), and has better performance and features than Vera Echo app

Hi all,

I have some observations that may help others.

I recently had to swap my Synology NAS (it died) and so did my Vera 3, with the Vera going first. The silver lining was this all happened during the shutdown, so I had time on my hands.

The old Vera 3 couldn’t run the required FW to use the Vera Echo app, so I used the v0.2.1 (very, very, very old) HA bridge jar setup which I setup years ago. I never touched it after getting it to work. I did not use docker, I just had a cron job to start the setup. I found the web interface very easy to use, and very fast.

So when I brought the new Vera online, I played with the native Vera amazon echo app. I found it to be MUCH slower than the HA Bridge setup. It took about 1-3 seconds for it to acknowledge the command, whereas with the old HA bridge, turning off or on a light was very quick, the voice commands were processed without delay. Strike one for the vera/amazon app. So, I wanted to go back to the HA bridge… you can mix-n-match it seems… have some items controlled by the amazon app, others with HA bridge. I did that.

Also, the vera amazon app does not allow you to control anything you’d like, like motion sensors or garage doors, the HA bridge setup does. I was even able to setup things like my denon receiver (which accepts http commands) and IPPower boxes, it was so simple with the HA bridge. Strike 2 for the vera setup.

The only thing I liked about the amazon/vera app was that I could use >> 30 devices.

Then my synology died. When I brought it back up, I upgraded the HA bridge to the latest docker version. Once I used the UI, I noticed it brought firefox to its knees. It was also crowded and complicated compared to the old one. Maybe the performance problem was a fluke though. Then I found that getting echo to discover the devices worked 1 out of 10 times and then it would find only 1 or 2 devices. I spent hours on this before giving up. Also, when I entered an http command hit Test on or off, the first time it would report an error. None of this was a problem with the old HA bridge v0.2.1. I could make the devices, hit go, and discover devices with zero issues.

So I gave up on the new HA bridge and restored the old HA version. Worked within 2 minutes. Fast too.

So my current setup is:

  1. I put all devices that the vera app cannot control (e.g. motion sensors) on the v0.2.1 HA bridge. That’s priority one.
  2. I put devices that I access often (for speed reasons) on the ha bridge, not to exceed 30.
  3. The rest go on the vera app… they will be under voice control, just not with the same speed.

So summary for me:

  1. old HA bridge worked great, new one will not work with amazon: “discover my devices” is not working well, and is erratic.
  2. Vera native amazon app is slow to respond when turning off/on a device, old HA bridge is fast
  3. old HA bridge doesn’t cause firefox to bog down, new one does.
1 Like