Google Home Assistant/Ezlo VOI Support

I’m trying to migrate my Google Home Assistant setup from the Vera Edge to my Ezlo Plus without any success so far. I was able to Unlink the Vera Edge from Google Home, but not able to successfully Link the Ezlo Smart Home Control. It sees all of my devices, but ends with “Something Went Wrong”,

I figure I need to add the Google Home connection in Ezlo VOI. I enter my Google Email address, and Password, but that takes me to “Webpage not Available”, which just shows a mass of text.

I use 2FA security in my Google account, so assuming that perhaps the Vera Mobile app can’t cope with that, I tried using an App Password, but the app responded that the password was incorrect.

That makes me wonder if Google Home support in the Ezlo Plus is actually working for anyone. I haven’t been able to find any recent posts that address this problem, related to the Ezlo Plus, so I don’t know if anyone else shares this problem. My wife is getting anxious that she can no longer ask Google to turn our lights on and off.

Hello @vicw!

We are currently checking on this. Please give us some time and we’ll get back to you with an update after we are done checking.

Ezlo VOI is broken and likely wont be fixed until Q4 2022.

VOI (Text Chat) I believe is not required for Google Home integration for voice control of devices however.

Google Home is still working with my Ezlo Plus OK for turning lights on and off etc but was setup and linked sometime ago now.

I assume you are using the Ezlo Smart Home Service in the Google Home app rather than the Vera one.

And you need to use the home.getvera.com portal page and select Manage Google Home Ezlo from the drop down menu on the top right of the page, to then select which devices you wish to expose to the Google Home app.

And then you ask Google Assistant to “update devices”.

Google Home app services - Home Control

The issue that was initially reported was giving the following behavior.

The behavior that is currently given is the following:

We certainly don’t have an ETA for a fix but we’ll use this new behavior to update the status of the integration issues of Ezlo controllers with Google Home.

1 Like

I’ve seen that before where it says you have no controllers on your account when trying to access a voice assistant setup web portal page. It seemed to happen sometimes.

I’ve just gone to home.getvera.com myself now and tried to access the “Manage Google Home Ezlo” setup page and although it was fairly slow to load the page, it did load ok and I did not get the you have no controllers message.

I suggest the OP tries again.

Edit. I didnt select any new devices and hit the “Finish” button, so if it now says “Something went wrong” then Ezlo need to fix that.

Thanks, @cw-kid I’m glad to know that I probably don’t need the VOI in order to use the Google Home Voice Assistant.

Yes, I’m using the Ezlo Smart Home Control selection in the Google Home app. I next get the selection to link an account to control it. It then gives me a screen (home.vera.com) labelled Vera, and allows me to Login. It then lets me select Allow to give Google Home permissions. After I select Allow, it lists all of my devices and Meshbots on the Ezlo, all preselected to Allow access. I then select FINISH, and after a brief delay, it responds with “home.getvera.com says Something went wrong!” with s selection for me to OK. I just loops on that message when I select the OK response.

I’m not sure what you are referring to with your statement that:

When I access that web address, I get the Vera Login, and my Ezlo Controller is shown as “Controller Offline”. I don’t know if that is normal, or not, but I had assumed it was normal. I don’t see that selection to Manage Google Home from the drop down menu.

If doing it on a PC in a web browser you need to click the arrow in the top right corner next to your username you can then select the “Manage Google Home Ezlo” setup page.

It seems broken for me also however. I am not seeing the “Something Went Wrong” error but when I select a new device to expose to Google Home app and then hit the Finish button at the bottom nothing seems to happen. And after asking Assistant to Update Devices my new device does not appear in to the Google Home app.

I finally figured that part out. It couldn’t be more unintuitive, though. It seemed to pretty much replicate the sequence in the Google Home app.

Looks broken to me, as a newbie to the Ezlo Plus, and I appreciate that you agree. Hope it can be resolved. We have come to rely on using Google Home Voice Assistance.

I will report this issue to the senior developers now as its also not working for me currently either as I said.

That is normal expected behaviour. As you cannot access the Ezlo web GUI via the old Vera portal page. They should add a redirect however.

Go to this URL instead to access the new web GUI, which is still being developed.

Existing devices I added into Google Home from the Ezlo Plus hub all show as being Offline and do not work in the Google Home app.

However devices in the Google Home app coming from my Vera Plus hub do still work OK and I can control them fine.

I saw that same behavior, where all of the devices appear, but were shown as Offline on my system yesterday, but now none of my devices show up at all in Google Home.