Global Cache ITACH IP2IR

Is anyone familiar with this device?

It is a new “cost effective” version of the GC100, does anyone know if the GC100 plugin will work with this device or am I to wait until an offical plugin gets release maybe one day soon hopefully.

If someone can point me in the right direction as to how to edit LUA code to work this device I would be most greatful.

Why don’t you just try it? I think I remember reading somewhere that it was backwards compatible.

Hi thanks for your reply. I have now tried it but appear to have failed so far. I installed the plugin and gave it the IP address of the iTach unit, when creating scenes then there are the options of the three emitters on the unit… I am unsure if this is due to the plugin or the fact that mcv can physically see the iTach unit.

The issue is that the iTach does not actually appear to be emitting as the engineer led’s on the output do not flicker upon sending a signal.

Has anyone got further than me, or can shed any light for me??

There’s a post on the Charmed Quark site that looks like they just use the same driver:

http://www.charmedquark.com/vb_forum/showthread.php?t=8957

One of the others here like @JOD that has a GC100 might be able to help confirm that you have it set up the same at least!

Also another thread that confirms it should be backwards compatible

I have managed to get up and running with your help thank you. The iTach unit does indeed work with the gc100 plugin.

Thank you

Good news! Did you have to do anything special?

No nothing special at all. Sorry I am still trying to get my head arround it all.

I think I am there now, my vera2 has been struggling to download the Luup code for the particualar IR devices I have picked but appart form that I appear to be up and running.

I have managed to download one IR template for my TV so I plan to use that as a template to create one for the Amplifier.

I guess that if I just change the “lookup values” and enter the correct Pronto codes which I can do by using the learning function built within iTach and convert them to Hex (which I think is the same as Pronto) then I should be there.

I am going to spend this afternoon having a play, If I hit any brick walls I will post my findings.

Thank you for your assistance thus far.

That’s pretty much it. Once you have a similar plugin for a template, then just edit the relevant parts like a unique name etc and copy and paste / replace the pronto codes into the correct actions.

To save learning codes, you can try to look here in the below location first.

http://www.remotecentral.com/cgi-bin/codes/

This looks interesting. With a wired ethernet connection too.

everything is ok and works well in test but I have the following issue.

When adding an IR device in UI4 I can select the type and manufacture and even test some codes but then Vera gives me an error like “luup unable to download files”

I got arround this but using some other files as templates and have created my own file for the particular amplifier I am using. This works about 95%.

Some of the entries in the I_ ***.xml file are not on the device list in SQ and when I assign 2 of these commands to a button in SQ the SQ decides to close and no output from iTach is given can you help please?

What are the ones that are missing?

Also, every time you update the implementation file in Vera, don’t forget that you’ll need to refresh SQremote first… you can use the update media devices button, but I find it far more reliable to force close it, and then re-open it again.

Hi guys, I am now a lot further on than I was, I have made two working modules.

Well I have one code in each module that fails to opperate corretly but it is to do with the length of time that the PRONTO code is transmitted for.

I initially made a plugin using the usb-uirt, this device sends out codes for a lot longer than the iTach device it would appear. I have created a plugin for the Onkyo amplifier I have which works great appart from the mute facility. Mute worked great on the USB device as did volue as the volume increased by increments of 5 and the mute worked.

Since I have re wired the house and installed the iTach unit this appears not to transmit for as long as using the same code the volume increases by 1 on each press and the Mute fails to work. I have tried repeating the contorol output in SQ remote but this does not work and am therefore a little stuck.

I have the same issue with my Panasonic Viera 3D tv (without rs232 so damn anoying) with this device in order to bring it out of standby you have to hold the standby button down for about 3 seconds. I am unable to make this happen using iTach however once the unit is on i can control it beautifully.

Has anyone any idea how to get the iTach or GC100 (same thing) to transmit a code for longer… SQ talks about the code being transmitted whilst the button is depressed but believe me this is not the case.