Global Cache GC100 and UI7

Does anyone have the GC100 plugin working on UI7? I had it setup and working well under UI5, but moved to UI7 for Linear GD00Z support and now it doesn’t work at all. I removed the GC100 plugin and reinstalled, but it can’t find the GC100 on my network and the settings and advance options pages are just blank, so I can’t set the IP, which is the same behavior as before I uninstalled the plugin. I see it listed a couple of times on UI7 release notes as being fully supported, so I’m not sure if this is something UI7 related or something on my end, while I can’t imaging what that would be. Any info at all would be appreciated.

Only way I could get to the setting and advanced under UI7 was by clicking on the plugin, so it would see the device. It seemed like I had to keep refreshing and then eventually somehow I got to the settings. It’s not easy, that’s for sure.

I’ve noticed that after you make a change in a plugin a reload Luup is required before the changes actually take effect and the .json file gets loaded. This was true for the port config on the Caddx plugin.

And I’m an idiot, haha. I had it working and decided to try and help you, and now I’m stuck in the same place. Can’t get the IP set, which is annoying. I’ll keep playing around and let you know if I figure out a way to get it set.

Thanks Big, sorry to drag you down with me! I’ve tried to uninstall and reinstall again this morning, no change. I’m on 1.7.481 so short of some sort of beta there’s no new firmware to go to. I’ve power cycled the veralite a couple of times and reloaded luup as well. Nothing has affected the issue yet in any way.

It seems this is possibly a known issue with this release as this seems relevant to the problem, from the release notes here:▾-version-7-0-3-1-7-481-1-7-906-▾-dec-19-2014

(FORUM REPORT) “Can’t detect device” for few plugins if luup.set_failure(false) is not called by the plugin developer

However a few lines up in the release notes, the GC100 plugin is specifically listed as “fully supported” so I’m not sure. Just talking out load at this point.

No worries. It’s not my only Vera, I’m just testing with the Edge to make sure it’s going to work at this point. I’ll get this figured out eventually… haha…

Has anyone found a fix for this, or are we at the mercy of a firmware update to fix it?

I’ve come up with exactly nothing so far.

Is the issue that you can’t get to the settings or advanced tab to input some setting? (You open the tab and it’s blank?) Or is there a different issue?

That’s the issue JoeyD. Plugin requires setting the IP address, which I can’t do since the settings and advanced tab are blank. Worked perfectly prior to upgrade to UI7. Uninstall of plugin and reinstall makes no difference.

The latest firmware release for UI7 introduced an “issue” where if the plug in does not have a json file, or if the json is not valid…it causes that symptom.

Providing a “placeholder” json file should get around this. Give me a little time to see if I can get it to work.

I read about that issue in some other posts and thought it might be related. Thanks for your time!

Try uploading the attached files…

The only change to the D_GC100.xml file is to include a reference to the new D_GC100.json file, which did not exist.

The json file includes references to a few of the standard UI7 tabs (Advanced, Logs, Notifications, Scenes).

Give it a shot and please report back on if its successful!

[Edit: After uploading the files, be sure to refresh your browser.]

Well that worked well JoeyD, thanks for your effort. Unfortunately, the IR devices that I created in UI5 don’t seem to work anymore, and it seems others have had trouble adding IR devices under UI7 as well. Any ideas? Again, your modified files certainly appear to make the GC100 plugin operate correctly as I can open the advance tab, set the IP address, and Vera no longer complains about it being disconnected. At this point that’s as deep as the rabbit hole goes…

Looks like it might be the same issue. For my IR devices, all exhibit the same behavior as the GC100 plugin before the fix, no settings pages. I’m going to open the files you provided and review them vs the original GC100, see if I can recreate the same fix for an IR device.

Unfortunately, I think that’s about as much as I can help. I don’t have an actual GC100 or any experience with IR devices that I could troubleshoot myself.

Good luck!

Thanks again JoeyD, I uploaded the attached files in the same fashion you did, or at least that was my attempt. Unfortunately it didn’t seem to make any difference. I was going to remove my IR devices and then add them again, but oddly, I can’t find the IR device option in UI7 at all. Its as if its been removed…

If your IR devices don’t have a json file (just as the GC100 did not) you will have the same symptoms.

You will need to do the following:

  1. You can make a copy of the .json file that I created for the GC100.
    a) by convention, the name of the file should be D_XXXXXX.json, where XXXX is common with the D_XXXX.xml file for the IR device.
    b) the only change you need to make to the file itself is at the end, where it says “device_type”: “xxxxxxx”. Replace xxxxxxx with the exact text from the device file for the IR device in the tag.

  2. Add a line to the D_XXXX.xml file of the IR device to references the json file the IR device. This is in the tag. See the D_GC100.xml file, and be sure to use the correct capitalization.

You could attach a sample D_xxxx.xml file for an IR device if you want and I can provide the first sample for you to try out.

It looks like there’s a little more work to it with the IR devices. Currently, I don’t have an xml and json file for each IR device, only the generic IrDevice1.xml. Not sure if they got removed in the upgrade to UI7 or what, but there’s some info here about creating the needed files and getting them to work in UI7. Not as easy as UI5, but apparently doable. I’m going to work through that and see where I get. Thanks again for the help so far.