Foscam FI9805W

I have a Foscam FI9805W outdoor camera with H264, it has no Pan Tilt and Zoom. I had some trouble setting it up on Vera. Autodect is not working on Vera with this camera, although i tried both enable UPnP and changing the port to 80. Only manually adding the camera proved working for me.

The camera firmware is:
System Firmware Version 1.4.1.5
App Firmware Version 1.14.1.18
Web Version 2.0.1.1

First Try - use plug in to create camera (not working)
First I manually installed the Foscam Plugin. On the Apps Plug in page I used the button create another device. It created a ghost device, which could mot be deleted.
Only option to remove the ghost device = http://<local_Vera_IP>:3480/data_request?id=device&action=delete&device=<device_ID>.
After that I removed the Foscam Plug In.
My conclusion do not use the create device button on the Foscam Plug in.

Second Try - autodetect camera (not working)

I went to Devices -> Add Devices.
I Choose Add UPNP device. The Foscam has a UPNP setting, which is enabled. It however does not show up in this list, although all my other UpnP devices are there.

Third try - Vistacam plugin 1.2 (not working)
On the forum MCVlorin says Foscam plug in is no longer supported, so I tried The VistaCam PT&HD IP Cameras, see http://forum.micasaverde.com/index.php/topic,11990.msg115154.html#msg115154.
This trial ended with a message from the plug that the camera is not supported.

Fourth try - Manually add camera (got it working)

I went to Devices -> Add Devices.
Now I "selected “I want to add an IP Camera”
Then I selected, manually add and had to put in Ip:port
Then on the next screen I choose Foscam
Put in the UrL http://<local_Vera_IP>:port/cgi-bin/CGIProxy.fcgi?cmd=snapPicture&usr=xxxx&pwd=xxxx
Put in username and put in password
I did not get a decent preview :’( and Choose the button Add
The Foscam Plug in was automatically installed (version 2.6),
and a Foscam camera device was created.
After a reload the camera was working ;D.

Missing picture/troubleshooting
When there is no picture you should check the URL under advanced settings it should read /cgi-bin/CGIProxy.fcgi?cmd=snapPicture&usr=xxxx&pwd=xxxx
Internet explorer looses the picture sometimes and always looses it when viewing full screen.
Firefox has no trouble and updates the picture every three seconds also when viewed full screen.

Streaming video (not working)
I also tried to enable streaming video.
I gave in http://<local_Vera_IP>:port/cgi-bin/CGIStream.cgi?cmd=GetMJStream&usr=xxxx&pwd=xxxx to change the steam format of the camera.
I added my MAC adress
On the advanced tab I added:
New service: urn:schemas-upnp-org:device:DigitalSecurityCamera:1
New variable: DirectStreamingURL
New variable: /cgi-bin/CGIStream.cgi?cmd=GetMJStream&usr=xxxx&pwd=xxxx
I restarted Vera. But ended up with getting no stream.
I also tried Da_JoJo I_Foscam98HD.xml and reloaded, checked settings but it gives no stream, see http://forum.micasaverde.com/index.php/topic,11027.msg112616.html#msg112616.
So I gave up on it. The above URL does work when put in a browser, so it has to do with how Vera Works.

Motion detection (not working)
Motion detection on the camera will give an e-mail or upload pictures. The feature of HTTP announcing when an alarm is tripped is not there in the current firmware.
The old models have the function set_alarm.cgi. It contains:
http 0:Disable notifying with http visit on alarm;1:enable
http_url http url when visit on alarm
The new models like the FI9805W with H264 don’t have this function, see http://foscam.us/forum/notify-http-on-alarm-missing-feature-fi9805w-t6760.html.

At least I can not find it in “Foscam IP Camera CGI User Guide-V1.0.4 copy.pdf”, see post http://foscam.us/forum/cgi-api-sdk-for-mjpeg-h-264-camera-t2986.html or download directly http://foscam.us/forum/download/file.php?id=401.
So you can not use this camera as a motion device with its current firmware.

Hello, dear mfp.
After some hours of frustrating try to connect my FI8905W to VeraLite, I’ve tried your fourth try. It differs from my previous try for what concern the url. My previous was http://192.168.1.112:8082/snapshot.jpg?user=xxxx&pwd=xxxx

But both following your guide and my previous try I obtain an unidentified Device as it appears below. Device that I cannot either delete unless I restore the Vera from a backup. Any suggestion?

Thank you very much. Bye from Italy

To delete the device:

http://ip_address:3480/data_request?id=device&action=delete&device=device_id

See below for more details:
http://wiki.micasaverde.com/index.php/Luup_Requests

[quote=“bagbag”]Hello, dear mfp.
After some hours of frustrating try to connect my FI8905W to VeraLite, I’ve tried your fourth try. It differs from my previous try for what concern the url. My previous was http://192.168.1.112:8082/snapshot.jpg?user=xxxx&pwd=xxxx

But both following your guide and my previous try I obtain an unidentified Device as it appears below. Device that I cannot either delete unless I restore the Vera from a backup. Any suggestion?

Thank you very much. Bye from Italy[/quote]

Hi first I advice you to remove your username password from your message. It is not a good idea to post this information.

The command to delete a device was given in the second post ans also explained in my first try. You do not have to use backup and restore to delete a ghost device.

If you follow the manual route a camera device should be created by vera. Under the advanced properties you could enter the correct string to capture pictures. If you have exactly the same camera you could use the string from my firts post only filling in your ip, port number, username and password.

I advice you to reboot your vera afterwards to make sure it load the correct files needed.

WOWWWWWWW, hi there!!!

It works. Yesterday I used the mfp’s “Fourth try” but I forgot everytime to specify “What type of camera is it?” so it didn’t work. Today I repeated the full series of instructions and all its ok. But where mfp says to put in the URL
http://<local_Vera_IP>:port/cgi-bin/CGIProxy.fcgi?cmd=snapPicture&usr=xxxx&pwd=xxxx"
I left the default parameter,
http://<local_Vera_IP>:port//snapshot.cgi
and its all OK.

By the way in the Settings of the cam there is this phrase: Number of seconds to archive the video after the sensor are tripped. This means that there is the capability to record a video and not only to take a picture?
Thank you very much

Bye

Hi bagbag,

It is correct you don’t have to change the url. This post is about the newer Foscam HD camera FI9805W.

You have a FI8905W, this is a non HD camera. On this camera motion detection works. You could better read the standard Foscam IP Camera Plugin thread http://forum.micasaverde.com/index.php/topic,11027.0.html

Thank you very much.

I’ll read it.

I just got a FI9805E and i used the method in “fourth try” above. I’m able to create a camera device, but I cannot get it to display an image.
I entered the MAC address
The URL I used successfully displays an image in a browser
Is there any reason that a FI9805E would be different than a 9805W?

Does anybody have an FI9805E working with Vera?

Thanks.

Finally got it working using these instructions:
http://forum.micasaverde.com/index.php/topic,10599.msg76555.html#msg76555

Leaving out the MAC address seemed to help.

Did you guys get the PTZ working and zoom in and out with FI9805W? I am considering buying two of those but for $200 a pop I want to make sure that PTZ, Motion and IR cut off with on/off/auto will properly work like with my indoor foscams FI9821W.

The referenced link in this thread links to a discussion where it says “tested with Foscams” but doesn’t specify which ones.

Hello, I am trying to get my 9805W foscam working in my vera lite. I am using option 4 as listed above here and use an URL that gives me a nice image in a browser:

http://192.168.1.198:88/cgi-bin/CGIProxy.fcgi?cmd=snapPicture&usr=user&pwd=password.

However, no picture in my vera lite…

settings under advanced:
name: Foscam Camera
device type: urn:schemas-upnp-org:device:DigitalSecurityCamera:2
ip: 192.168.1.198:88
device file: D_DigitalSecurityCamera2.xml
username: user
password: password
url: /cgi-bin/CGIProxy.fcgi?cmd=snapPicture&usr=user&pwd=password

Please help.

I got my FI9805E working now. Yeah! I decided to go with the POE version instead of the wireless version for 2 reasons.
A) One cable to the camera
B) reduce WiFi traffic

Setup:
Foscam FI9805E, POE injector, 25 feet ethernet cable, BlueIris software configured to record on any motion.