Foscam FI8918W Setup instructions UI5

After struggling with trying to setup a Foscam FI8918W and finding bits of information spread out everywhere, I am posting my steps in an effort to help anyone else who may be trying to accomplish this.

  1. Download I_FoscamPTZ.xml from the Foscam support page (under Vera compatible devices>network cameras>foscam pan/tilt)
  2. Unzip the file
  3. Connect to vera in your browser via it’s ip address (i.e.
  4. Go to Apps>install apps>foscam ip camera>install
  5. Go to Apps>develop apps>luup files>upload> browse to your unzipped I_FoscamPTZ.xml file
  6. Click Go
  7. Go to Devices>Add device>add ip camera>manually add>yourcameraip:port (i.e. Do not add http or ://
  8. Camera type = generic ip camera
  9. Image url = yourcameraip:port/snapshot.cgi (i.e. Do not add http or :// (I suspect you also leave out the ip and only enter /snapshot.cgi, but you can put it in for now, I’ll explain below.)
  10. Enter user name and password
  11. Don’t worry about not seeing the camera image, click add
  12. Go to Dashboard>overview>cameras>click on your camera
  13. Advanced>url>/snapshot.cgi (be sure to add the / but make sure there is no ip address in there, take it out if there is. This is why I am thinking you should only enter /snapshot.cgi in the setup wizard…)
  14. advanced>mac>enter your camera’s mac address (found on bottom of your camera) if you want to archive images
  15. advanced>impl_file>I_FoscamPTZ.xml

Hope this helps…

There is also the Foscam plugin in the MiOS Marketplace. Just install the plugin and set the implementation file of the camera to be I_FoscamPTZ.xml.

I am having the same setup. but some how i dont know how the archive works? not sure you have the experience as well.

my Foscam camera able to see picture, pan and tilt without problem. however everytime i do a video recording or schedule picture archive, there is nothing recorded. i wonder how this work?

You have to put the camera’s MAC address in the camera control panel (the wrench button) >> Settings tab >> MAC Address field for archiving to work.

@safmse what Firmware Ver. of UI5 are you using, as I’ve tried the process you referenced many times and it would not work on my Vera 3 Lite running 1.5.346.

I would complete all of the steps you referenced, it would unsuccessfully display the image and I would still “Click Add” but it would never show up in my device menu any where.

The only way I could get the camera to manually add was using the “Apps --> Develop App --> Create Device” option.

@J2Red: I am using 1.5.346. I was having the same issue (kept adding the camera but it would not show up on my dashboard anywhere) until I read somewhere that you need to connect to your Vera unit via it’s IP address, not via (step 3 in my list) Once I did that I was able to add the camera and it showed up.

I too had the Add Camera problem and found that connecting via the IP Address (vs. resolved the issue.

Here’s another great post for resolving Foscam/VeraLite issues:,10599.0.html

Also found on a previous post that downgrading the firmware on this camera to works since later versions of firmware encrypt the username/password.

when I rolled back to the earlier firmware this worked for me.

I tried everything, read several of the threads on here but can’t get my FI8918W to work. It says “Camera requires a valid username and password”. My indoor Foscam cameras work only this one gives me issues.

I fixed it, I used the Foscam plugin and in the URL I did the following:

Instead of having in the URL field only: /snapshot.cgi
I wrote: /snapshot.cgi?user=&pwd=&t="%20name=“refresh”

It doesn’t display a thumnail in Mios but when you go into the device you will see the video feed. It works with the DropBox plugin as well to capture the images.