Firmware v1.7.1028 breaks HikVision running v5.5

I have 4 CCTV setup, all Hikvision, but a mixture of firmware 5.4 and 5.5
The Vera firmware upgrade last night to v1.7.1028 has stopped access to the v5.5 cameras with error “invalid credentials”. The only thing to change is the Vera firmware. They have been working without issue for months.

The cameras are not the ones supported by default rather they were added as “generic” cameras using a URL, which had been pre-tested in the browser.

One other minor issue is that the cameras that are still accessible no longer show a preview picture in the “camera” screen. They will show a picture if you open an individual camera. Before the upgrade there were 4 preview pictures in the camera home screen.

I post this as a warning to other HikVision camera owners and in the hope that someone might have already found the solution. >:(

The issue is the authentication.

Hik v5.5 defaults authentication to digest. v5.4 default is basic.

If you change the v5.5 back to digest/basic (i.e. less secure) then camera all work again without changing anything in Vera.

Quite why Vera has gone from supporting digest or basic (remember it worked before the Vera firmware “upgrade”) is quite bizarre. A bit of step backward as you are now forced to run the camera in a less secure mode for Vera work, when it used to work with digest.

I can also confirm after the firmware upgrade that I am also getting this problem. Dahua cameras set up as generic IP cameras via the URL.

Is there a way to set up the device / URL using digest via an API call (ie like the following URL) if it’s not possible via the GUI?


Hello Guys,

This has been acknowledged and will be addressed through a hotfix, coming this week.

[quote=“Sorin, post:4, topic:199104”]Hello Guys,

This has been acknowledged and will be addressed through a hotfix, coming this week.[/quote]

Although this does not (yet) directly impact me, can I just say from a customer perspective it is great to see something like this being fixed so quickly.

Thank you Tillsy,

It will be part of a few more other hotfixes that have been reported in the meantime.

Thank you! :slight_smile:

The other related issue I have seen is the username and password.
When you add the username and password on the URL they are not restricted to Alpha Numeric characters. If you try and change them via the UI you get an error message. Now the ability to add a new camera with non-alpha numeric, just fails, no error message, I have proved this is the reason. Add a new account to the camera that obeys the rules and all is well.

However, changing accounts on existing cameras does not restore the preview screen. You have to delete and re-add the cameras. This makes no sense.

Still no go for me.
I have a Vera Plus on Version (1.7.1030/1.7.3830/1.7.3831/1.7.3832) and can’t get past the “Test your camera configuration” screen in Vera. I’m trying to add a Hikvision DS-2CD2142FWD-IS with firmware V5.5.0 build 170725. It doesn’t matter what I put in the camera url field, I get a popup asking me for credentials and then I enter them, click OK and the popup comes back. I’ve tried the following with and without populating the Camera Username and Camera Password fields. These urls work in Chrome (after competing the Chrome credentials popup):
On the camera side, on the following screen, Configuration->Network->Advanced->Integration Protocol I’ve enabled “Hikvision-CGI” and changed the Hikvision-CGI Authentication to Digest/Basic and tried with ONVIF enabled and disabled.
Did something change or is this the same bug that was supposed to be hotfixed?

Smartified Home

Hello, gsads,

Yes, addressed this issue, however you still need to create this camera manually instead of adding it through the wizard.
Try the instructions from here :,38475.msg289160.html#msg289160

Thanks for your quick reply.
I have configured many Hikvision cameras both directly and through an NVR in the past without having to install a separate xml file. They all use D_DigitalSecurityCamera2.xml without issue.
The only thing that changed is the Vera firmware and the Hikvision firmware.
This issue likely has to do with authentication, not configuration.

Smartified Home

I have a Vera Plus running v1.7.4001. My Hikvision DS-2CD2042WD-I was working (displaying in Vera app and iOS app) fine, but after upgrading its firmware to v5.5.53_180730 from older firmware v5.3.6_151105, it no longer shows a live view. It just shows the error “Invalid Camera URL.” I am also trying to add another identical camera with no luck.

Is there any way to get this Hikvision camera model to be added and functioning with Vera? Any chance for more broad Hikvision Support in the future?

Hi there,

Actually, we’re adding a few Hikvision cameras as we speak. So I believe this should improve the overall support of the existing Hikvisions as well.

1 Like

Thank you, @Sorin. Would I expect to see those implemented as part of the upcoming firmware release? Looking forward to it!

I don’t think it’s gonna be part of the upcoming beta but I’ll try keeping a short leash on this.
We’ll soon have a bug reporting category on this forum, if this replicates in the upcoming firmware please submit this information there.

Vera Lite 1.7.1040
Vera Edge 1.7.4000

Hikvision: 5.4 and 5.5 on about 6 different models for cameras.
All of the above combinations can be added as a generic camera to Vera!

What you are trying to achieve can be done. I will look in my notes later for the answer. The invalid username / password message just means that you have got the URL wrong.

Hikvison settings:
Configuration > Security > Authentication (set to digest)
Configuration > Security > Security Service (enable ISAPI and HTTP)

On Vera
Vera > Cameras > Choose “other IP Camera”
“Next” X3
“Manually install camera”
Camera Type: “Other IP camera”
URL: http://username:password@IPaddr:port/Streaming/channels/2/picture
Press the test button

As started before this works with a variety of Hikvision 5.4.x and 5.5.x firmware.

Unfortunately, on the current Hikvision firmware I am using there is not an ISAPI or http selection. If I go to System > System Settings > Security > Security Service page there is only a checkbox for “Enable Illegal Login lock” and nothing else. Firmware version is v5.5.53 build 180730