Firmware update 7.0.22 bricked my VeraEdge - any way to recover?

Last night I backed up my VeraEdge controller and started the update procedure. After several minutes, the unit went offline and has not come back.

Old version: 1.7.2931
Attempted new version: 1.7.3014 (UI7 ▾ Software Update ▾ Version 7.0.22 (1.7.963/1.7.3014/1.7.3015/1.7.3016) ▾ August 3, 2017)

The power light is slow-blinking once per second, and from some old documentation ( believe this means the firmware is corrupted. If left alone, the Vera will try to reboot itself every once in a while, but it always reaches the slow-blinking power light state. (I could not find any current documentation for interpreting the LED meaning on the VeraEdge / UI7.)

I have tried power cycling it and using the reset button in various combinations but cannot get it to do anything. It is either stuck on slow blink, or if I hold the reset button while powering on, the power light fast-blinks, internet light goes out, and wifi/zwave/system lights stay on. Seems like I’m interrupting the boot with the reset button - the lights don’t change state, and it is not communicating at all.

Is there a method for re-flashing firmware on these units locally, such as though the USB port, or is this unit simply dead now?

Tried contacting vera support - their page says they have Saturday hours but no answer & no response yet to email inquiry sent last night.

Any help would be appreciated.


FYI for anyone who stumbles across this…

Seems these veraedge units are only recoverable if you can establish TCP/IP communication. I had already worked on that angle considerably before hearing back from support. I was hoping they would have a way of flashing it through USB but he went right to TCP/IP and trying the reset hole.

He tried using the same wiki I’d already found but we could not establish communication.

So basically my vera is a brick thanks to an official firmware update, and I have zwave stuff all over my house that doesn’t work anymore. My options are to buy a new controller or stop using home automation. Fantastic.

Hello James,

Checking on this, you are already in touch with our CC team, and the case is still open.

Yes, and thank you for getting back to me John. It is unfortunate that my veraedge will not be recoverable, but we are on a path to resolution and I appreciate the help.

Is vera going to help you out? That’s crazy a firmware update bricked your devices; vera should make it right with you.

Today i tried to update my Vera3 to the last firmware.
The same symptoms. The brick.

I also tried to update to the latest firmware not knowing the results others have been having and now my VeraEdge controller is continuously going thru a reboot and trying to connect sequence and will not bring up the dashboard. Has anyone found a solution other than buying a new controller

In my case the bricked Vera Edge could not be recovered. Vera Support offered a discount on a new unit so I took the opportunity to upgrade to Vera Plus. Had some hiccups with z-wave on the new controller but support was able to work that out, and all is well on the new unit.

On recovering the bricked Vera - my experience is that if you can’t establish stable, reliable TCP/IP communication to the Vera, then you will not be able to flash it. There does not seem to be an onboard or hardware-based method for flashing firmware (I assume support would have tried working this angle in my case if it were possible).

I’m assuming you did the hard-reset to restore factory settings before trying to establish a link to the device, right?

It’s been a while since I’ve been inside these but does the Edge have an internal serial header you can use?This is way above the “average-user” level, but for those tech enough it may work.

I believe I had to do something similar on one of my Pluses to nurse it back.

if it still shows lights it still can be recovered it

1 Like

como se puede hacer?


Qǐng yòng yīngyǔ