Firewall issues with Ezlo

While trying to get my Ezlo to work I did find out something that could be very significant for all users. There isn’t any documentation that I can find regarding Ports that are used by Ezlo and what communication outside of the network is initiated by the device. I tried enabling UPnP and Turned off GEO blocking temporarily to see if this would fix the issue; It did not help.
I would be grateful if anybody has some knowledge of firewall settings that would allow Ezlo to function in a secure network.

I concur – something besides, “load the android application” would be preferable for a device designed to be an IoT networking workhorse. I can’t see my ezlo plus from anything but my android, (not web or windows store app) and I have zero information to work with, like you. This feels even less complete than the initial Vera Plus release – I I’m just jumping into it in Nov 2021.

Are you using this to access the Web GUI?

https://ezlogic.mios.com/#/login

Looks like Ezlo hubs such as the Ezlo Plus and Ezlo Atom are not currently supported with the Microsoft App store version of the Vera app. Mine all say “Offline”.

I am using the iPhone app. Trying to use Ezlo to manage locks in rental properties. I previously used Vera to do this and it worked great. I need a reliable platform to do this. I have increased network security at the sites and am offering a much better Internet experience for guests. Running with no firewall isn’t an option, nor should it be. There really needs to be clear documentation regarding ports and communication to allow optimized firewall configuration. It may be necessary to set up a VLAN for this. Some of this can be sorted out by doing some testing, but my Ezlo Plus doesn’t work so I can’t do and investigating.

We are on it…

@clawmd

For the iPhone and Android Vera mobile apps to connect to a controller remotely, there is no need to manually open Firewall ports on the router. The app will connect via the MIOS cloud infrastructure / relay servers.

In the Vera app under Settings - Customer Care at the bottom it should say “Connection Status: Relay Connected”.

@clawmd, we will provide the documentation at the nearest time.
Also, we can do a session to go through all of the settings.