Filtrete 3M-50 thermostat...anyone looked at one of these?

I’m probably going to be doomed to get a Carrier Infinity if I want remote access–and it looks like the later units don’t allow non-gateway control. We have a two-stage heat pump with a two-stage gas furnace for aux/emergency heat, and it’s a two-zone system to boot. But these Filtrete guys look cheap, and from what I can tell, don’t require gateway routing for control. Anyone tried to make one wiggle?


Its the same as the 2GIG thermostat and there was a user who was going to try and get one working with both WiFi and Zwave as it has plug in comms modules. See the below thread and perhaps PM the user who was going to try it:

[quote=“strangely, post:2, topic:167422”]Its the same as the 2GIG thermostat and there was a user who was going to try and get one working with both WiFi and Zwave as it has plug in comms modules. See the below thread and perhaps PM the user who was going to try it:[/quote]

There seems to be a fair amount of interest in this thing’s big brother, the CT-80. And it sounds like Radiothermostat is going to publish the entire web-API for it this quarter:

If it had to be web-based and I got good control of my HVAC remotely and don’t have to go through someone’s toll-gate to do it, I’d be pretty pleased.


I tried the Filtrete 3M50 and experienced a many connection issues (both WIFI and Cloud ) to consider it reliable enough for use where remote access is critical (eg - a vacation home). Maybe they will improve it over it time (via firmware upgrades). For now, for a standalone IP thermostat consider buying one of the more established brands( Bayweb, Ecobee, Proliphix).

I had some issues initially when I set it up but I since got a firmware upgrade and it works fine for me via WiFi. I haven’t tried imthe Z-Wave module yet but it supposedly can be used with both WiFi and Z-Wave. They have also released their API doc for http access.

I bought one of these and enabled the Wifi. I got that setup and it updated the firmware and worked fine. I then ordered the Zwave module for $25 and installed that. I had zero problems and it works great. Just plugged it in, followed the directions, and was online and added to the network in minutes. They are both working and active, although the zwave overrides the wifi, which is fine.

My wife called me and asked me to turn the AC on. I had the auto setting to high so it wasn’t turning on. I told her one second, I pulled up iVera, changed the setting to turn the AC on at 73 instead of 78 and BAM it was on and I had a wife who was happy. Of course she told me I was a geek.

Overall I like this thermostat. Pretty simple to use, pretty thin (at least compared to my other one), not that expensive, and has a full auto mode which is great. I hated having to switch between heat and AC…

Could you elaborate?

Could you elaborate?[/quote]

The program within z-wave will override any local or wifi programming. That is one issue I had with this unit - once you install the z-wave usnap module, the only way you can control this thing is through z-wave (even the local programming on the unit itself gets overwritten by the z-wave program. Which is not a negative for most people - but the wife finds it easier to change the settings on the physical unit rather than through vera or any other cloud means. One geek in the family is enough ;D ;D

If you manually set the tstat to be in “hold” mode in the unit itself, does the Z-Wave still override it?

Also, what if you use the Radio Thermostat iPhone app or a web browser over WiFi, and set it to “hold” mode, does Z-Wave still override it, even if you don’t change anything via Z-Wave?

You can still set control the thermostat manually at the unit itself. What the Z-Wave module disables is basically the programming. I am still able to communicate to the unit via the Wifi connection and see everything. In fact when my internet connection went down I ended up getting emails from them saying communication was disrupted to the device.

I did some tests and yes the Wifi can still control it. That doesn’t get disabled. So again from what I have seen, its just the programming capabilities of the device that get turned off when z-wave is setup.

To me this is a good thing, as you setup the controls you want in your home automation then. The auto heat/cool still work also, which is enough for me until I get into more advanced scenes.

That was my expectation, from what I had read; enabling it for Z-Wave disables the internal schedule. Settings changes can be made through any method (local, Z-Wave, Wifi). Thanks for the clarification.

That’s great to hear we can use both Zwave and WiFi. Looks like I’ll be ordering the Z-Wave USNAP module. Thanks.

Does anyone know if this will work with european systems?

Here in the Netherlands we generally dont have integrated HVAC systems, but simply a heatpump providing hot water to radiotors throughout the house (Central Heating, no 24v powersupply, no active cooling).

I saw the unit supports WIFI and toggling between F and C but what puzzles me is:

  1. Can it replace my honeywell Chronotherm III (oldie) in steering my CV
  2. Will the Zwave/Zigbee module support european Zwave frequencies

I can only find it online as a 2Gig CT30 (ships standard with U-snap Zwave module, whereas the Filtrete 3M50 ships standard with U-snap WIFI module)

Anyone able to advise me?

Henk, no idea.

Randman, I can poll successfully. So not sure what the issue is.

[quote=“Haderak, post:14, topic:167422”]Henk, no idea.

Randman, I can poll successfully. So not sure what the issue is.[/quote]


Can you tell us what version of software is on your Vera?

I have Vera 2 with firmware version 1.1.1245 and Z-Wave version 3.2.


I excluded, reincluded, and configured my tstat, all with the Vera 2 about 3 feet away from the tstat. I was able to poll successfully once, but failed the next 6 times that I tried. Changing setpoint works ok. For those who don’t have problems, what versions do you have for Vera and the Z-Wave firmware? I have Vera 2 version 1.1.1245 and latest Z-Wave firmware (3.2).

I have a Vera 2 with 1.1.1245 firmware and using Zwave 2.78.

Maybe something to do with 3.20 versus 2.78. I’ll let the MCV folks who are working on my trouble ticket know in case this gives them a clue.



maybe not directly related but could I use a wifi thermostat and somehow? control it from within the iphone app or the standard mios web interface and still be able to link it with other devices for scenes ?

I’m using vera 1.

many thanks.