Fibaro Roller Shutter 2 (FGRM-222) always show 100% or 0%

i have a FGRM-222 connected to a courtain … everything just works perfekt … including the percentages.

however if i set it to 50% … the courtains do move EXACT to 50%
but on the next poll, the dimming status is set to 100%
it never lasts on any other value as 0 or 100 … any idea what that could be ?

At least, you are able to dim your curtains. I can only perform full opening or closing. Can you tell me please what firmware you have and how did you manage to do the calibration without any error issued by the controller?

its V2.2
the calibration always gave me an error if do it via z-wave
so i did it the old fashion way via tmp button and it also worked via up-down buttons.

the calibration did run just once and it worked perfectly right after that.

dimming works perfectly (i’m actually suprised it went this smooth) … just the problem with aftr the polling …

well its always goes to 100% if its more then 1% set … so its not such a big deal, more a optical thing.

I mean the Vera firmware. I never succeeded with any of the 3 calibration manner…

and i do get the controller error if try calibrate via z-wave … but i have not spend much time in figuring that out.

OK, I’m on the same firmware. So you go through a successful calibration whenever you initiate it with the Fibaro module button, don’t you?
I will retry with this method ASAP. Thank you.

i just tested this.

if i set 29 to HEX 1 or 29 to DEC 1 … the calibration does start. but the UI will return a config error.
because the module will immideatly after the calibation has startet set it back to “0” so vera suspects the parameter has not been set properly.

to avoid that … change 29 to “monitor only” or remove it after the calibration is done.

we use Z-Wave native motors with built-in optical encoders. Precise control and reporting, accuracy 1% for tubular motors, 10% for drapery motors. Totally plug and play with Vera

i dont really know how this relates to a FGRM-222 Configuration issue ?
everyone here appreciate some product advice, but thats just spam …

Zwavemotors has been around on the forum. They are doing no harm by providing an alternative.

  • Garrett

I can attest to this on the drapery motors. They are completely plug and play - and they work great.

I tried the calibration, setting the parameter 29 to 1, but the process fails with a “user configuration failed” message sent by the module a few seconds after. The curtain starts to move and stops 3 seconds after. I changed the parameter to monitor only, but nothing happens.

looks like the calibration does fail somehow … can you operate them manually (by pressing up/down buttons) ?

the calibration will open and close the curtains completely at least once.
sometimes twice to re-messure.

Yes, full closing and opening are working fine, either with the physical buttons or with the UI.
I have 7 of these modules and all of them “work” like this. Maybe the issue is linked with the roller model I have…


just have installed some FGRM 222 - all is working fine.

But you must close the blind control before - this is important.
(Best way would be to close with switch).

Roller Shutter performs the calibration process, completing full cycle - up, down and up again

If it is open (up) - it will not work.


BTW: The error message you can ignore - I think it’s as nullx8 said…


I think I get the same issue, and what I’ve done is just set Poll in the settings to “never” ( 0 ) to workaround the issue.

Regarding the fact you get an error in calibration ( I have exact same error ). I think it’s because of the parameter 29, which is automatically set from 1 to 0 after calibration has started. May be the fact the parameter value is not the one expected by vera the source of the issue ? In my side, i’ve just ignored the error message.

All is working fine, only small issue is that sometime the value shows something like 98% instead of the 100% expected.


The problem is not the error message but the calibration, which is actually failing.
And consequently, I can’t use the dimming function with my roller. For instance, if it is closed and if I set it to 20%, it goes to 100% and fully opens.


I can confirm I have the same problem as the OP. If I set the curtains to 50% after Vera polls the Fibaro Blind module it then shows as 100% in Vera.

I have a VeraLite UI5 version 1.5.622

Regarding the error seen when you add the calibration parameter this is normal and can be ignored. In fact after the calibration routine has completed, you can then remove the parameter 29 from the device options for the device.

See the calibration section of my blog post here for more details.

I might try setting the polling to 0 as suggested.

interesting thread as I have the same issue. Will try the polling to 0 trick, if that also fails, will have to take the wall switches out again (aaargh! :slight_smile: and try to calibrate using the button on the Fibaro module.

I’ve just disabled the polling see here for more info