Fibaro KeyFob

Unfortunately, I am not able to set up the device to operate. Add a device and what’s next? How for example, set direct roller shutter control?

EDIT: All the time I got the message “Waiting for wake up to configure device …” I used the white and green options. I’ve done many times command “Configure node right now” and “Replace failed” - no effect. I replaced the batteries with new ones, the two devices have the same problem.

My keyfob is due to arrive tomorrow - I’ll let you know in a couple of days how I go. :slight_smile:

OK - success!

  • Opened the package, removed the labels, cleaned the battery from sticky residue, closed it all.
  • Went into devices on the Vera (GUI7), searched for ‘keyfob’ and chose the Fibaro (FGKF-601)
  • When ready to include, clicked one of the buttons three times quickly then rested the thing on top of my Vera (past experience with a Fibaro door sensor was it had to be as close as possible to configure reliably)
  • It seemed to add in ok, but then it went into “Waiting for wakeup to configure device”
  • I then found a post where someone was saying that the remote would not stay awake for long enough - you need to put it in learning mode which keeps it awake for longer - this is by holding down circle & minus, then triangle once (green light), then plus. I’m not convinced that’s the case - I think what’s more likely is that a fair amount of data gets transferred initially, and that may take a few goes before it’s complete. I tried it, but later I simply used the circle & plus method (or alternatively the circle & minus, then tap triangle until it goes to white, then plus to confirm. I basically made a minor change to a button, and then saved the change, woke the remote and placed it as quickly as possible on the Vera. Did that a few times and eventually it all came good.

It now accepts changes to the buttons really quickly. On the other hand my battery level has dropped from 75% to 47% in all this, but that is an estimate so I expect it will go up again in a while. Also keep in mind that when making any changes to it - you almost certainly need to place it near/on top of the Vera.

Confusingly the icon at the moment is for the Fibaro Button - the thing that looks like a mushroom.

Once it’s added in properly, you go into the device itself, then “Select scenes for device buttons”. In there you can assign house modes (eg night/day/etc) or a scene (eg turn on all lights) to the buttons. Each button has four possible actions (one, two, or three clicks plus press & hold) - so with six buttons there are 24 different possible commands you can program in. In theory there are another six (by using button combos) but frankly I’m going to be fine with the basic six. I have currently assigned one button for the garage door lock scene (single press to open - it automatically locks after a few seconds) and one button for the front door (press to run the unlock scene, double press for the lock scene).

I did a dozen attempts, still without a positive effect. Keyfobs I put directly on Vera Plus.
What version of device do you have?
My two are FGKF-601 ZW5 v3.2. 04/03/2017

Mine is dated 14/3/2017 but otherwise the same. Like I say, the way I did it was to:

  1. Add it in as a new device - as soon as Vera is waiting to include it then wake the dang keyfob up and place it on the Vera - close to the back/power socket seemed to be best for me.
  2. Once it appears, it may (as it did in my case) say that it is “waiting for wakeup”. No amount of waking it up and placing it on the Vera, or telling the Vera to poll the keyfob every few seconds helped. What did help was:
  3. Go into the new keyfob device, and configure something - eg assign an action for a button. As soon as you hit save, wakeup the keyfob (circle & minus, then tap triangle until it goes to white, then plus to confirm - all as quickly as possible) and put it on the Vera.
  4. Repeat step 3 a few times and eventually (it probably took me six tries) I found it actually finished saving whatever it needed to do and from then on, making a change to the keyfob worked with one go. My only assumption is that with the first synch, Vera overwrites multiple settings - so with this first synch the keyfob goes to sleep before it’s complete so needs to be repeated a few times. When it’s is finally complete it, further updates only change what has actually changed… at least that’s my guess.

All the mucking around also appears to have sucked the life out of the battery - it’s down to 35% now… but will replace that soon and see how long it lasts. I will say - once you do get it working - it’s pretty neat to have, so it’s worth persisting. Good luck! :slight_smile:

Thank you for the advice.

Unfortunately I’m not able to set up my keyfobs.
I applied for a support ticket, maybe I have something wrong with Vera.

[quote=“Sierek, post:6, topic:196919”]Thank you for the advice.

Unfortunately I’m not able to set up my keyfobs.
I applied for a support ticket, maybe I have something wrong with Vera.[/quote]

No problem - hope you manage to get it resolved. Like I said, it did take a while for me to get it to work. I deeply suspect it’s not Vera as such but the keyfob is just tricky to setup. All I can suggest is not giving up, and keep trying.

Still cannot get mine to work, even after following ninkasi’s kind instructions. Anyone else / any ideas?

I managed to configure the device by a “green” option. I had to repeat > 20 times, but 2 m to Vera.

[quote=“Sierek, post:9, topic:196919”]Success!
I managed to configure the device by a “green” option. I had to repeat > 20 times, but 2 m to Vera.[/quote]

Glad to hear it! Definitely a pain to setup (I also have setup a Fibaro door sensor that took a while to do) but is good now it’s finally configured.

I do not have good news. I repeat the procedure for the second device and no effect.
There must be an error in the Vera software. Fibaro Home Center and OpenHub users do not have similar problems.

Yesterday I made> 100 attempts, no effect. The battery dropped from 100% to 25%
Today’s first attempt - success! I used “green” option, 2m distance from Vera.

It follows that acceptance of the remote command after waking is completely accidental.

Glad to hear it’s worked for you now as well!

My experience - a few weeks down the track - is that my original battery went to 35% over the time spent setting it up and never recovered. I replaced with a fresh battery and it went to 100% and is now down to 85%. I’ve changed the device settings for “Wakeup interval (seconds):” to 0, and same for “Poll this node at most once every” to reduce strain on the battery. If it can last for a year, that would be good enough. The device can also be set with a lock mode, but I personally think that would be a pain to always have to unlock before using. I generally don’t think the buttons will be pressed accidentally in my pocket so battery loss there should be minimal.

In general the remote is working well, although I would temper that with it not working immediately sometimes - in other words, I’ll come home and press the button and nothing will happen the first time although I am in range of my network. I might need to try a couple of times before it works. I’m going to monitor it for a while, but if this is consistent (ie it’s consistently unreliable) then I don’t think I’ll bother getting one for my wife as she has minimal tolerance for this sort of thing.

It would also nice if it could control devices directly eg have the plus/minus keys dim or brighten the current selected light… rather than having to use scenes. Not a biggie for my purposes though - my main use is for it to be with my car keys, and using it to open/close the garage and/or lock/unlock doors

…and a further update. With the latest update to UI7 the icon has changed to a remote control. So that’s nice. On the flip side have found the battery definitely is going flat quickly. The issue (I suspect) is that the buttons are very light touch and are being activated accidentally - and when this is done away from the house the remote possibly even tries a few times to send, without luck, the command(s). I will need to setup the lock combo.

The other minor issue is that on returning to the house it can take time for it to reconnect to the network - what this means is that I will turn up at the house and press a button to unlock the door and nothing will happen. Try again, and still nothing. One more time and bingo it works. What this means is that, combined with needing to set an unlock sequence on the remote to save battery life, the wife acceptance factor will be low with this. Shame.

Is the pairing now easier with latest firmware.

Hi Everyone,

I have three Veras Edge with 1.7.3231 firmware and one FGKF-601 (Fibaro Keyfob). No, pairing is a hell. I drained battery, and still, it looks like hell to force to work with any of my Vera devices. Keyfob looks like really handy device, only if I could force it to work… :frowning:

I was wondering if anyone had any luck getting the fob to work.
Mine is stuck at wakeup.

[quote=“basa, post:16, topic:196919”]I was wondering if anyone had any luck getting the fob to work.
Mine is stuck at wakeup.[/quote]

You will see in this thread a few people have managed to get theirs to work. Eventually. It just takes a lot of patience with multiple attempts.

I think the main point here is , weather this is a bug or feature in a suported device?

I think the main point here is , weather this is a bug or feature in a suported device?[/quote]

My guess is that it is better supported in a full Fibaro “Home Center” system. If you are using Vera, well it’s a little trickier to get it to work. I don’t blame Vera - I suspect this is a topic that should be raised with Fibaro who in turn may be able to identify why it may be so hard to synch up…

Guys, any luck in making it working? I’ve drained the battery to 0 and failed. Is there any support from Vera Sprt team on that? Did anyone raised a ticket?